Opracowanio na podstawie materiaw kursu CCNA Adresowanie IP

































- Slides: 33
Opracowanio na podstawie materiałów kursu CCNA Adresowanie IP Wykład: Zaawansowane sieci komputerowe Prowadzący: dr inż. Sławomir Nowak
Model ISO/OSI – warstwa sieci
Model ISO/OSI a model TCP/IP
protokoły TCP/IP
Warstwa INTERNET w modelu TCP/IP ADRES IP • Posiada go każdy interfejs sieciowy • Każdy adres IP jest UNIKALNY w całej sieci (nie jest dopuszczalne duplikowanie adresów) Fizyczny adres MAC hosta ma znaczenie tylko lokalne, ponieważ identyfikuje hosta w sieci lokalnej.
Adres hierarchiczny Jan Kowalski Ul. Słoneczna 15 22 -712 Ciasne Majty Poland Adres nie-hierarchiczny: pokój 2123439785764345
Adres IP – układ hierarchiczny A, B – podsieci 1, 2, 3, 4. . . – numery hostów w podsieci
Adres IP Sieciowy adres IP – hierarchiczny, 32 bitowy, binarny, logiczny, reprezentowany przez cztery liczby dziesiętne, zwane oktetami. Każdy oktet reprezentuje jedną, 8 bitową liczbę binarną. Przyjmuje więc wartości od 0 do 255 Mamy więc notację np. 118. 57. 251. 26 Część adresu to numer podsieci, część to numer hosta. Jak rozpoznać, która jest która?
Adres IP – klasy adresów Adresy w Internecie podzielone są na KLASY adresów:
Adres IP – klasy adresów Pierwszy oktet adresu zapisany binarnie identyfikuje Klasę: 1. 176. 186. 14. 112: 176 = 10110000 - B 2. 197. 76. 210. 100: 197 = 11000101 - C 3. 129. 118. 32. 189: 129 = 10000001 - B 4. 113. 26. 172. 106: 113 = 01110001 - A 5. 201. 200. 100. 90: 201 = 11001001 - C 6. 47. 145. 148. 211: 47 = 00101111 - A
Adres IP – klasy adresów Aby określić klasę, należy patrzeć tylko na pierwszą liczbę: 1. 172. 168. 46. 194: 172 - B 2. 118. 57. 251. 26: 118 - A 3. 64. 118. 32. 189: 64 - A 4. 200. 52. 157. 156: 200 - C 5. 191. 45. 133. 190: 191 - B 6. 225. 117. 89: 225 - D 7. 126. 31. 111. 35: 126 - A 8. 192. 250. 16. 81: 192 - C 9. 223. 1. 199. 201: 223 - C 10. 145. 209. 40. 12: 145 - B
Adres IP – klasy adresów Część adresu to numer podsieci, część to numer hosta. Jak rozpoznać, która jest która?
Adres IP – adresy zarezerwowane Adres sieci – bity hosta ustawione na 0
Adres IP – adresy zarezerwowane Adres rozgłoszeniowy – bity hosta ustawione na 1
Adres IP – unikatowość adresów w Internecie Adres unikatowe – aby zapewnić stabilność sieci przy przekazywaniu danych przez rutery. Adresy IP przydzielane są globalnie przez organizację IANA (Internet Assigned Numbers Authority). W związku z gwałtownym rozwojem Internetu publicznie dostępne adresy IP zaczęły się wyczerpywać. Jak rozwiązać ten problem?
Adres IP – unikatowość adresów w Internecie Przyjęte lub proponowane rozwiązania globalnie: • adresy prywatne (RFC 1918) wraz z NAT • bezklasowy routing międzydomenowy CIDR (classless interdomain routing); • IPv 6;
Adres IP – unikatowość adresów w Internecie Adresy prywatne • Prywatnych adresów IP można używać razem z adresami publicznymi; • Podłączenie do Internetu sieci z adresami prywatnymi wymaga translacji adresów NAT.
NAT – translacja adresów sieciowych Konwerter NAT • • • W podsieci każdy komputer ma unikatowy adres; Każdy pakiet opuszczający firmę przechodzi przez tzw. konwerter NAT; Konwerter NAT przekształca wewnętrzny adres IP na unikatowy adres IP firmy Adres wewnętrzny IP odwzorowywany jest w postaci numeru portu źródłowego protokołu TCI lub UDP; Numer ten zapisywany jest indeksem w tablicy translacji NAT. W tablicy tej można odnaleźć wewnętrzny adres IP. Wady: Zmienia charakter sieci na „połączeniowy” Narusza zasadę warstwowości protokołów. Narusza zasadę „IP jednoznacznie identyfikuje hosta”.
CIDR – bezklasowy routing międzydomenowy (Classless Inter. Domain Routing), RFC 1519 • W 1987 roku wizjonerzy przewidywali wzrost Internetu do nawet 100 000 sieci. Nikt nie dawał im wiary. . . • 100 000 sieć została podłączona w roku 1996! • • 256 hostów klasy C – za mało! 65536 hostów klasy B – za dużo! CIDR – przydzielanie pozostałych w zasobach adresów IP w blokach o różnych wielkościach, bez zwracania uwagi na klasy Pojawiło się pojęcie maski podsieci – określającej ile bitów w adresie IP przypada na adres sieci, a ile na adres hosta. Można grupować adresy podczas routingu.
IP v. 6 (RFC 2460 – 2466) Ogromna przestrzeń adresowa!!! • Protokół IP v. 6 wykorzystuje adres w postaci liczby 128 bitowej (w porównaniu do 32 bitów dla IP v. 4); Adresów jest 7 * 10 23 na metr kwadratowy Ziemi !!!! • Inne: uproszczenie nagłówka, lepsza obsługa opcji nagłówka, zwiększone bezpieczeństwo, brak sumy kontrolnej nagłówka. Po latach badań i rozwoju protokół IPv 6 jest powoli wprowadzany w wybranych sieciach. Być może w przyszłości protokół IPv 6 zastąpi protokół IPv 4 jako podstawowy protokół Internetu.
Podział na podsieci i maski podsieci • W ramach całego Internetu podział na podsieci zapobiega wyczerpaniu się dostępnej puli adresów IP; • Dla administratora systemu podział na podsieci jest sposobem na wydzielenie i zaadresowanie oddzielnych części sieci LAN; Podział na podsieci oznacza wykorzystanie maski podsieci do podzielenia sieci na mniejsze, bardziej efektywne i łatwiejsze w zarządzaniu segmenty. Aby utworzyć adres podsieci, administrator pożycza bity z pola hosta i przeznacza je na pole podsieci.
Podział na podsieci i maski podsieci Przykładowo dla adresu sieci klasy C 200. 52. 157. 0 Maska 255. 192 daje 11111111. 11000000 Mamy więc dwie!! możliwe podsieci: podsieć 10 xxxxxx podsieć 01 xxxxxx UWAGA: nie można wykorzystać adresów podsieci 11 xxxxxx – bo jest to adres rozgłoszeniowy 00 xxxxxx – bo jest to adres sieci nadrzędnej
Podział na podsieci i maski podsieci
Przypisywanie adresów IP dla hosta • Statyczne • Dynamiczne • Statyczne: adres IP wprowadzany jest ręcznie przez administratora. Sprawdza się w małych sieciach.
Przypisywanie adresów IP dla hosta • Statyczne
Przypisywanie adresów IP dla hosta • Dynamiczne • Protokół RARP (Reverse Address Resolution Protocol) • Podobny w działaniu do protokołu ARP; • Pozwala uzyskać adres IP w sieci lokalnej dla znanego adresu MAC; • Żądanie jest generowane (rozgłaszane w sieci lokalnej) przez host, który chce poznać swój adres IP • Odpowiedzi z adresem IP udziela tzw. Serwer RARP.
Przypisywanie adresów IP dla hosta • Dynamiczne • Protokół BOOTP (Bootstrap Protocol) • W przeciwieństwie do protokołu RARP pakiety BOOTP mogą zawierać nie tylko adres IP, ale i adres routera, adres serwera oraz informacje zależne od producenta sprzętu; • Nie obsługuje dynamicznego przydzielania adresów; • Przechowuje stały profil dla każdego urządzenia przyłączonego do sieci; • Obecnie niewykorzystywany.
Przypisywanie adresów IP dla hosta • Dynamiczne • DHCP (Dynamic Host Configuration Protocol) • Następca protokołu BOOTP; • Wystarczy zdefiniowa zakres możliwych adresów na serwerze DHCP; • Jest obecnie powszechnie wykorzystywany.
Przypisywanie adresów IP dla hosta
Adresowanie IP a LAN – protokół ARP • W komunikacji w ramach LAN datagram zawiera zarówno adres MAC jak i adres IP urządzenia docelowego; • TCP/IP zawiera protokół o nazwie ARP (Address Resolution Protocol). Host automatycznie pobiera adres MAC dla transmisji lokalnych lub generuje żądanie ARP. Podręczne tablice ARP przechowywane są lokalnie; • Komunikacja pomiędzy segmentami sieci LAN wymaga adresu IP i MAC zarówno urządzenia docelowego, jak i pośredniczącego urządzenia routującego. TCP/IP zawiera protokół proxy ARP: dostarcza adres MAC urządzenia pośredniczącego w transmisji z sieci LAN. Inną możliwością jest konfiguracja bramy domyślnej.
Adresowanie IP a LAN – protokół ARP Początkowo w tablicy lokalnej ARP może nie być żadnych wpisów. Wystarczy jednak wykonać kilka poleceń ping z adresami różnych hostów, a następnie wykonać arp -a
Podsumowanie i uwagi • Adresowanie IP zapewnia każdemu urządzeniu w Internecie unikatowy identyfikator. • Aby komunikować się w Internecie, komputer musi mieć adres IP. • Klasy adresów IP określają logiczny podział przestrzeni adresowej, którego celem jest sprostanie wymaganiom sieci o różnych rozmiarach. • Podział na podsieci jest używany do dzielenia sieci na mniejsze części. • Adresy zarezerwowane spełniają w adresowaniu IP specjalną rolę i nie można ich używać do innych celów.
Podsumowanie i uwagi – c. d. • Zadaniem maski podsieci jest określenie części adresu IP identyfikujących sieć i hosta. • Adres IP można skonfigurować statycznie lub dynamicznie. • Dynamiczny adres IP można przypisać za pomocą protokołu RARP, BOOTP lub DHCP. • Protokoły ARP i proxy ARP mogą być używane do rozwiązania problemów z odwzorowywaniem adresów.

































