Interdomain Routing Monitoring and Modeling Timothy G Griffin









































- Slides: 41
Interdomain Routing: Monitoring and Modeling Timothy G. Griffin Computer Laboratory University of Cambridge timothy. griffin@cl. cam. ac. uk http: //www. cl. cam. ac. uk/~tgg 22/ SRCCS Workshop Seoul, Korea January 11 2005
Outline • Routing & Forwarding • BGP = Border Gateway Protocol • PUBLIC BGP data sources – High volume – Rich Semantics – High Variability • Examples • A Challenge
Architecture of Dynamic Routing IGP EGP (= BGP) AS 1 IGP = Interior Gateway Protocol Metric based: OSPF, IS-IS, RIP, EIGRP (cisco) IGP AS 2 EGP = Exterior Gateway Protocol Policy based: BGP The Routing Domain of BGP is the entire Internet
Technology of Distributed Routing Link State • Topology information is flooded within the routing domain • Best end-to-end paths are computed locally at each router. • Best end-to-end paths determine next-hops. • Based on minimizing some notion of distance • Works only if policy is shared and uniform • Examples: OSPF, IS-IS Vectoring • Each router knows little about network topology • Only best next-hops are chosen by each router for each destination network. • Best end-to-end paths result from composition of all next-hop choices • Does not require any notion of distance • Does not require uniform policies at all routers • Examples: RIP, BGP
The Gang of Four Link State IGP EGP OSPF IS-IS Vectoring RIP BGP
Forwarding vs. Routing BGP process BGP tables OSPF process OSPF tables RIP process RIP tables IP Forwarding Table Router
How Many ASNs are Being Used Today? Jan 11, 2005 Thanks to Geoff Huston: http: //www. potaroo. net/
Some Korean ASNs See http: //www. cidr-report. org/autnums. html 1237 1704 1781 3559 3757 3825 4040 4060 4666 4766 4861 5051 7557 7558 7562 7563 7564 7620 9275 9452 9454 9455 9488 9489 9494 9521 9526 9581 9640 9641 9643 9698 9699 9700 9763 9766 9847 9857 9864 9884 9945 9949 9959 9964 9967 9970 == == == == == == == == == == == == == KREONET-AS-KR Korea Institute of Science and Technology Information KAIST-SEOUL-AS-KR Korea Advanced Institute of Science and Technology KAIST-DAEJEON-AS-KR Korea Advanced Institute of Science and Technology KORNET-AS-KR Korea Telecom ERX-TRAN Korea Telecomm Research Laboratory ERX-HANANET Korea Telecomm Research Center ERX-KORNET-PS Korea Telecomm Research Center ERX-KORNET-DJ Korea Telecomm Research Center HNCNET-AS We are new Internet Service Provider in South Korea. KIX Korea Internet Exchange for "96 World Internet Exposition GLOBAL-IP-KOREA-AS-AP Global One Communications KOLNET-AS-KR Korea Telecom Hitel KTNET-AS Korea Trade International Association KBS-AS Korean Broadcasting System KOTISNET-AS Korea International Trade Assocication(KITA) KII-AS Korea Internet Infrastructure KAERINET-AS Korea Atomic Energy Research Institute IASIAWORKS-AS i. Asia. Works Korea, Ltd APAN-KR-AS Asia Pacific Advanced Network Korea(APAN-KR) Consortium KRICTNET-AS-KR Korea Research Institute of Chemical Technology KUNET-AS Korea University SUPERNET-AS Korea Telecom ATM service EDUNET-AS Korea Education & Research Information Service SNU-AS-KR Seoul National University KARINET-AS Korea Aerospace Research Institute KOSINET-AS Korea open system information network KININET-AS Korea INstitute of Industry & Technology Information KOSCOM-AS KOREA SECURITIES COMPUTER CORP. HKTI-KR-AS-AP Cable & Wireless Internet Services (Korea) Limited I-KOREA-AS Internet-Korea KITEL-AS Korea Information&TELecommunication system CO. SIGNGATE-AS Korea Information Certificate Authority KFTCCA-AS Korea Financial Telecommunications & Clearings Institute KDIC Korea Deposit Insurance Corporation KFB-AS Korea First Bank KRNIC-AS-KR Korea Network Information Center KTIS-AS Korea Telecom Infomation System Group AFFIS-AS Korea Information Center for Agriculture, Forestry KSE-AS KOREA STOCK EXCHANGE KSFC-AS-KR Korea Securities Finance Corporation KOGAS-AS-KR KOREA GAS CORPORATION KSDNET-AS-KR Korea Securities Depository SINGTEL-KR Sing. Tel Korea Limited KCACBACKUP-AS-KR Korea Information Security Agency HOSEO-AS HOSEO UNIVERSITY KOREASTOCKEXCHANGE-AS KOREA STOCK EXCHANGE PERSNET Korea Telecom Freetel KEBCS-AS Korea Exchange Bank of Credit Services KUT-AS Korea University of Technology and Education 9971 == MULTINET-AS KOREA MULTINET INC. 9974 == SIGNKOREA-AS KOREA SECURITIES COMPUTER CORP. BUNDANG CENTER 9976 == ICNDP-AS-KR Korea Cable TV Nam. Incheon Broadcasting. co. ltd 9979 == KEB-AS KOREA EXCHANGE BANK 10050 == EPOSTBANK-AS-KR Ministry of Information and Communication Republic of Korea 10055 == KORAIL-AS-KR Korean National Railroad Administration 10059 == KIDC-AS Korea Internet Data Center 18161 == HANYANG-WOMENS-UNIV-AS-AP Hanyang Womens college in 17 Hangdang-dong Seongdong-Ku, S 10063 == KMA-AS Korea Meteorological Administration 18163 == JINJU-UNIV-AS-AP Jinju National University in 150 chilamdong Jinju, Gyeongnam, Korea 10064 == INFOSECKOREA-AS Infosec. Korea, Inc. 18169 == KOREA-CULTURE-CONTENT-AGENCY-AS-AP KOREA CULTURE & CONTENT AGENCY in Seoul 18309 == KOVAN-AS-KR Korea VAn Service Co. LTD 10064 == INFOSECKOREA-AS Infosec. Korea, Inc. 18310 == VITSSEN-AS-KR Korea cable television Anyang Broadcasting Corporation 10070 == KRISS-AS Korea Research Institute of Standards and Science 18312 == KAMCO-AS-KR Korea Asset Management COrporation 10073 == KNOU-AS Korea National Open University 18325 == KORCHRISTUNIV 160 -AS-KR Korea Christian University 10088 == KWANGWOON-UNIV-AS-AP KWANGWOON University in Seoul, Korea 18340 == KORAC-HEALTHSCI 1 -AS-KR College of Health Sciences, Korea University 23552 == KORNU-AS-KR Korea Nazarene University 10157 == YAHOO-AS-KR Yahoo! Korea, Corp. 23560 == METLIFEKOREA-AS-KR Met. Life Korea 10158 == CIGNAL-AS Cignal Global Communications Korea, Inc. 23560 == METLIFEKOREA-AS-KR Met. Life Korea 10161 == KITC-AS Korea Investment Trust Management & Securities Co. , LTD 23664 == MONTESSORI-AS-AP Montessori Korea in Seoul, Korea 10162 == KIT-AS Korea Internet Telecom 23668 == KOREA-POLYTECHNIC-UNIV-AS-AP KOREA POLYTECHNIC University 23714 == KEIMYUNG-UNIV-AS-AP KEIMYUNG University in Daegu, Korea 10165 == CUSTOMS-AS-KR KOREA CUSTOMS SERVICE 23716 == CHANGWON_COLLEGE-UNIV-AS-AP CHANGWON_COLLEGE in Changwon-City, Kengsangnam-Do, K 10166 == KOWANET-AS-KR Korea Water Resources Corporation 23743 == FAREAST-UNIV-AS-AP FAREAST University, Korea 10168 == NSKFB-AS Korea First Bank 23759 == KMMH-UNIV-AS-AP KEIMYUNG COLLEGE, Korea 10170 == BOKNET-AS The Bank of Korea 23908 == IIAC-AS-AP Incheon international Airport Corp in Incheon, Korea 23971 == CHUGYE-UNIV-AS-AP CHUGYE University For The Arts in Seoul, Korea 10178 == KBTUS-AS Korea Baptist Theological University/Seminary 23972 == ASANMED-AS-AP ASAN Medical Center in Seoul, Korea 10183 == NUCH-AS-KR The Korean National University of Cultural Heritage 23975 == YC-UNIV-AS-AP yonam institute of digital technology in jinju, South Korea 10184 == KFCCC-AS Korean Federation of Community Credit Cooperatives 23980 == YOUNGNAM-UNIV-AS-AP YOUNGNAM University in Gyeongsangbuk-do, Korea 10187 == KISDI-AS-KR Korea Information Society Developement Institute 23981 == SWC-UNIV-AS-AP Suwon Women. s College in Kyonggi-Do, Korea 23982 == HANKYONG-UNIV-AS-AP HANKYONG National University in Ansung, Kyonggi-do, Korea 10194 == KOREAFUTURES-AS-KR koreafutures inc 23983 == DAEJEON-UNIV-AS-AP Daejeon University in Daejeon , Korea 10194 == KOREAFUTURES-AS-KR koreafutures inc 23989 == DONGGUK-UNIV-AS-AP DONGGUK University in Kyongju Gyeongsangbuk-do Korea 10201 == CWNK-KR-AS-AP Cable & Wireless Network Korea. 29864 == KOREA-DAILY Korean Central Daily News 17576 == KOSEF-AS-KR Korea Science and Engineering Foundation 29864 == KOREA-DAILY Korean Central Daily News 17579 == KREONET 2 -AS-KR Korea Institute of Science and Technology Information 17585 == PPS-AS-KR Public Procurement Service The Republic of Korea 17590 == KGPC-AS-KR Korea Game Promotion Center 17591 == KRFNET-AS-KR korea Research Foundation 17592 == IBK-AS-KR Industrial Bank of Korea 17595 == KINSNET-AS-KR Korea Institute of Nuclear Safety 17601 == KCGF-AS-KR KOREA CREDIT GUARANTEE FUND 17605 == WCOM-AS-KR MCI Worldcom Korea 17837 == KCP-AS-KR Korea Cyber Payment Inc 17840 == KOREACERT-AS-KR KECA, Inc. 17852 == KOREALIFE-AS-KR KOREALIFE 17865 == SCOURT-AS-KR Supreme Court of Korea 17866 == KISTNET-AS-KR Korea Institute of Science and Technology 17867 == KBINET-AS-KR KOREA BANKING INSTITUTE 17875 == KSDA-AS-KR The Korea Securities Dealers Association 18023 == KOREAMARITIME-UNIV-AS-AP Korea Maritime University in Young. Do. Gu Dong. Sam. Dong Busan, Korea 18026 == CHEJU-UNIV-AS-AP CHEJU University in 1, Ara 1(il)-dong, jeju-si JEJU-DO Korea 18028 == GYEONGSANG-UNIV-AS-AP GYEONGSNAG National University in 900 Gazwadong, JINJU, Korea 18030 == DONGYANG-UNIV-AS-AP Dongyang Technical College in 62 -160 Kochuk-dong, Kuro-gu, Seoul, Korea 18031 == SANGMYUNG-UNIV-AS-AP Sang Myung University in 7 Hongji-Dong Jongro-Gu, Seoul Korea 18034 == KANGNUNG-UNIV-AS-AP KANGNUNG University in jibyeundong 123 Kangnung, Kangwon, Korea 18035 == HANSEO-UNIV-AS-AP HANSEO University in 360, Daegok-Ri, Seosan-Si, Chung. Nam, Korea 18038 == KNUE-UNIV-AS-AP Korea National University of Education 18157 == CHUNGJU-UNIV-AS-AP CHUNGJU University in 123 Keomdanri Iryoumyun Chungsi, Chungbuk, korea 18158 == CHUNGBUK-UNIV-AS-AP Chungbuk University in 48 Gasindong Hungduckku Chengju, Chungbuk, Korea
How Many Prefixes are Being Routed Today? Jan 11, 2005 From AS 4637: Reach Network
What do I Mean by “BGP” ? BGP = + RFC 1771 “optional” extensions RFC 1997 (communities) RFC 2439 (damping) RFC 2796 (reflection) RFC 3065 (confederation) … + routing policy configuration languages (vendor-specific) + Current Best Practices in Management of Interdomain Routing
Four Types of BGP Messages • Open : Establish a peering session. • Keep Alive : Handshake at regular intervals. • Notification : Shuts down a peering session. • Update : Announcing new routes or withdrawing previously announced routes. announcement = prefix + attributes values 11
BGP Attributes Value ----1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16. . . 255 Code ----------------ORIGIN AS_PATH NEXT_HOP MULTI_EXIT_DISC LOCAL_PREF ATOMIC_AGGREGATE AGGREGATOR COMMUNITY ORIGINATOR_ID CLUSTER_LIST DPA ADVERTISER RCID_PATH / CLUSTER_ID MP_REACH_NLRI MP_UNREACH_NLRI EXTENDED COMMUNITIES Reference ----[RFC 1771] [RFC 1771] [RFC 1997] [RFC 2796] [Chen] [RFC 1863] [RFC 2283] [Rosen] Most important attributes reserved for development From IANA: http: //www. iana. org/assignments/bgp-parameters Not all attributes need to be present in every announcement
BGP Route Processing Open ended programming. Constrained only by vendor configuration language Receive Apply Policy = filter routes & BGP Updates tweak attributes Apply Import Policies Based on Attribute Values Best Route Selection Best Route Table Apply Policy = filter routes & tweak attributes Transmit BGP Updates Apply Export Policies Install forwarding Entries for best Routes. IP Forwarding Table 13
Routing Example 2 Thanks to Han Zheng
“Strange” Round Trip Times Moscow State U B Intel Berkeley A HP Palo Alto B 201 ms 4 ms A 257 ms C C
… and its routing RBNet C eless r i W & Cable CAIS nica Telefo B A AT&T t Ne e v o b A
Data Collection: GNU Zebra router BGP sessions Zebra Box router BGP sessions router
Reading the Data www. mrtd. net route_btoa translates binary to ASCII
RIPE Routing Information Service http: //www. ripe. net/ris rrc 00. ripe. net rrc 01. ripe. net rrc 02. ripe. net rrc 03. ripe. net rrc 04. ripe. net rrc 05. ripe. net rrc 06. ripe. net rrc 07. ripe. net rrc 08. ripe. net rrc 09. ripe. net rrc 10. ripe. net rrc 11. ripe. net rrc 12. ripe. net at RIPE NCC, Amsterdam, collects default free routing updates from peers. From October 1999. at LINX, London. Collects route updates announced by LINX members. From July 2000. at SFINX, Paris. Collects route updates announced by SFINX members. From March 2001. at AMS-IX, Amsterdam. Collects route updates announced by AMS-IX members. From January 2001. at CIXP, Geneva. Collects route updates announced by CIXP members. From April 2001. at VIX, Vienna. Collects route updates announced by VIX members. From June 2001. at Otemachi, Japan. Collects route updates announced by JPIX members. From August 2001. in Stockholm, Sweden. Collects route updates announced by the NETNOD members. From April 2002. at San Jose (CA), USA. Collects route updates announced by the MAE-WEST members. From May 2002. at Zurich, Switzerland. Collected route updates announced by the TIX members. From May 2003 to until early Feb at Milan, Italy. Collects route updates announced by the MIX members. From Nov 2003. at New York (NY), USA. Collects route updates announced by the NYIIX members. From Feb 2004. at Frankfurt, Germany. Collects route updates announced by the DE-CIX members. From Jul 2004.
University of Oregon Route Views Project http: //antc. uoregon. edu/route-views Participants AOL (No. Va) 66. 185. 128. 48 through AS 1668 APAN (tpr 2 -tokyo) 203. 181. 248. 242 through AS 7660 ATT (SFO) 192. 205. 31. 33 through AS 7018 Abilene (Indiana) 198. 32. 8. 252 through AS 11537 Accretive (PAO) 207. 246. 129. 6 through AS 11608 Accretive (SEA) 207. 246. 129. 14 through AS 11608 Army Research Lab 192. 12. 65. 1 through AS 13 Broadwing (ADDS) 216. 140. 14. 186 through AS 6395 Broadwing (MAE-EAST) 216. 140. 8. 63 through AS 6395 Broadwing (MAE-WEST) 216. 140. 2. 62 through AS 6395 C&W USA (Santa Clara) 208. 172. 146. 2 through AS 3561 COMindico (AU) 203. 194. 0. 5 through AS 9942 Carrier 1 (NYC) 212. 4. 193. 253 through AS 8918 EBONE (EU) 192. 121. 154. 25 through AS 1755 ELI (MAE-EAST) 208. 186. 154. 36 through AS 5650 ELI (MAE-WEST) 208. 186. 154. 35 through AS 5650 EPOCH (PAIX) 155. 229. 0. 36 through AS 4565 ESnet (GA) 134. 55. 20. 229 through AS 293 France Telecom (NYC) 193. 251. 128. 22 through AS 5511 GLOBIX (LINX) 195. 66. 224. 82 through AS 4513 GLOBIX (New York) 209. 10. 12. 28 through AS 4513 GLOBIX (Chicago) 209. 10. 125 through AS 4513 GLOBIX (Palo Alto) 209. 10. 12. 156 through AS 4513 GT Group Tel (Toronto, CA) 216. 18. 63. 137 through AS 6539 Genuity (Palo Alto) 4. 0. 4. 90 through AS 1 Global. Crossing (PAIX) 208. 51. 113. 253 through AS 3549 IAGnet (Chicago) 204. 42. 253 through AS 267 IIJ (Japan) 202. 232. 1. 91 through AS 2497 ISC (Palo Alto) 204. 152. 184. 126 through AS 3557 Intermedia (MAE-EAST) 198. 32. 187. 23 through AS 2548 JINX (Johannesburg) 196. 7. 106. 72 through AS 2905 Jippii (ESPANIX/Spain) 62. 164. 11. 10 through AS 8782 LINX (London) 194. 68. 130. 254 through AS 5459 Level 3 (Denver) 209. 244. 2. 115 through AS 3356 MFN/Above. Net (MAE-WEST) 207. 126. 96. 1 through AS 6461 MFS/MAE-lab (San Jose) 204. 29. 239. 1 through AS 6066 Nacamar (Frankfurt) 213. 200. 87. 254 through AS 3257 Netrail (MAE-WEST) 205. 215. 45. 50 through AS 4006 Port 80 (Stockholm) 217. 75. 96. 60 through AS 16150 RCN (PAIX) 207. 172. 6. 221 through AS 6079 RCN (VA) 207. 172. 6. 173 through AS 6079 RIPE NCC (Amsterdam) 193. 0. 0. 56 through AS 3333 STARTAP (Chicago) 206. 220. 240. 95 through AS 10764 Sprint (Stockton) 144. 228. 241. 81 through AS 1239 Telefonica (New York) 213. 140. 32. 144 through AS 12956 Teleglobe (London, UK) 195. 219. 96. 239 through AS 8297 Teleglobe (PAIX) 207. 45. 223. 244 through AS 6453 Telstra (Sydney, AU) 203. 62. 252. 26 through AS 1221 TELUS (Toronto) 66. 203. 205. 62 through AS 852 Touch. America () 157. 130. 182. 254 through AS 19092 Verio () 129. 250. 0. 11 through AS 2914 Verio () 129. 250. 0. 6 through AS 2914 WCI Cable (Hillboro, OR) 209. 161. 175. 4 through AS 14608 Williams (San Francisco) 64. 200. 199. 3 through AS 7911 Williams (San Francisco) 64. 200. 199. 4 through AS 7911 X 0 (Bay Area) 205. 158. 2. 126 through AS 2828 Zocalo (Berkeley) 157. 22. 9. 7 through AS 715 blackrose. org (Ann Arbor) 204. 212. 44. 131 through AS 234 net. INS (Des Moines) 167. 142. 3. 6 through AS 5056 Many streams since 2001
SNU Routes SNU == AS 9488 TABLE_DUMP|1103846404|B|195. 66. 224. 138|2914| 147. 46. 0. 0/16|2914 4766 9488|IGP|195. 66. 224. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846404|B|195. 66. 226. 138|2914|147. 46. 0. 0/16|2914 4766 9488|IGP|195. 66. 226. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 90|8342|147. 46. 0. 0/16|8342 701 3786 9488|IGP|195. 66. 224. 90|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 83|5511|147. 46. 0. 0/16|5511 3356 4766 9488|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 99|13237|147. 46. 0. 0/16|13237 4766 9488|IGP|195. 66. 224. 147|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 54|286|147. 46. 0. 0/16|286 4766 9488|IGP|195. 66. 224. 54|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 138|2914| 147. 0. 0/16|2914 4766 9488|IGP|195. 66. 224. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846404|B|195. 66. 226. 138|2914|147. 0. 0/16|2914 4766 9488|IGP|195. 66. 226. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 90|8342|147. 0. 0/16|8342 701 3786 9488|IGP|195. 66. 224. 90|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 83|5511|147. 0. 0/16|5511 3356 4766 9488|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 99|13237|147. 0. 0/16|13237 4766 9488|IGP|195. 66. 224. 147|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 54|286|147. 0. 0/16|286 4766 9488|IGP|195. 66. 224. 54|0|0||NAG|| TABLE_DUMP|1103846409|B|195. 66. 224. 138|2914| 203. 246. 119. 0/24|2914 4766 9488|IGP|195. 66. 224. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846409|B|195. 66. 226. 138|2914|203. 246. 119. 0/24|2914 4766 9488|IGP|195. 66. 226. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846409|B|195. 66. 224. 90|8342|203. 246. 119. 0/24|8342 701 3786 9488|IGP|195. 66. 224. 90|0|0||NAG|| TABLE_DUMP|1103846409|B|195. 66. 224. 83|5511|203. 246. 119. 0/24|5511 3356 4766 9488|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846409|B|195. 66. 224. 99|13237|203. 246. 119. 0/24|13237 4766 9488|IGP|195. 66. 224. 147|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846409|B|195. 66. 224. 54|286|203. 246. 119. 0/24|286 4766 9488|IGP|195. 66. 224. 54|0|0||NAG|| TABLE_DUMP|1103846410|B|195. 66. 224. 138|2914| 210. 97. 140. 0/23|2914 4766 9488|IGP|195. 66. 224. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846410|B|195. 66. 226. 138|2914|210. 97. 140. 0/23|2914 4766 9488|IGP|195. 66. 226. 138|0|296|2914: 410|NAG|| TABLE_DUMP|1103846410|B|195. 66. 224. 90|8342|210. 97. 140. 0/23|8342 701 3786 9488|IGP|195. 66. 224. 90|0|0||NAG|| TABLE_DUMP|1103846410|B|195. 66. 224. 83|5511|210. 97. 140. 0/23|5511 3356 4766 9488|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846410|B|195. 66. 224. 99|13237|210. 97. 140. 0/23|13237 4766 9488|IGP|195. 66. 224. 147|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846410|B|195. 66. 224. 54|286|210. 97. 140. 0/23|286 4766 9488|IGP|195. 66. 224. 54|0|0||NAG|| Data from rrc 01. ripe. net (LINX, London) December 24, 2004
KAIST Routes AS 1704 TABLE_DUMP|1103846404|B|195. 66. 224. 83|5511| 137. 68. 0. 0/16|5511 9318 1704|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 54|286|137. 68. 0. 0/16|286 9318 1704|IGP|195. 66. 224. 54|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 90|8342|137. 68. 0. 0/16|8342 1299 209 9318 1704|IGP|195. 66. 224. 90|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 99|13237|137. 68. 0. 0/16|13237 9318 1704|IGP|195. 66. 224. 176|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 90|8342| 143. 248. 0. 0/16|8342 3292 15412 9318 1781|IGP|195. 66. 224. 64|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 83|5511|143. 248. 0. 0/16|5511 9318 1781|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 64|3292|143. 248. 0. 0/16|3292 15412 9318 1781|IGP|195. 66. 224. 64|0|0|3292: 1008 3292: 1905|NAG|| TABLE_DUMP|1103846404|B|195. 66. 226. 64|3292|143. 248. 0. 0/16|3292 15412 9318 1781|IGP|195. 66. 226. 64|0|0|3292: 1008 3292: 1905|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 99|13237|143. 248. 0. 0/16|13237 9318 1781|IGP|195. 66. 224. 176|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 138|2914|143. 248. 0. 0/16|2914 4766 9318 1781|IGP|195. 66. 224. 138|0|307|2914: 410|NAG|| TABLE_DUMP|1103846404|B|195. 66. 224. 54|286|143. 248. 0. 0/16|286 9318 1781|IGP|195. 66. 224. 54|0|0||NAG|| TABLE_DUMP|1103846404|B|195. 66. 226. 138|2914|143. 248. 0. 0/16|2914 4766 9318 1781|IGP|195. 66. 226. 138|0|307|2914: 410|NAG|| AS 1781 TABLE_DUMP|1103846406|B|195. 66. 224. 90|8342|1 92. 249. 24. 0/24|8342 3292 15412 9304 9318 1781|IGP|195. 66. 224. 64|0|0||NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 83|5511|192. 249. 24. 0/24|5511 9318 1781|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 64|3292|192. 249. 24. 0/24|3292 15412 9304 9318 1781|IGP|195. 66. 224. 64|0|0|3292: 1008 3292: 1905|NAG|| TABLE_DUMP|1103846406|B|195. 66. 226. 64|3292|192. 249. 24. 0/24|3292 15412 9304 9318 1781|IGP|195. 66. 226. 64|0|0|3292: 1008 3292: 1905|NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 99|13237|192. 249. 24. 0/24|13237 9318 1781|IGP|195. 66. 224. 176|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 138|2914|192. 249. 24. 0/24|2914 4766 9318 1781|IGP|195. 66. 224. 138|0|307|2914: 410|NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 54|286|192. 249. 24. 0/24|286 9318 1781|IGP|195. 66. 224. 54|0|0||NAG|| TABLE_DUMP|1103846406|B|195. 66. 226. 138|2914|192. 249. 24. 0/24|2914 4766 9318 1781|IGP|195. 66. 226. 138|0|307|2914: 410|NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 90|8342| 192. 249. 25. 0/24|8342 701 1239 9318 1781|IGP|195. 66. 224. 90|0|0||NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 83|5511|192. 249. 25. 0/24|5511 9318 1781|IGP|195. 66. 224. 83|0|0||NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 99|13237|192. 249. 25. 0/24|13237 9318 1781|IGP|195. 66. 224. 176|0|0|13237: 40044 13237: 46441|NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 138|2914|192. 249. 25. 0/24|2914 4766 9318 1781|IGP|195. 66. 224. 138|0|307|2914: 410|NAG|| TABLE_DUMP|1103846406|B|195. 66. 224. 54|286|192. 249. 25. 0/24|286 9318 1781|IGP|195. 66. 224. 54|0|0||NAG|| TABLE_DUMP|1103846406|B|195. 66. 226. 138|2914|192. 249. 25. 0/24|2914 4766 9318 1781|IGP|195. 66. 226. 138|0|307|2914: 410|NAG||
A Picture of AS 1237 KREONET-AS-KR Korea Institute of Science and Technology Information 5511 209 2914 286 13237 701 2516 3786 7018 4766 3608 1237 9489 9949 9870 9860 7564 10063 9982 209 == ASN-QWEST Qwest 286 == AS 286 KPN Eurorings Backbone AS 1237 == KREONET-AS-KR Korea Institute of Science and Technology Information 2914 == VERIO Verio, Inc. 2516 == KDDI CORPORATION 3608 == KIX-AS-KR National Computerization Agency 5511 == OPENTRANSIT France Telecom 3786 == ERX-DACOMNET DACOM Corporation 4766 == KIX Korea Internet Exchange for "96 World Internet Exposition 7564 == KAERINET-AS Korea Atomic Energy Research Institute 9489 == KARINET-AS Korea Aerospace Research Institute 9949 == HOSEO-AS HOSEO UNIVERSITY 9860 == TMCNET-AS Tong. Myong College 9982 == PAICHAI-AS PAICHAI UNIVERSITY 9870 == DEUNET-AS DONG-EUI UNIVERSITY 10063 == KMA-AS Korea Meteorological Administration 13237 == LAMBDANET-AS Lambda. Net AS for European Operations
BGP Operations : Hard State Protocol Establish session on TCP port 179 AS 1 BGP session Exchange all active routes AS 2 Exchange incremental updates While connection is ALIVE exchange route UPDATE messages 24
A few AS 1237 updates BGP 4 MP|1103885081|A|195. 66. 226. 138|2914|221. 158. 73. 0/24|2914 4766 3608 1237 17576|IGP|195. 66. 226. 138|0|296|2914: 410|N BGP 4 MP|1103885081|A|195. 66. 226. 138|2914|221. 158. 73. 0/24|2914 4766 3608 1237 17576|IGP|195. 66. 226. 138|0|307|2914: 410|NAG|| BGP 4 MP|1103885106|W|195. 66. 226. 138|2914|221. 158. 73. 0/24 BGP 4 MP|1103896978|A|195. 66. 226. 138|2914|221. 158. 73. 0/24|2914 4766 17576|IGP|195. 66. 226. 138|0|296|2914: 410|NAG|| BGP 4 MP|1103885081|A|195. 66. 226. 138|2914|203. 253. 232. 0/24|2914 4766 3608 1237 17576|IGP|195. 66. 226. 138|0|296|2914: 410 BGP 4 MP|1103885081|A|195. 66. 226. 138|2914|203. 253. 232. 0/24|2914 4766 3608 1237 17576|IGP|195. 66. 226. 138|0|307|2914: 410|NAG BGP 4 MP|1103885106|W|195. 66. 226. 138|2914|203. 253. 232. 0/24 BGP 4 MP|1103896978|A|195. 66. 226. 138|2914|203. 253. 232. 0/24|2914 4766 17576|IGP|195. 66. 226. 138|0|296|2914: 410|NAG||
BGP Update Streams Data from rrc 01. ripe. net (LINX, London)
A Closer Look …
High Variability
A Closer Look …
… 1000 Second Bins
Look At BGP Table Size
A Closer Look …
Another Example: Christmas Eve!
A Closer Look …
High Variability, Again
… 1000 Second Bins
And Table Size
SQL Slammer from Route-Views
A Challenge Develop rigorous models for • Generation of BGP updates • Propagation of BGP updates • BGP observations MUST BE EXTERNALLY AND INTERNALLY CONSISTENT!!
This will not be easy • Data is complex • Implementation matters • A network of BGP speakers acts like a large network of Communicating Finite State Machines ---- so is a large finite state transducer • BGP topology is not known • BGP policies are secret
Implementation Does Matter! stateless withdraws widely deployed stateful withdraws widely deployed Thanks to Abha Ahuja and Craig Labovitz for this plot.









































