Security in DNSDNSSEC Yalda Edalat Pramodh Pallapothu Agenda

  • Slides: 18
Download presentation
Security in DNS(DNSSEC) Yalda Edalat Pramodh Pallapothu

Security in DNS(DNSSEC) Yalda Edalat Pramodh Pallapothu

Agenda l l l l What is DNS? Cashing in DNS Threats to the

Agenda l l l l What is DNS? Cashing in DNS Threats to the DNS What should match in DNS transaction? What is DNSSEC? DNSKEY, RRSIG, NSEC, DS DNSSEC issues

What is DNS? l l l First step to communicate between computers which support

What is DNS? l l l First step to communicate between computers which support IP is knowing IP address. Memorizing four decimal numbers for each web site is difficult. Memorizing host names are easier. At beginning, SRI-NIC was responsible to maintain a single file containing IP addresses for hosts. Internet grows rapidly and need to guarantee the uniqueness of IP addresses. Creating an Internet distribution database (DNS).

Cashing in DNS l l To reduce load on DNS server caching mechanism for

Cashing in DNS l l To reduce load on DNS server caching mechanism for a specific period of time after a successful answer.

Threats to the DNS: Most weaknesses in DNS fall into these categories: l Ø

Threats to the DNS: Most weaknesses in DNS fall into these categories: l Ø Ø Ø Cache poisoning Client flooding Compromise of DNS server’s authoritative data

Cache Poisoning

Cache Poisoning

What should match in DNS transaction? 1 2 3 4 2 1 3 4

What should match in DNS transaction? 1 2 3 4 2 1 3 4

Other threats l Client flooding: client sends a query, but receives thousands of DNS

Other threats l Client flooding: client sends a query, but receives thousands of DNS responses from attacker v l lake in authentication of responses, without strong authentication, the client can not verify the origin of response. Compromise of DNS server’s authoritative data: attacker gains administrative privileges and plans to modify zone information

Need for more security l l l q Original DNS did not include security.

Need for more security l l l q Original DNS did not include security. Dependency of some commands on hostnames for authentication (“r” command in UNIX). False information in DNS cause unexpected results. appropriate security is needed to provide adequate protection in DNS, and it is accomplished through DNSSEC

DNSSEC l l l DNS Security Extension Defines additional Resource Records DNSKEY, RRSIG, NSEC

DNSSEC l l l DNS Security Extension Defines additional Resource Records DNSKEY, RRSIG, NSEC and DS are four of those Resource Records.

DNSKEY It is the public key for the zone and is published in zone

DNSKEY It is the public key for the zone and is published in zone file. example. com. 86400 IN DNSKEY 256 3 5 ( AQPSKmynfz. W 4 ky. Bv 015 MUG 2 De. IQ 3) 86400 secs -> TTL of 1 day 256 -> Flag value which indicates it’s a zone key. 3 -> Protocol value 5 -> RSA/SHA 1 , RR value is base 64 encoding.

RRSIG records store digital signatures that were created by signing the resource records associated

RRSIG records store digital signatures that were created by signing the resource records associated with a domain using a DNSKEY. host. example. com. 86400 IN RRSIG A 5 3 86400 20030322173103 ( 20030220173103 2642 example. com. o. JB 1 W 6 WNGv+ldv. Q 3 WDG 0 MQkg 5 IEhj. Rip 8 WTr ) 86400 secs -> TTL A -> indicates that this is a signing of the A RRs for "host. example. com" 5 -> RSA/SHA 1 …. ….

NSEC is used to provide proof of nonexistense of any name within a zone.

NSEC is used to provide proof of nonexistense of any name within a zone. alfa. example. com. 86400 IN NSEC host. example. com. ( A MX RRSIG NSEC TYPE 1234 ) The first four text fields specify the name, TTL, Class, and RR type (NSEC). The entry host. example. com. is the next authoritative name after alfa. example. com. in canonical order. The A, MX, RRSIG, NSEC, and TYPE 1234 mnemonics indicate that there are A, MX, RRSIG, NSEC, and TYPE 1234 RRsets associated with the name alfa. example. com.

DS The Delegation Signer (DS) RR contains the hash of the public key of

DS The Delegation Signer (DS) RR contains the hash of the public key of the child zone. This record is signed by the parent zone's private key with a matching RRSIG RR. dskey. example. com. 86400 IN DS 60485 5 1 ( 2 BB 183 AF 5 F 22588179 A 53 B 0 A 98631 FAD 1 A 292118 )

How does DNSSEC work ?

How does DNSSEC work ?

DNSSEC issues l l l The average size of a DNS response message increases.

DNSSEC issues l l l The average size of a DNS response message increases. The zone file increases in size due to the addition of the additional DNSSEC records. The number of DNS transactions increases due to the requirement to perform additional queries for zone public key records when constructing trust chains. The client has to spend additional time validating the signed data and validating the public key, potentially slowing the resolution process. The server has to generate new signatures over all RRset changes, which places an incremental load on the server function.

DNSSEC Reference l RFC 3833 A Threat Analysis of the Domain Name System RFC

DNSSEC Reference l RFC 3833 A Threat Analysis of the Domain Name System RFC 4033 DNS Security Introduction and Requirements RFC 4034 Resource Records for the DNS Security Extensions RFC 4035 Protocol Modifications for the DNS Security Extensions RFC 4398 Storing Certificates in the Domain Name System (DNS) NSEC 3 - "DNSSEC Hashed Authenticated Denial of Existence" draft-ietf-dnsext-nsec 3 -06. txt DNS and Bind, 4 th Edition, Paul Albitz and Cricket Liu, O'Reilly www. dnssec. org – A resource page for DNSSEC