SNMPv 2 Management Information Prof Choong Seon HONG
























- Slides: 24
SNMPv 2 Management Information Prof. Choong Seon HONG Kyung Hee University 1
Overview q SNMPv 2 expands the functionality of SNMP and broadens it applicability to include OSI-based as well as TCP/IP-based networks Kyung Hee University 2
11. 1 Background q The development of SNMPv 2 SNMP advantages 1. SMI and SNMP MIB are quite simple and therefore can be easily and quickly implemented 2. SNMP is based on the Simple Gateway Monitoring Protocol (SGMP), for which a great deal of operational experience had been gained. By 1988, the critical need of network management, in short term (for current level of network complexity) and long term (for more complex environments) So, two-track policy was adopted: SNMP would be used to meet immediate network management needs, and an OSI-based solution would be pursued for long-term needs. OSI-based solution was CMOT (CMIP over TCP/IP) Kyung Hee University 3
Background (cont’d) q The development of SNMPv 2 (cont’d) Two-track strategy has not worked, for several reasons 1. It was initially intended that SMI and MIB of SNMP be subsets of those for OSI systems management. So, this was planned to enable a relatively easy transition. But, the complex object-oriented approach of OSI was incompatible with quick deployment of SNMP 2. Development of stable OSI standards, and the product implementation for network management has taken than anticipated. SNMP has been implemented by a broad range of vendors and is widely deployed. According to the large and complex network configuration, SNMP life is reaching the end of its useful life So, interesting in fixing SNMP to extend its useful lifetime Kyung Hee University 4
Background (cont’d) q The development of SNMPv 2 (cont’d) One major flaw of that has inhibited the use of SNMP is that it provides no security facilities no capability to authenticate the source management message nor any capability to prevent eavesdropping. SNMP is vulnerable to attacks that can modify or disable a network configuration So, secure SNMP was proposed, in July 1992 Because secure SNMP does not address other deficiencies related performance and functionality. – Kyung Hee University SMP (Simple Management Protocol) was developed. 5
Background (cont’d) q The development of SNMPv 2 (cont’d) The extensions defined in the SMP proposal fall into four categories Scope : SMP is designed to facilitate management of arbitrary resources, not just “network resource”. Thus, SMP can be applications management, systems management, and manager-to-manager communication Size, speed, and efficiency : The development of a bulk transfer capability for the efficient exchange of large amounts of management information Security and privacy : SMP incorporate the enhancements found in secure SNMP Deployment and compatibility : designed to incorporate with SNMP platforms, using a subset of SMP capabilities After the publication of secure SNMP and SMP, both in July of 1992, , a consensus emerged within the Internet community that it was highly desirable to enable users and vendors to make a single transition for the original SNMP to second-generation SNMP SMP was accepted as a baseline for beginning the process of defining a new SNMP standard, known as SNMP version 2 Kyung Hee University 6
Background (cont’d) q The development of SNMPv 2 (cont’d) SNMPv 2 functional working group completed its work in Dec. of 1992 SNMPv 2 security working group completed its work in Jan. of 1993 Then, a set of Proposed Internet Standards in March of 1993 New set of RFCs issued in 1996 with dropping the security aspects of SNMPv 2 q SNMP Specifications (Table 11. 1) Kyung Hee University 7
Background (cont’d) q SNMPv 2 Enhancement SNMPv 2 can support either a highly centralized network management strategy or a distributed one. In the latter case, some system operate in the role of both manager and agent. Agent/intermediate manager/superior manager The key enhancement to SNMP that are provided in SNMPv 2 Structure of Management Information (SMI) Manager-to-manager capability Protocol operations SMI expansion The macro used to define object types has been expanded to include several new data types and to enhance the documentation associated with an object. New convention that has been provided for creating and deleting conceptual rows in the table SNMPv 2 MIB contains basic traffic information about the operation of the SNMPv 2 protocol; analogous to the snmp group in MIB-II Kyung Hee University 8
Background (cont’d) q SNMPv 2 Enhancement Most noticeable change in protocol operations Get. Bult. Request PDU : enabling the manager to retrieve large blocks of data efficiently. It is well suited to retrieving multiple rows in a table Inform. Request PDU : enabling one manager to send trap of information to another Kyung Hee University 9
11. 2 Structure of Management Information q SNMPv 2 SMI is nearly a proper superset of the SNMPv 1 SMI q SNMPv 2 introduces four key concepts of Object definitions Conceptual tables Notification definitions Information modules Kyung Hee University 10
SMI (cont’d) q Object definitions SNMPv 2 SMI are used to describe managed objects. ASN. 1 macro OBJECT-TYPE is used to convey the syntax and semantics of all managed objects in a systematic way SNMPv 2 specification the OBJECT-TYPE macro (Fig. 11. 1). Some associated definitions (Fig. 11. 2) Same general structure as the OBJECT-TYPE macro defined in RFC 1155 (SNMP SMI) , with refinements in RFC 1212 (concise MIB Definitions) Comparison between the macro defined in the SNMPv 2 documents and the macro defined for SNMP in RFCs 1155 and 1212 Kyung Hee University 11
SMI (cont’d) q Data types Data Type INTEGER Unsigned 32 Counter 64 Guage 32 Time. Ticks OCTET STRING Ip. Address OBJECT IDENTIFIER Opaque Kyung Hee University SNMPv 1 X X X X SNMPv 2 X X X X X 12
SMI (cont’d) q An example of enumerated integers, taken from if. Test. Table in RFC 1573 (Evolution of the Interfaces Group of MIB-II) if. Test. Result OBJECT-TYPE SYNTAX INTEGER { none (1) -- no test yet requested success (2) in. Progress (3) not. Supported (4) un. Able. Token (5) -- due to state of system aborted (6) failed (7) } MAX ACCESS read-only STATUS current Description “ Kyung Hee University : : = {if. Test. Entry 4} “ 13
SMI (cont’d) q Limited-range gauge for Guage 32 Kyung Hee University 14
SMI (cont’d) q Units. Part contains a textual definition of the units associated with an object is useful for any object that represents a measurement in some kind of units, such as time q MAX-ACCESS Clause not-accessible-for-notify read-only read-create q STATUS Clause indicating that this definition is current or historic, not including the “optional” or “mandatory” categories defined for SNMPv 1 “obsolete” means that this object should not be implemented, but “deprecated” that implementer wishes to support for backward compatibility with older implementations Kyung Hee University 15
SMI (cont’d) q SNMPv 2 Tables Table has zero or more rows, and each row contains one or more scalar objects Form of SNMPv 1, SNMPv 2 1. A conceptual table has a SYNTAX clause of the form SEQUENCE OF <entry> where <entry> is conceptual row 2. A conceptual row has a SYNTAX clause of the form SEQUENCE {<type 1>, ……. , <type. N>} where <type> is columnar object form of each <type> is <descriptor><syntax> <descriptor> is name of columnar objects <syntax> is the value of object’s SYNTAX Clause 3. Each Kyung Hee macro University columnar object is defined in the usual manner with an OBJECT_TYPE 16
SMI (cont’d) SNMPv 2 enhances conventions used in RFC 1212 and in the RMON specification (RFC 1757) to facilitate row creation, deletion, and access. Two categories of conceptual tables are allowed in SNMPv 2 Tables that prohibit row creation and deletion by a manager: These are controlled completely by the agent Tables that allow row creation and deletion by a manager : Such a table may be initialized with no rows, with only the manager causing row creation and deletion. Kyung Hee University 17
SMI (cont’d) q Table Indexing INDEX Clause defines a base conceptual row INDEX component of the row definition determines which object value(s) will unambiguously distinguish one row in the table That is, INDEX objects (or objects) determine a conceptual row instance optional use of IMPLIED modifier to an object name in SNMPv 2 Given object identifier is y, INDEX objects are i 1, i 2, …. , i. N, then the instance identifier for an instance of object y in particular row is y. (i 1). (i 2)…. . (i. N) Kyung Hee University 18
SMI (cont’d) In the previous slide, each term in parentheses is interpreted as follows: Integer-valued String-valued, fixed-length String-valued, variable length preceded by the IMPLIED keyword String-valued, variable length not preceded by the IMPLIED keyword Octet-identifier-valued not preceded by the IMPLIED keyword Ip. Address-valued - IMPLIED keyword enables a small savings in the instance identifier when the index objects is a variable string Kyung Hee University 19
SMI (cont’d) q Flowchart for conceptual row creation Kyung Hee University 20
SMI (cont’d) q Checklist of features of row creation MANDATORY FEATURES 1. It must handle rows larger than one PDU 2. It must allow management station to learn of columns not implemented in agent 3. It must allow management station to learn of columns not accessible in agent 4. It must arbitrate between multiple managers accessing same row 5. It must protect create operations from reordering 6. It must allow protocol entity to detect too. Big before create is executed 7. It must allow read-only and read-create object to coexist in same row VERY IMPORTANT FEATURES USEFUL FEATURES Kyung Hee University 21
SMI (cont’d) q Checklist of features of row creation Feature 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 Kyung Hee University Category Must Must Important Useful Useful create. And. Wait Yes Yes No Yes Yes No create. And. Go No Yes Yes Yes No No No Yes No 22
SMI (cont’d) q Notification Definitions NOTIFICATION-TYPE macro is used to define the information that is sent by an SNMPv 2 entity when an exceptional event occurs at the entity. Example link. Up NOTIFICATION-TYPE OBJECTS {if. Index, if. Admin. Stats, if. Oper. Status} STATUS current DESCRIPTION “A link. Up trap signifies that the SNMPv 2 entity, acting in an agent role, has detected that the if. Oper. Status object for one of its communication links transitioned out of the down state. ” : : = {snmp. Traps 4} Kyung Hee University 23
SMI (cont’d) q example snmp. MIB MODULE-IDENTITY LAST-UPDATED “ 9511090000 Z” ORGANIZATION “IETF SNMPv 2 Working Group” CONTACT-INFO “ Marshall T. Rose Postal : Dover Beach Consulting, Inc. 420 Whisman Court Mountain View, CA 94043 -2186 US Tel : +1 415 968 1052 E-mail : mrose@dbc. mtview. ca. us” DESCRIPTION “The MIB module for SNMPv 2 entities. ” REVISION “ 930401000 Z” DESCRIPTION “The initial revision of this MIB module was published as RFC 1450. ” : : = {snmp. Modules 1} Kyung Hee University 24
























