Dynamic Host Configuration Protocol Nagwek DHCP Op 1

  • Slides: 17
Download presentation
Dynamic Host Configuration Protocol

Dynamic Host Configuration Protocol

Nagłówek DHCP Op (1) Htype (1) Hlen (1) Hops (1) Xid (4) Secs (2)

Nagłówek DHCP Op (1) Htype (1) Hlen (1) Hops (1) Xid (4) Secs (2) Flags (2) Ciaddr (4) Yiaddr (4) Siaddr (4) Giaddr (4) Chaddr (16) Sname (64) Files (128) Options (variable)

Opis pól nagłówka DHCP n Op – typ / kod komunikatu 1 = BOOTREQUEST,

Opis pól nagłówka DHCP n Op – typ / kod komunikatu 1 = BOOTREQUEST, 2 = BOOTREPLY n Htype – typ adresu sprzętowego 1 – 10 Mb ethernet n Hlen – długość adresu sprzętowego 6 – dla 10 Mb ethernet n n Hops – klient ustawia na zero; używane czasami podczas startowania za pomocą agentów Xid – identyfikator transakcji liczba losowa wybrana przez klienta używana przez klienta i serwer do kojarzenia pakietów przesyłanych między nimi. n Secs – wypełniane przez klienta; ilość czasu (sekundy) jaka upłynęła od przyjęcia adresu lub odnowienia go.

Opis pól nagłówka DHCP n n n Flags – flagi; opisane dalej Ciaddr –

Opis pól nagłówka DHCP n n n Flags – flagi; opisane dalej Ciaddr – adres IP klienta; wypełniane wyłącznie gdy klient znajduje się w stanie: BOUND, RENEW, REBINDING i odpowiada na zapytania ARP Yiaddr – „your” adres klienta Siaddr – adres IP następnego serwera w bootstrap; otrzymywane w DHCPOFFER, DHCPACK przez serwer Giaddr – adres IP relay agenta; używane podczas startowania z wykorzystaniem agentów relay (pośredniczących) Chaddr – adres sprzętowy klienta

Opis pól nagłówka DHCP n n n Sname – nazwa hosta serwera (opcjonalne); null

Opis pól nagłówka DHCP n n n Sname – nazwa hosta serwera (opcjonalne); null terminated string File – nazwa pliku boot; null terminated string; puste w przypadku DHCPDISCOVER; pełna ścieżka dostępu z plikiem w DHCPOFFER Options – pole dodatkowych opcjonalnych parametrów Maksymalny rozmiar nagłówka DHCP to 576 octetów.

Uwagi n n n DHCP jest używane do inicjacji TCP/IP jeszcze na długo przed

Uwagi n n n DHCP jest używane do inicjacji TCP/IP jeszcze na długo przed tym niż zostanie ono dostatecznie skonfigurowane Stacja musi akceptować (zgodnie z RFC 1122) i przesyłać dalej do powłoki IP pakiety dostarczane do adresu sprzętowego klienta jeszcze przez skonfigurowaniem IP. DHCP serwery i BOOT agenci nie mogą dostarczać informacje do klientów nie akceptujących sprzętowych pakietów unikastowych.

Uwagi n Aby dostarczyć informacje do klientów nie akceptujących pakietów unikastowych, DHCP używa flag.

Uwagi n Aby dostarczyć informacje do klientów nie akceptujących pakietów unikastowych, DHCP używa flag. B MBZ B – flaga broadcast; MBZ – Musi Być Zero (zarezerwowane do przyszłuch zastosowań)

Klient serwer protokół n n DHCP używa formatów BOOTP zdefiniowanych w RFC 951 Pole

Klient serwer protokół n n DHCP używa formatów BOOTP zdefiniowanych w RFC 951 Pole „OP” wysyłane od klienta do serwera zawiera BOOTREQUEST; BOOTREPLY używane jest w przeciwnym wypadku Pierwsze 4 bajty w polu opcji zawierają odpowiednio wartości dziesiętne 99, 130, 83, 99 (taki sam trik jak używany w RFC 1497); w pozostałej części pola znajdują się listy parametrów przesyłanych przez DHCP zdefiniowanych w RFC 1533 Jedna z opcji musi być zawarta w każdym komunikacie DHCP: „DHCP message type” definiująca typ komunikatu DHCP

Komunikaty DHCP n DHCPDISCOVER Rozgłoszenie klienta do zlokalizowania dostępnych serwerów n DHCPOFFER Serwer do

Komunikaty DHCP n DHCPDISCOVER Rozgłoszenie klienta do zlokalizowania dostępnych serwerów n DHCPOFFER Serwer do klienta w odpowiedzi na DHCPDISCOVER z ofertą konfiguracyjną n DHCPREQUEST Komunikat klienta do serwera: - prośba o oferowane parametry od jednego serwera i odrzucenie ofert innych serwerów - potwierdzenie parametrów np. po restarcie - rozszerzenie czasu wypożyczenia na konkretny adres

Komunikaty DHCP n DHCPACK Serwer do klienta z parametrami konfiguracyjnymi dodatkowo z obowiązującymi adresami

Komunikaty DHCP n DHCPACK Serwer do klienta z parametrami konfiguracyjnymi dodatkowo z obowiązującymi adresami sieciowymi n DHCPNAK Serwer do klienta z ze wskazaniem, że posiada niepoprawny adres np. : został przeniesiony do innej podsieci n DHCPDECLINE Klient do serwera wskazując, że adres sieciowy jest w użyciu n DHCPRELEASE Klient do serwera rezygnując z adresu sieciowego i dalszej rezerwacji

Komunikaty DHCP n DHCPINFORM Klient do serwera; zapytanie wyłącznie o lokalne parametry konfiguracyjne; klient

Komunikaty DHCP n DHCPINFORM Klient do serwera; zapytanie wyłącznie o lokalne parametry konfiguracyjne; klient już posiada inne zewnętrzne informacje o adresach sieciowych

Czasowy diagram wymiany informacji DHCP Serwer (nie wybrany) Klient Serwer (wybrany) Początek inicjalizacji DHCPDISCOVER

Czasowy diagram wymiany informacji DHCP Serwer (nie wybrany) Klient Serwer (wybrany) Początek inicjalizacji DHCPDISCOVER Określanie konfiguracji Zbieranie ofert DHCPOFFER Wybór konfiguracji DHCPREQUEST Potwierdzenie konfiguracji DHCPACK Inicjalizacja zakończona Zakończenie DHCPRELEASE Zwolnienie konfiguracji

Init/ Reboot INIT DHCPNAK Restart Send DHCPDISCOVER Send DHCPREQUEST DHCPACK (not accept. ) Send

Init/ Reboot INIT DHCPNAK Restart Send DHCPDISCOVER Send DHCPREQUEST DHCPACK (not accept. ) Send DHCPDECLINE Wybieranie SELECTING Rebooting DHCPNAK Discard offer Sellect offer / Send DHCPREQUEST DHCPACK Record lease, set timers T 1, T 2 DHCPNAK Lease expired/ Halt network Zezwolenie REQUESTING DHCPOFFER Discard DHCPACK Record lease, set timers T 1, T 2 Powiązanie BOUND DHCPOFFER, DHCPACK, DHCPNAK Discard T 1 expires/ Send DHCPREQUEST to leasing server DHCPOFFER Collect replies Odnowienie REBINDING DHCPACK Record lease, set timers T 1, T 2 expires/ Broadcast DHCPREQUEST DHCPACK Record lease, set timers T 1, T 2 Odświeżenie RENEWING Transmisyjno-stanowy algorytm dla klientów DHCPNAK Halt network

DHCP - opcje n Zakres 0 – 255 , gdzie: n n n 0

DHCP - opcje n Zakres 0 – 255 , gdzie: n n n 0 – podkład (stan początkowy) 255 – koniec opcji Subnet Mask (1) RFC 950 Code Len Subnet mask 1 4 m 1 m 2 m 3 m 4

n n Router option (3) Code Len 3 n Address 1 Address 2 a

n n Router option (3) Code Len 3 n Address 1 Address 2 a 1 a 2 a 3 a 4. . . Time Server option (4) RFC 868 Code Len 4 n Address 1 Address 2 a 1 a 2 a 3 a 4. . .

n n Domain Name Server (6) RFC 1035 Cooki Server (8) RFC 865 Domain

n n Domain Name Server (6) RFC 1035 Cooki Server (8) RFC 865 Domain Name (15) IP Forwarding Enable/Disable (19) Code 19 n n Len Value 1 0/1 Default IP TTL (23) Broadcast Address (28)

n n n n ARP Cache Timeout (35) NTP Servers (42) X Window System

n n n n ARP Cache Timeout (35) NTP Servers (42) X Window System Font Server (48) POP 3 Server (70) Default IRC Server (74) DHCP Message Type (53) NDS Server (85) NDS Tree Name (86)