Instytut Telekomunikacji PW NGN SIGTRAN Signalling Transport Materiay

  • Slides: 13
Download presentation
Instytut Telekomunikacji PW NGN – SIGTRAN (Signalling Transport) Materiały wykładowe do użytku wewnętrznego Sigtran

Instytut Telekomunikacji PW NGN – SIGTRAN (Signalling Transport) Materiały wykładowe do użytku wewnętrznego Sigtran 1

Kontekst szczególny: 3 GPP G VLR Rel. 7 Sigtran 2

Kontekst szczególny: 3 GPP G VLR Rel. 7 Sigtran 2

SIGTRAN (Signalling Transport) • Pierwotna potrzeba - transfer sygnalizacji ISUP w sieci IP Cel:

SIGTRAN (Signalling Transport) • Pierwotna potrzeba - transfer sygnalizacji ISUP w sieci IP Cel: ISUP IAM . . . ACM • "przenieść" ISUP w relacji Centrala-MGC Wymaganie podstawowe: • zapewnić pełną funkcjonalność SS 7 na styku Centrala-MGC ISUP (logicznie) Centr. /STP MGC MTP 1/2/3 PSTN DSS 1/SS 7 (ITU) SG MG Cel w obecnej wersji: • przenieść „protokoły sieci CS” IP/? /? /? IP SIP(T/I) SIP/H 323 (IETF/ITU) SG - Signalling Gateway MGC - Media Gateway Controller ST - Signalling Transfer Point (SS 7) 3

cd. – szczegół: pełna funkcjonalność … ISUP IAM SG - Signalling Gateway MGC -

cd. – szczegół: pełna funkcjonalność … ISUP IAM SG - Signalling Gateway MGC - Media Gateway Controller ST - Signalling Transfer Point (SS 7) . . . ACM Centr ISUP (centrala-centrala) MGC /STP MTP(. . . ) SG IP(ddd(. . . )) PSTN DSS 1/SS 7 (ITU) MG ISUP MTP 3 MTP_Transfer_req MTP_Transfer_ind MTP( IAM) MTP( ACM) SIP(T/I) IP SIP/H 323 (IETF/ITU) SG ISUP MTP 3 IP[ ddd (IAM) ] IP[ ddd (ACM) ] Transfer. Prohibited Sign. Route. Set. Test TCP: • duże opóźnienia (ACK, sekwencyjność) • niezgranie timerów TCP z sygnalizacyjnymi • brak obsługi multi-homing (wiele interfejsów) • podatny na Do. S ddd = ? MTP_Transfer_ind • niezawodny, bezpieczny i szybki transport (TCP nie wystarcza) • pełna funkcjonalność styku: ISUP/MTP 3 wymaga od SG „czegoś więcej” niż zwykłego "przepakowania" wiadomości ISUP IP[ ddd (SNM) ] Transfer. Allowed wymagana jest „jakaś” adaptacja MTP_Pause MTP_Resume 4

SIGTRAN - funkcje • A zatem - główna idea transportu sygnalizacji SS 7/IP –

SIGTRAN - funkcje • A zatem - główna idea transportu sygnalizacji SS 7/IP – cel ogólny: funkcjonalne przeniesienie „protokołu” warstwy N – ale są „drobne niuanse” odnośnie tego co przenosić fizycznie… Warstwa sygnalizacyjna N PDU prymitywy komunikacyjne adaptacja Podstawowa kwestia: co fizycznie przenosi "adaptacja" : PDU czy prymitywy ? • PDU - brak zarządzania międzywarstwowego w protokole adaptacji • prymitywy – oznacza przenoszenie prymitywów komunikacyjnych oraz zarządzania międzywarstwowego w protokole adaptacji Generyczny transport dla strumieni sygnalizacyjnych IP SCTP - Stream Control Transmission Protocol (RFC 2960) • zarządzanie asocjacjami i strumieniami (połączeniami <=> #7 data link) • sekwencyjność w obrębie poszczególnych strumieni • segmentacja i składanie danych warstwy adaptacyjnej • potwierdzanie, sterowanie przepływem, detekcja/eliminacja błędów np. http: //www. isoc. org/briefings/017/index. shtml Sigtran 5

SIGTRAN – zasada działania (RFC 2719) Dwa kanoniczne tryby pracy 1. transfer prymitywów międzywarstwowych

SIGTRAN – zasada działania (RFC 2719) Dwa kanoniczne tryby pracy 1. transfer prymitywów międzywarstwowych (N)-(N+1) tzw. (N) User Adaptation SG … N+1 N MGC … współpraca N-1 N+1 NUA SCTP IP IP N N-1 współpraca – w zaawansowanej wersji może emulować warstwę N IP PSTN Req N- ind Centr N- ind • Ind SG/MGC N+1 + … … współpraca’ N+1 NUA SCTP IP wystarczy „przenieść” prymitywy m-warstwowe IP IP szczególne zastosowanie NUA: warstwa (N+1) w SG 2. zastąpienie „oryginalnej” warstwy (N) z punktu widzenia warstwy (N+1) tzw. (N) Peer-to-peer Adaptation MGC Centr … SG … N+1 N+1 N N N-1 PSTN NPA SCTP IP IP IP należy emulować pełną warstwę N znacznie bogatsza funkcjonalność niż UA (np. timery, monitorowanie statusu łącza) 6

Warstwa MTP 2 – dwie możliwości 1. transfer prymitywów międzywarstwowych (MTP 2)-(MTP 3) M

Warstwa MTP 2 – dwie możliwości 1. transfer prymitywów międzywarstwowych (MTP 2)-(MTP 3) M 2 UA - MTP 2 User Adaptation RFC 3331) MTP-3 MTP-2 MTP-1 ISUP współpraca MTP-3 MTP-2 MTP-1 PSTN MGC M 2 UA SCTP IP IP MTP 2 -ind ISUP SG MTP 2 -ind Centr SIGTRAN : = zdalna realizacja prymitywów - transferu danych - zarządzania IP Funkcje M 2 UA (ogólnie: pośredniczy między MTP 2 w SG a MTP 3 w MGC) 1. Pełna współpraca składników MTP 3 po sieci IP - obsługa styku MTP 2/MTP 3 w zakresie przesyłu danych - raportowanie zmian statusu łącza blokowi zarządzania (SNM) 2. Zarządzanie skojarzeniami (association) i ruchem SCTP 3. W SG nie ma funkcji punktu sygnalizacyjnego SS 7 (Signalling Point); brak wyższych warstw SS 7 4. Punkt sygnalizacyjny Sigtran jest w MGC 7

MTP 2 dwie możliwości cd. M 2 UA - konfiguracja równoważna logicznie Centr MGC

MTP 2 dwie możliwości cd. M 2 UA - konfiguracja równoważna logicznie Centr MGC ISUP/SCCP MTP-3 ISUP/SCCP ind MTP-2 req MTP-3 MTP-2 MTP-1 Preferowane zastosowania: - własna sieć - mała koncentracja łączy SS 7/ duże rozproszenie (wielu) SG - SG zintegrowane z MG Sigtran 8

MTP 2 dwie możliwości – cd. 2. wprowadzenie funkcjonalności warstwy MTP 3 w węźle

MTP 2 dwie możliwości – cd. 2. wprowadzenie funkcjonalności warstwy MTP 3 w węźle SG MTP 2 User Peer-to-Peer Adaptation Layer – M 2 PA (RFC 4165) Centr ISUP MTP-3 MTP-2 SG=STP (węzeł poziomu MTP-3) MGC MTP-3 MTP-2 MTP-1 ISUP M 2 PA SCTP IP IP IP PSTN SG jest kompletnym węzłem STP Preferowane zastosowania: - styki międzyoperatorskie albo konfiguracja SG-SG - duża koncentracja łączy SS 7 - zaawansowane funkcje w SG (STP/ISUP/SCCP…) Funkcje M 2 PA (zastępuje część MTP 2 między sąsiednimi blokami MTP 3) 1. Pełna współpraca składników MTP 3 po sieci IP - obsługa styku MTP 2/MTP 3 w zakresie przesyłu danych - wszystkie funkcje raportowanie zmian statusu łącza blokowi zarządzania (SNM) 2. Zarządzanie skojarzeniami (association) i ruchem strumieni SCTP 3 W SG jest punkt sygnalizacyjny SS 7; mogą też rezydować wyższe warstwy SS 7 (np. SCCP)

M 3 UA – MTP 3 User Agent • Warstwa MTP 3 – M

M 3 UA – MTP 3 User Agent • Warstwa MTP 3 – M 3 UA (MTP 3 User Agent) (RFC 4666) MGC Centr IAM/ACM/ANM… ISUP Współpraca MTP-3 M 3 UA MTP-2 SCTP MTP-1 IP IP PSTN SG jest „pełnowartościowym” węzłem STP IP Preferowane zastosowania: - duża koncentracja łączy SS 7 - styki międzyoperatorskie. zaawansowane filtry. obecność ISUP/SCCP w SG Funkcje M 3 UA (ogólnie: pośredniczy między MTP 3 w SG a użytkownikami_MTP 3 w MGC) 1. Pełna współpraca składników użytkowych względem MTP 3 po sieci IP - obsługa styku MTP 3/warstwa_użytkowa w zakresie przesyłu danych - raportowanie zmian statusu dróg sygnalizacyjnych warstwom_użytkowym 2. Zarządzanie skojarzeniami (association) i ruchem SCTP 3. W SG jest punkt sygnalizacyjny SS 7(mogą też rezydować wyższe warstwy SS 7) - możliwość współpracy peer-to-peer (Użytk 1 -M 3 UA 2 -Użytk 2) Sigtran 10

MTP 3 UA cd. Przykład dla warstwy MTP 3 – M 3 UA (MTP

MTP 3 UA cd. Przykład dla warstwy MTP 3 – M 3 UA (MTP 3 User Agent) SG ISUP MTP 3 MTP_Transfer_req MTP_transfer_ind MTP( IAM) ISUP M 3 UA MTP 3 M 3 UA DATA[ MTP_Transfer() ] MTP( ACM) Transfer. Prohibited(APC) Sign. Route. Set. Test(APC) Transfer. Allowed(APC) DUNA (APC) MTP_transfer_ind MTP_transfer_req MTP_Pause DAUD (APC) DAVA (APC) MTP_Resume prymitywy zarządzania MTP 3 MTP_Pause MTP_Resume APC – Affected Point Code Niektóre wiadomości poziomu M 3 UA/SIGTRAN SNM • DATA – przenosi prymityw części MTP 3 • DUNA – Destination Unavailable • DAUD – Destination Audit • DAVA – Destination Available (SUA ma podobne i własne wiadomości, za to M 2 UA zasadniczo już inne) Sigtran 11

SUA – SCCP User Agent • Warstwa SUA (SCCP User Agent) (RFC 3868) MGC

SUA – SCCP User Agent • Warstwa SUA (SCCP User Agent) (RFC 3868) MGC TCAP SUA SUA SCTP IP IP IP Centr IAM/ACM/ANM… TCAP Współpraca SCCP MTP-3 MTP-2 MTP-1 PSTN SG jest „pełnowartościowym” węzłem SCCP IP DODATKOWO: pełna funkcjonalność SCCP w środowisku pakietowym z węzłem SCCP Funkcje SUA 1. Pełna współpraca składników użytkowych względem SCCP po sieci IP - obsługa styku SCCP/warstwa_użytkowa w zakresie przesyłu danych - raportowanie zmian statusu aplikacji warstwom_użytkowym - translowanie adresów SCCP (GT – nagłówki globalne) na adresy IP 2. Zarządzanie skojarzeniami (association) i ruchem SCTP 3. W MGC nie ma punktu sygnalizacyjnego SS 7 (oszczędność przestrzeni adresowej MTP 3) 4. W SG mogą rezydować wyższe warstwy – tak jak dla M 3 UA, i tutaj istnieje możliwość 12 współpracy peer-to-peer (Użytk 1 -SUA 2 -Użytk 2)

SIGTRAN – pozostałe zastosowania • Zasadniczo wszystkie protokoły rdzeniowe i dostępowe PSTN ISUP, INAP,

SIGTRAN – pozostałe zastosowania • Zasadniczo wszystkie protokoły rdzeniowe i dostępowe PSTN ISUP, INAP, MAP, DSS 1, sygnal_analogowa (logicznie) MGC/ SSP SCP Centr /SSP MTP(ISUP / SCCP(TCAP(INAP/MAP)) ) PSTN sygnalizacja DSS 1, V 5. 2 (logicznie) IP( Sg. T( ISUP / SCCP(TCAP(INAP/MAP). . . ) ) ) SG IP H. 248 PRA/E 1 MG + SG IP(Sg. T(DSS 1/V 5. 2) PABX AN-V 5 IUA (Q. 921) (RFC 4233) Sigtran V 5 UA(LAPV 5) (RFC 3807) 13