241 Physical and Data Link Layers Surasak Sanguanpong

























- Slides: 25
/241 Physical and Data Link Layers Surasak Sanguanpong nguan@ku. ac. th http: //www. cpe. ku. ac. th/~nguan Last updated: May 24, 1999 Applied Network Research Group Department of Computer Engineering, Kasetsart University
/242 Networks Devices LANs Bridge Hub Switch Router ATM Switch WANs X. 25 or Frame Relay Switch Modem CSU/DSU TA/NT 1 S Applied Network Research Group Comm. Server Multiplexer stat mux Department of Computer Engineering, Kasetsart University
/243 Hub Application Presentation Session Transport Network Datalink Physical HUB Applied Network Research Group Department of Computer Engineering, Kasetsart University
/244 Common Data Links Ethernet Token Ring FDDI Dual Ring Applied Network Research Group Point-to-point Department of Computer Engineering, Kasetsart University
/245 LAN/WAN layers comparison LAN Data Link )frames( Physical )bits, signals, clocking( E t h e r n e t WAN X. 25 Link ISDN 802. 2 LLC 8 0 2. 3 8 0 2. 4 8 0 2. 5 Dial on SDLC HDLC Demand Frame PPP Relay F D D I V. 24 EIA/TIA-232 G. 703 V. 35 EIA/TIA-499 EIA-530 HSSI • Separate physical and data link layer for LAN and WAN Applied Network Research Group Department of Computer Engineering, Kasetsart University
/246 Medium Access Control l Protocol for controlling access to transmission medium Defined as part of Data Link layer The protocol performs: n n perform functions related to medium access (MAC sublayer( concerned with the transmission of a link-level between two nodes (LLC sublayer( Network Data Link Physical Applied Network Research Group LLC Logical Link Control sublayer MAC Medium Access Control sublayer Department of Computer Engineering, Kasetsart University
/247 Ethernet and IEEE 802. 3 10 Base 2 - Thin Ethernet hub bridge 10 Base 5 - Thick Ethernet hub router server 10 Base. T-Twisted pair Applied Network Research Group Department of Computer Engineering, Kasetsart University
/248 Ethernet/802. 3 Operation l Every node can receive a transmission by all other nodes l need addressing scheme to identify a destination l only destination copies frame to it, all other nodes have to discarded the frame A B C C finds the bus is free A B ignores frame C terminator A C B A C transmits frame addressed to A A B C A A copies frame signal is absorbed by the terminators Applied Network Research Group Department of Computer Engineering, Kasetsart University
/249 Token Ring and IEEE 802. 5 Token Ring • IBM’s token ring is equivalent to IEEE 802. 5 Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2410 Token Ring/802. 5 Operation T A T=0 T A T T=1 Data • Token Ring LANs continuously pass a token or a Token Ring frame Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2411 Fiber Distributed Data Interface (FDDI( FDDI Dual Ring 100 Mbps • Devices on FDDI maintain connectivity on dual counterrotating rings Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2412 FDDI Dual-Homed SAS DAC SAS DAS • Devices attached to FDDI use token passing Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2413 Common WAN Technologies SDLC HDLC LAPB PPP X. 25 Frame Relay ISDN Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2414 Physical Layer: WAN RS-232 V. 35 X. 21 HSSI others DSU/CSU )Modem( DTE Data Terminal Equipment End of the users device on the WAN link Applied Network Research Group DCE Data Circuit-terminating Equipment End of the WAN providers side of the communication facility Department of Computer Engineering, Kasetsart University
/2415 Data Link Layer: WAN protocols )Modem( DSU/CSU l DSU/CSU SDLC--Synchronous Data Link Control For IBM SNA networks; primary and secondary roles on link l HDLC--High-level Data Link Control Common WAN data link l LAPB--Link Access Protocol, Balanced DTE-to-DCE data link for X. 25; either side initiates a link l Frame Relay--Simplified version of HDLC framing for higher speed, unacknowledged data communications l PPP--Point-to-Point Protocol Part of TCP/IP stack for WAN links; can support ISDN Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2416 SLIP : Serial Line IP l l l Method for encapsulation IP datagrams on serial line RFC 1005 de facto standard Popular for connecting home computer to Internet, via modem SLIP with Remote Connection Workstation RS-232 modem SLIP Host modem RS-232 Dialup or Leased Line SLIP with Direct Connection RS-232 Applied Network Research Group RS-232 Department of Computer Engineering, Kasetsart University
/2417 SLIP frame format l Simple : no header, just a framing character around data l l Use 0 x. C 0 (SLIP END) to terminate datagrams SLIP ESC is 0 x. DB if found 0 x. C 0, substitute with 0 x. DB 0 x. DC if found 0 x. DB, substitute with 0 x. DB 0 x. DD IP datagrams C 0 DB DB DC DB DD C 0 SLIP encapsulation Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2418 SLIP deficiencies l l Need manual configuration of IP address both sides (no negotiating mechanism( Only one protocol can be used because there is no field to specify type of protocol No checksum; bad for protocols that depend on CRC! Slow line make inefficient to carry only 1 byte date with 40 bytes overhead (IP+ TCP header( l l l CSLIP (Compress SLIP) reduces 40 byte headers to 3 -5 bytes known as Van Jacobson Compression (see RFC 1144( smaller headers greatly improve the interactive response time Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2419 PPP: Point-to-Point Protocol l l Method for encapsulation IP datagrams on serial line, correct all deficiencies in SLIP Support either an asynchronous link with 8 N 1 or bit-oriented synchronous link Two parts: l LCP (Link Control Protocol) to establish, configure and test connection l NCP (Network Control Protocol) support different network layer protocols RFC 1548 specifies encapsulation method RFC 1322 NCP Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2420 PPP frame format l l l Each frame begins and ends with a flag 0 x 7 E. Followed by an address byte whose value is always 0 x. FF, and then a control byte, with a value of 0 x 03. To solve flag 0 x 7 E in information field: l l On a synchronous link is done by the hardware bit stuffing. On asynchronous links the 0 x 7 D is used 2 Flag 7 E Addr FF 1 Control 03 Applied Network Research Group 1 1 up to 1500 bytes Protocol LCP Protocol 0021 IP datagrams Protocol C 021 Link Control Data Protocol 8021 Network Control Data 2 1 FCS Flag 7 E Department of Computer Engineering, Kasetsart University
/2421 PPP framing l l Like ISO HDLC standard and use 0 x 7 D as Escape Character Replace 0 x 7 E with 0 x 7 D, 0 x 5 E Replace 0 x 7 D with 0 x 7 D, 0 x 5 D A byte value less than 0 x 20 e. g. 0 x 10 is transmitted with 0 x 7 D, 0 x 21 7 E 7 D 01 1 ESC 7 D 5 E 7 D 5 D 1 1 Applied Network Research Group 1 ESC 1 7 D 21 1 1 Department of Computer Engineering, Kasetsart University
/2422 PPP advantage l l Support multiple protocols CRC for every frame Dynamic negotiation of the IP address for each end Link control protocol for negotiating data-link options Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2423 WAN Frame Format Summary Link Control Protocol (LCP( Code identifier Length Data PPP Flag Address Control Protocol Control Proprietary LCP FCS Flag Cisco HDLC Flag Address Data SDLC, LAPB, and Frame Relay Flag Address Applied Network Research Group Control Data Department of Computer Engineering, Kasetsart University
/2424 Loopback Interface l l channel for client and server on the same host use to communicate Class A network ID 127 is reserved for the loopback interface Most system assigns 127. 0. 0. 1 with the name localhost Loopback interface appears as another link layer to the network layer Applied Network Research Group Department of Computer Engineering, Kasetsart University
/2425 Summary l l The physical layer provides access to the wires of an internetwork The data link layer provides support for communications over several types of data links: LAN (Ethernet/IEEE 802. 3, Token Ring/IEEE 8025, FDDI( Dedicated WAN (SDLC, HDLC, PPP, LAPB( Switched WAN (X. 25, Frame Relay, ISDN( Applied Network Research Group Department of Computer Engineering, Kasetsart University

























