RFC 2889 Traffic Type Support in OPNFV VSPERF









- Slides: 9
RFC 2889 Traffic Type Support in OPNFV VSPERF Sridhar K. N. Rao Spirent Communications 1 -June-2016
RFCs • RFC – RFC 2889: Benchmarking Methodology for LAN Switching Devices – RFC 2285: Benchmarking Terminology for LAN Switching Devices
Test Case Metrics • Forwarding Rate: Number of frames per second that a device can be observed to successfully transmit to the correct destination interface in response to a specified offered load. • Address Learning Rate and Caching-Capacity: Highest measure learning rate that was successful and ‘address-capacity’. • Congestion Control: – HOLB: Frame loss or added delay observed on an uncongested output interface whenever frames are received from an input interface which is also attempting to forward frames to a congested output interface. – Forward Pressure: Methods which depart from or otherwise violate a defined standardized protocol in an attempt to increase the forwarding performance of a DUT/SUT.
Corresponding Result-Constants • FORWARDING_RATE_FPS • NOF_ADDRS_FLOOD_COUNT_RATIO – Flood count indicates destination address is not in the table) • CONGESTION_CONTROL_EXISTS – HOLB or FORWARD PRESSURE? ?
Input Parameters • Inputs for the new traffic-type functions • Existing: – Frame Sizes – Duration – Num_of_pkts – Trials – Loss_rate – Traffic-Parameters • New: – Burst Size list. – Aging time?
SOURCE CHANGES
Component Factory • Current: return Traffic. Controller. RFC 2544 • The parameter “traffic_type” is unused – For any traffic_type just return Traffc. Controller. RFC 2544() – We will use this parameter to Identify the Traffic. Controller. • If traffic_type is == rfc 2889 – Then return Traffic. Controller. RFC 2889 • else – return Traffic. Controller. RFC 2544 •
Traffic Controller: • Traffic. Controller. RFC 2889 – Will also inherit from ITraffic. Controller and Iresults – Member functions • append_results • send_traffic – Would call any one of the following, which is implemented in trafficgen class » send_rfc 2889_forwarding_rate » send_rfc 2889_learning_caching » send_rfc 2889_congestion • send_traffic_async – Start and wait functions • stop_traffic • print and get results.
Configuration • • • | "Name": "phy 2 phy_2889" | "Traffic Type": "rfc 2889_forwarding" | "Deployment": "p 2 p", | "bi. Directional": "True", | "Description": " RFC 2889 Forwarding Test"









