MPEG 2 TS over IP irinosfc wide ad

  • Slides: 16
Download presentation
MPEG 2 -TS over IPの設計と実装 入野 仁志 irino@sfc. wide. ad. jp 親: akimichiさん サブ親:

MPEG 2 -TS over IPの設計と実装 入野 仁志 irino@sfc. wide. ad. jp 親: akimichiさん サブ親: uhyoさん

MPEG 2 n n フレーム間圧縮方式 MPEG 2 -PS(Program Stream) n n n MPEG 2

MPEG 2 n n フレーム間圧縮方式 MPEG 2 -PS(Program Stream) n n n MPEG 2 -TS(Transport Stream) n n 可変長のデータ DVDなど 188 byte固定長のデータ 放送などに使われる。PSに比べてデータ構造が冗長的 D-VHSなど PES (Packetized Elementary Stream)を介してTS-PS相 互変換可能

MPEG 2 -TS n < 28. 2 Mbps(1080 i/720 p) n n n <

MPEG 2 -TS n < 28. 2 Mbps(1080 i/720 p) n n n < 14. 1 Mbps(480 p/480 i) n n DVHS HS mode(14. 4 Mbps) HD仕様BSデジタル放送(約22 Mbps) DVHS STD mode(12 Mbps) Micro. MV(12 Mbps) SD仕様BSデジタル放送(7 Mbps強) < 7. 0 Mbps(480 i) n DVHS LS 2

DVとMPEG 2 -TS n DV n n n フレーム内圧縮 30 Mbps(SD) DIF Block(80 byte)

DVとMPEG 2 -TS n DV n n n フレーム内圧縮 30 Mbps(SD) DIF Block(80 byte) n MPEG 2 -TS n n n フレーム間圧縮 14. 1 Mbps(SD) MPEG 2 -TS packet(188 byte) 多重化可能 映像音声以外にシ ステム情報を含む

本システムの設計 Receiver Output Device Sender Input Device (Source) Analog Source Analog Signal DVHS n

本システムの設計 Receiver Output Device Sender Input Device (Source) Analog Source Analog Signal DVHS n Mpeg 2 -TS over IEEE 1394 PC Mpeg 2 -TS over IP DVHS PC Mpeg 2 -TS over IEEE 1394 TV w/ BS digital receiver 送信側 n n Internet Micro. MV Camera Micro. MVカメラやDVHSのA/D変換を利用してMPEG 2 -TSを生成 受信側 n BSデジタル受信機能内蔵のTVやDVHSのD/A変換を利用して 映像を鑑賞

システム設計(ネットワーク部分) n 設計目標 n RTP, RTCP n n RFC 1889, RFC 1890 RFC 2250(RTP

システム設計(ネットワーク部分) n 設計目標 n RTP, RTCP n n RFC 1889, RFC 1890 RFC 2250(RTP Payload Format for MPEG 1/MPEG 2 Video. ) Multicast IPv 6

インターネット上を流れるパケット n RFC 2250 n RTPペイロード部分に 188 byteのMPEG 2 -TS データを複数入れる。 n IP Header(20

インターネット上を流れるパケット n RFC 2250 n RTPペイロード部分に 188 byteのMPEG 2 -TS データを複数入れる。 n IP Header(20 Byte or 40 Byte) UDP Header(8 byte) RTP Header(12 Byte) MPEG 2 -TS(188 byte) MTU 1500の場合7個の MPEG 2 -TSデータが入る MPEG 2 -TS(188 byte)

実装 n 実装環境 n Linux Kernel 2. 4. 19+Usagi Libraw 1394 n C言語(gcc 3.

実装 n 実装環境 n Linux Kernel 2. 4. 19+Usagi Libraw 1394 n C言語(gcc 3. 2) n MPEG 2機器としてDVHS n n 日立DT-DR 20000 Victor HM-DH 3000(DVフォーマットもデコード可) STD modeを対象とする n n SD仕様 (480 i)(現行TV相当) 12 Mbps

LinuxのIEEE 1394の扱い方 User Space libraw 1394 /dev/sda scsi core sbp 2. o /dev/raw 1394

LinuxのIEEE 1394の扱い方 User Space libraw 1394 /dev/sda scsi core sbp 2. o /dev/raw 1394 /dev/video 1394 raw 1394. o Video 1394. o Ieee 1394. o ohci 1394. o Kernel Space