TLS SSLv 2 RFC 6176 SSLv 3 POODLE

  • Slides: 14
Download presentation

TLS: история • SSLv 2 небезопасен (RFC 6176) • SSLv 3 небезопасен (POODLE) •

TLS: история • SSLv 2 небезопасен (RFC 6176) • SSLv 3 небезопасен (POODLE) • TLS 1. 0 – RFC 2246 (1999) • TLS 1. 1 – RFC 4346 (2006) • TLS 1. 2 – RFC 5246 (2008) Sourсe: https: //www. trustworthyinternet. org/ssl-pulse/

Тысяча мелочей Ø Goto fail – уязвимость в Safari https: //gotofail. com/ Ø Уязвимость

Тысяча мелочей Ø Goto fail – уязвимость в Safari https: //gotofail. com/ Ø Уязвимость в Gnu. TLS http: //www. gnutls. org/security. html#GNUTLS-SA-2014 -2 Ø Уязвимость в продуктах Microsoft https: //technet. microsoft. com/library/security/MS 14 -066 Ø Не найдено проблем в NSS

Все идет по плану - II Certificate pinning ВНЕДРЯЕТСЯ • Google Chrome – давно

Все идет по плану - II Certificate pinning ВНЕДРЯЕТСЯ • Google Chrome – давно • Firefox 32+ • Internet Explorer Certificate transparency ВНЕДРЯЕТСЯ • Google Chrome • С начала 2015 обязательна регистрация EVсертификатов в лог-сервисах http: //www. certificate-transparency. org/ev-ctplan

Все идет по плану - III Шифрование трафика • Google ранжирует сайты по HTTPS

Все идет по плану - III Шифрование трафика • Google ранжирует сайты по HTTPS выше • Universal SSL от Cloud. Flare • Шифрование по умолчанию http: //www. internetsociety. org/news/internetsociety-commends-internet-architecture-boardrecommendation-encryption-default IETF: DNS Privacy, TLS 1. 3… Let's Encrypt • https: //letsencrypt. org/

Новые алгоритмы Шифр Cha 20 + MAC Poly 1305 Эллиптические кривые: быстрее, чем 2048

Новые алгоритмы Шифр Cha 20 + MAC Poly 1305 Эллиптические кривые: быстрее, чем 2048 -битные RSA-ключи • Apache умеет 2 сертификата на домен, nginx – пока нет https: //securitypitfalls. wordpress. com/2014/10/06/ rsa-and-ecdsa-performance/ Perfect Forward Secrecy