SIP Speaker JiaYu Wang Adviser Quincy Wu Date






















- Slides: 22
以SIP 為基礎之整合式語 音信箱系統 Speaker: Jia-Yu Wang Adviser: Quincy Wu Date: 2007/08/31 1
outline l SIP (Session Initiation Protocol) l l l 以SIP 為基礎之整合式語音信箱系統 l l SIP訊息流程 SIP封包格式 SIP Headers SDP (Session Description Protocol ) 主要目標與成果 錄製、聽取語音留言流程圖 實作成果 Reference 2
SIP (Session Initiation Protocol) l 由IETF的MMUSIC (Multiparty Multimedia Session Control) Working Group開發 l l RFC 2543 - SIP: Session Initiation Protocol RFC 3261 - SIP: Session Initiation Protocol (RFC 3261取代了RFC 2543) 3
SIP (Session Initiation Protocol) l l A Signaling Protocol 使用 IP Client / Server 架構 相似於 HTTP的文字編碼方式 l l l sip: andy@hit. edu. tw sip: +886424961356@hit. edu. tw Request and Response 4
SIP (Session Initiation Protocol) l l SIP的訊息格式 (HTTP 1. 1) l RFC 2616 描述媒體的連線 l (SDP) RFC 2327 媒體(RTP) l RFC 3550 定址方式 (URI) l (URI) RFC 2396 5
SIP (Session Initiation Protocol) 6
SIP Request methods l RFC 3261 l l l REGISTER INVITE ACK BYE OPTIONS CANCEL 7
SIP封包格式 SIP SDP INVITE sip: bob@zzz. edu SIP/2. 0 Via: SIP/2. 0/UDP pc 33. yyy. edu; branch=z 9 h. G 4 b. K 776 asdhds Max-Forwards: 70 To: Bob <sip: bob@zzz. edu> From: Alice <sip: alice@yyy. edu>; tag=1928301774 Call-ID: a 84 b 4 c 76 e 66710@pc 33. yyy. edu CSeq: 314159 INVITE Contact: <sip: alice@pc 33. yyy. edu> Content-Type: application/sdp Content-Length: 142 v=0 o=Alice 2897654321 IN IP 4 10. 0. 0. 1 s=Phone Call c=IN IP 4 192. 168. 0. 1 t=0 0 m=audio 49170 RTP/AVP 0 a=rtpmap: 0 PCMU/8000 10
SIP Headers INVITE sip: bob@zzz. edu SIP/2. 0 Via: SIP/2. 0/UDP pc 33. yyy. edu; branch=z 9 h. G 4 b. K 776 asdhds Max-Forwards: 70 To: Bob <sip: bob@zzz. edu> From: Alice <sip: alice@yyy. edu>; tag=1928301774 Call-ID: a 84 b 4 c 76 e 66710@pc 33. yyy. edu CSeq: 314159 INVITE Contact: <sip: alice@pc 33. yyy. edu> Content-Type: application/sdp Content-Length: 142 11
SDP (Session Description Protocol ) l l l l v=0 o=Alice 2897654321 IN IP 4 10. 0. 0. 1 s=Phone Call c=IN IP 4 192. 168. 0. 1 t=0 0 m=audio 49170 RTP/AVP 0 a=rtpmap: 0 PCMU/8000 12
SDP (Session Description Protocol ) l l v= (protocol version) 意思是目前傳送的SDP版本(SDP Version 0),例如: v=0。 o= (owner/creator and session identifier) 描述連線的來源端訊息,Origin的縮寫。 o=<username> <session id> <version> <network type> <address> l l 例如: o=Alice 2897654321 IN IP 4 10. 0. 0. 1 s= (session name string) 主叫端用來描述會談名稱,例如: s=Phone Call c= (Connection infomation) (可省略) 描述連線訊息,例如: c=IN IP 4 192. 168. 0. 1 13
SDP (Session Description Protocol ) l l l t= (start time and stop time) 定義協定訊息發送後的一段有效期間。一般來說不太需要用到, 但是不可省略,因此常會輸入 0值來傳送,例如: t=0 0 m= (media name and transport address) 媒體名稱及傳送位址,m=<media> <port> <transport> <format list> 例如:m=audio 49170 RTP/AVP 0 a= (media Attributes) 描述媒體編碼型式和相關支援能力參數, 例如:a=rtpmap: 0 PCMU/8000 14
實作成果: Web-based語音留言操作畫面 http: //ms 11. voip. edu. tw/~jiayu/meeting/20070831/web-listen. htm 20
實作成果 l VMS錄製、聽取語音留言 l l l http: //ms 11. voip. edu. tw/~jiayu/meeting/20070831/Recording. htm http: //ms 11. voip. edu. tw/~jiayu/meeting/20070831/Listen. htm IVR聽取語音留言 l l l http: //ms 11. voip. edu. tw/~jiayu/meeting/20070831/IVRS_listen. mpg http: //ms 11. voip. edu. tw/~jiayu/meeting/20070831/IVRS_quick_listen. mpg http: //ms 11. voip. edu. tw/~jiayu/meeting/20070831/IVRS_listen_by_moblie_phone. mpg 21
Reference l Wi. Ki-SIP l l 網路電話SIP原理與應用 l l http: //zh. wikipedia. org/w/index. php? title=SIP&variant=zh-tw 戴江淮、姜玲鳳,儒林,2005 SIP: Session Initiation Protocol l RFC 3261 22