Policybased Accounting Draft Update Tanja Zseby Sebastian Zander
Policy-based Accounting Draft Update Tanja Zseby, Sebastian Zander Fraunhofer Institute FOKUS Competence Center for Global Networking (Glo. Ne) [zseby, zander]@fokus. fhg. de http: //www. fokus. fhg. de December 14, 2001
Comments on Draft reviewed by IESG Several comments received – Wording/Clarification – Terminology – Technical Issues New version sent to the AAAARCH list Plan: – Include result from discussion today – Submit revised I-D ASAP December 14, 2001 2
Wording/Clarification Motivation/problem statement enhanced Clarified that providers need to agree on allowed policies beforehand (for accounting agreements between providers, roaming ) Clarified that metering/collection policies can be derived from accounting policies Clarified that accounting policies do not configure charging and billing process Clarified that policies can consist of multiple rules Accounting Policy Attributes (differ from accounting attributes) – Section split into subsections: accounting policy condition, and policy action – Rephrased: variables in policy condition/action – New attributes explained More realistic values in examples Usage of the word “enforced”: policies are enforced by the network elements References for Diff. Serv, bandwidth broker, mobile IP included Typos, crossreferences December 14, 2001 3
Terminology (1) Meter, Reader/Collector, Manager – As used in RFC 2722 (RTFM) – Meter includes classifier (differs from Diff. Serv definition) Meter This document uses the definition of meter as given in [RFC 2722]. This meter definition already includes the classification of packets. With this it differs from the Diff. Serv model [RFC 2475] where classifier and meter are considered as separate entities. Classifier/Filter – As used in RFC 2475 (Diff. Serv) – Used only for additional (external) classification Classifier This document uses the definition of classifier as given in [RFC 2475]. Since this document assumes that meters already include classification functions, the term classifier is only used for entities that perform additional classification (e. g. as part of data post processing). December 14, 2001 4
Terminology (2) Service Class – Service definition taken from policy terminology draft – Service class: service with specific properties Service Class A service class specifies the handling of a service (as defined in [RFC 3198]) belonging to that class by the service provider. A service class has some kind of identifier (e. g. name) and the handling of the service is defined by a Service Level Specification (SLS) as described in [RFC 3198]. December 14, 2001 5
Technical Issues (1) Accounting describes the collection of data about resource consumption. This includes the control of data gathering (via metering), transport and storage of accounting data. . . Comment: Accounting as one particular layer in accounting architecture which only provides specific accounting functions […] is confusing Model in draft Accounting Alternative Model Accounting AAA Architecture AAA ASM Collection Metering December 14, 2001 Service Equipment 6
Technical Issues (2) Does AAA configure services ? – General issue for AAAARCH group – Already some discussion on mailing list – Maybe just clarification needed: • not the AAA server but the ASM configures the service • AAA servers only forward configuration data (like RADIUS passes configuration information to clients) Other Opinions ? December 14, 2001 7
Thank you for your attention ! December 14, 2001
- Slides: 8