Network Security Kerberos Tuomas Aura T110 5240 Network
Network Security: Kerberos Tuomas Aura T-110. 5240 Network security Aalto University, Nov-Dec 2012
Outline Kerberos authentication Kerberos in Windows domains 2
Kerberos authentication 3
Kerberos Shared-key protocol for user login authentication Uses passwords as shared keys Solves security and scalability problems in password-based authentication in large domains Based loosely on the Needham-Schroeder secret-key protocol Kerberos v 4 1988 - at MIT Kerberos v 5 1993 - [RFC 4120] Updated protocol and algorithms ASN. 1 BER message encoding Implemented in Windows 2000 and later Used in intranets: e. g. university Unix systems, corporate Windows domains 4
Kerberos architecture 1. – 2. Authentication 3. – 4. Ticket for a specific service 5. – 6. Authentication to the service 5
Kerberos architecture (some details) 1. – 2. Authentication with password → client gets TGT and KAT 3. – 4. Authentication with TGT and KAT → client gets service ticket and KAB 5. – 6. Authentication with service ticket and KAB → client gets service access 7
Kerberos ticket Message type, version FLAGS KEY CNAME, CREALM Client name and realm TRANSITED transit realms AUTH-TIME, END-TIME CADDR Client IP address (optional) AUTORIZATION-DATA App-specific access constraints Encrypted with server’s master key REALM, SNAME Server name and realm Same format for both TGT and service ticket Credentials = ticket + key ASN. 1 encoding in Kerberos v 5 “Encryption” also protects integrity, actually encryption and a MAC Flags: FORWARDABLE, FORWARDED, PROXIABLE, PROXY, MAY-POST-DATE, POSTDATED, INVALID, RENEWABLE, INTINIAL, PRE-AUTHENT, HW-AUTHENT INITIAL flag indicates TGT 8
Kerberos protocol (more details) Initial login of user A: 1. 2. A → AS: AS → A: Preauthentication, A, TGS, NA 1, Addr. A A, TGT, EKA (KA-TGS, NA 1, TGS, Addr. A) 3. 4. A → TGS: TGS → A: TGT, Authenticator. A-TGS, B, NA 2, Addr. A A, Ticket, EKA-TGS (KAB, NA 2, B, Addr. A) 5. 6. A → B: B → A: Ticket, Authenticator. AB AP_REP Ticket request: Authentication to server B: KA , KTGS, KB = master keys of A, TGS and B KA-TGS = shared key for A and TGS KAB = shared key for A and B TGT = B, EKTGS (INITIAL, KA-TGS, A, Tauth, Texpiry 1, Addr. A)) Ticket = B, EKB(KAB, A, Tauth, Texpiry 2, Addr. A)) Preauthentication = EKA (1 TA) Authenticator. A-TGS = EKA-TGS (2 TA) Authenticator. AB = EKAB (3 TA) AP_REP = EKAB(4 TA) A, B = principal names Tx = timestamp Addr. A = A’s IP addresses Notes: 1234) ASN. 1 encoding adds type tags to all messages Encryption mode also protects message integrity 9
Kerberos realms Users and services registered to one KDC form a realm name@realm, e. g. A@X, alice@asia. sales. contoso. com Cross-realm trust: Two KDCs X and Y share a key (krbtgt@Y is registered in KDC X and krbtgt@X in KDC Y) KDCs believe each other to be honest and competent to name users in their own realm Cross-realm authentication: Client A@X requests from TGS at realm X a ticket for TGS at realm Y The ticket is encrypted for krbtgt@Y (i. e. TGS at realm Y) Client A@X requests from TGS at realm Y a ticket for server B@Y Access control at several steps: Local policy at each KDC about when to honor tickets from other realms Local policy at B@Y about whether to allow access to users from other realms ACLs at B@Y determine whether the users is allowed to access the particular resources Possible to transit multiple realms → TRANSITED field in the ticket lists intermediate realms Local policy at each server about which transit realms are allowed 11
Realm hierarchy Large organizations can have a realm hierarchy Hierarchy follows internet names → easy to find a path between realms → can filter cross-realm requests based on the names Can add shortcut links or create even a fully connected graph between KDCs E. g. Windows domain hierarchy Compare with X. 509 certification hierarchy: similarities, differences? 12
Password guessing attacks Kerberos is vulnerable to password guessing: Sniffed KRB_AS_REQ or KRB_AS_REP can be used to test candidate passwords → offline brute-force password guessing In Kerberos v 4, anyone could request a password-encrypted TGT from AS → easy to obtain material for password cracking Preauthentication in Kerberos v 5 prevents active attacks to obtain material for password cracking → must sniff it ! Note: active vs. passive attacks Misleading thinking: active attacks (e. g. Mit. M) are more difficult to implement than passive attacks (sniffing) Reality: Active attacks can often be initiated by the attacker while passive attacks require attacker to wait for something to sniff → vulnerability to such active attacks is serious ! 13
PKINIT Goal: take advantage of an existing PKI to bootstrap authentication in Kerberos Replaces the KRB_AS_REQ / KRB_AS_REP exchange with a public-key protocol Public-key authentication and encryption to obtain TGT Continue with standard Kerberos → transparent to TGS and application servers No password, so not vulnerable to password guessing Uses DSS signatures and ephemeral DH Windows 2000 and later, now standard [RFC 4556] 14
Delegation Server may need to perform tasks on the client’s behalf Recursive RPC; agents operating when the user is no longer logged in; batch processing at night Alice can give her TGT or service ticket and key to David Controlling the use of delegated rights in applications: Ticket may specify many allowed client IP addresses Authorization-data field in ticket may contain app-specific restrictions It is safer to delegate a service ticket than TGT Ticket flags related to delegation: FORWARDABLE flag in TGT: the TGT can be used to obtain a new TGT with different IP addresses PROXIABLE flag in TGT: the TGT can be used to obtain service tickets with a different IP address Kerberos delegation is identity delegation When B has A’s ticket and key, B can act as A and nobody can tell the difference → difficult to audit access; similar to sharing passwords Other protocols delegate only access rights, and the delegate can be identified 16
Kerberos in Windows domains Thanks to Dieter Gollmann 17
Windows access control summary The O/S stores security attributes for each processes (subject) in an access token Token contains a list of privileges and SIDs (i. e. user and group identifiers) Permissions are decided by comparing the list of SIDs against a DACLs on an object The access token is local to the machine, created at login time, and never sent over the network How to authorize access to resources managed by a Windows service (=daemon) on a remote server, e. g. over remote procedure call (RPC)? 18
Network credentials Alice’s user name, SID and network credentials are cached on the user workstation username and password, or TGT and KA-TGS Alice’s processes can use her network credentials for remote login Two authentication protocols: NTLM and Kerberos V 5 (RFC 1510) These authentication protocols do not reveal the password to the server Applications can also ask the user for a different user name and credentials and store them separately 19
Tokens and remote access Access tokens are meaningful only to the local machine and cannot be sent over network The server does not trust the client machine to tell who Alice is and which groups she belongs to Instead, the client authenticates Alice to the server using her network credentials. The server creates a new login session and a new token (on the server) for Alice The service may now assign the token to a process or thread (=impersonation) The authentication protocols also provide the server with Alice’s user and group SIDs produce a session key for protecting data between the client and server Encryption and authentication of session data is controlled by applications Different secure session protocol exist for network logon, RPC, COM 20
Kerberos ticket in Windows Message type, version FLAGS KEY Username, domain CNAME, CREALM Client name and realm TRANSITED transit realms AUTH-TIME, END-TIME User and group SIDs CADDR Client IP address (optional) AUTORIZATION-DATA App-specific access constrains Encrypted with server’s master key REALM, SNAME Server name and realm 22
Related reading William Stallings. Network security essentials: applications and standards, 3 rd ed. chapter 4. 1; 4 th ed. chapter 4. 1– 4. 2 (Kerberos v 5 only) William Stallings. Cryptography and Network Security, 4 th ed. : chapters 14. 1 (Kerberos v 5) Dieter Gollmann. Computer Security, 2 nd ed. : chapter 12. 4; 3 rd ed. chapter 15. 4 Kaufmann, Perlman, Speciner. Network security, 2 nd ed. : chapter 14 Online: How the Kerberos Version 5 Authentication Protocol Works, http: //technet. microsoft. com/en-us/library/cc 772815(v=ws. 10). aspx 23
Exercises How does Kerberos fix the flaw in Needham-Schroeder secret-key protocol? Find source code for a Kerberized client/server application (e. g. telnet) and see how it accesses Kerberos services Why is Kerberos used on the intranets and TLS/SSL on the Internet? Could it be the other way? Learn about Encrypted Key Exchange (EKE) and other similar password-based authentication protocols. Which problem do they solve? Should standard protocols include data fields or messages for proprietary extensions? What are the arguments for and against? 24
- Slides: 20