Multimedia Datenformate MIME Multipurpose Internet Mail Extensions Robert
Multimedia - Datenformate MIME Multipurpose Internet Mail Extensions Robert Kämpf HRZ, TU Darmstadt Kaempf(at)hrz. tu-darmstadt. de http: //www. tu-darmstadt. de/hrz/media
Inhalt • • • ASCII - E-Mail Zeichensätze Binärdaten Multimedia-Mail zu Fuß MIME - E-Mail WWW und MIME
E-Mail historisch • Mitte 80 er Jahre • E-Mail (Textmitteilung) z. B. auf Großrechnern • Rechner A zu Rechner B • Protokolle – SNA, DECNET, X 25 – BITNET, EARN – Programme der Hersteller z. B. VMS-Mail A B
E-Mail und IP (Internet) • E-Mail Transport von A nach B SMTP (Simple Mail Transfer Protokoll) RFC 821 • E-Mail Format für formale Angaben (Absender, Empfänger, Datum, etc) RFC 822 • einheitliche Festlegung für das Internet, über Länder- und Systemgrenzen. • Klassische Post gibt Größen auch vor: Anschrift, Länderkennung, Postleitzahl
Was ist ein RFC ? • Request For Comments • Arbeitsgruppen machen Vorschläge auf Basis von vorhandenen Lösungen. • Verabschiedung • Entspricht DIN im Internet, aber – unkomplizierter – praxisnäher – schneller
SMTP RFC 821 • Verbindungsaufbau: Port 25/tcp • Kommandos – – – HELO MAIL FROM: RCPT TO: DATA. QUIT Sender-Hostname Absender Empfänger Start der Datenübertragung Ende der Verbindung
Mailformat RFC 822 • Brief-Kopf (Header) – – – From: To: Date: Subject: CC: Reply-To: • Leerzeile • Brief-Inhalt (Body) • Zeichensatz: ASCII (7 -Bit) Absender Empfänger Datum Betreff Kopien Antwort-Adresse
SMTP E-Mail (RFC 821/822) • Weltweite Übertragung von E-Mail • Funktioniert perfekt mit ASCII-Zeichensatz (englische Texte) • Text ist in Zeilen gegliedert (Zeilen haben weniger als 998 Zeichen) • Herstellerunabhängig
Problem 1: Sonderzeichen • Europäische Texte haben Sonderzeichen Umlaute (ÄäÖöÜüß), Akzente (á, à, â). • ASCII kenne keine Sonderzeichen • Zwischenlösung: 7 -Bit ASCII mit Umlauten statt z. B. [ { } ] – nicht international möglich – abhängig vom Hersteller • Zeichensätze mit Sonderzeichen sind 8 -Bit – Übertragung per E-Mail führt zu Verlust oder Veränderung der Sonderzeichen
Internationale Zeichensätze • 7 -Bit: ASCII • 8 -Bit: IBM PC Codepage 850 – DOS – Umlaute, Akzente und Grafiksonderzeichen • 8 -Bit: ISO-8859 -1 (ISO Latin 1) – – alle Sprachen mit lateinischen Zeichen genormt Verbreitet bei UNIX-Workstations (Linux!) Auch bei Mircosoft - ab Windows 95 Zwei Zeichensätze bei Microsoft auf einem System: Speichern als Text: DOS-Text / Windows-Text
7 -Bit: ASCII
8 -Bit: IBM PC (Codepage 850)
8 Bit: ISO 8859 -1 (ISO Latin 1)
Problem 2: Binäre Daten kommen überall vor: • Dokumente aus Textprogrammen – Textinformationen und – Formatierungsinformationen !!! • Bilddateien, Audiodateien, Mediendateien • Programme Standard 7 -Bit ASCII Mail geht nicht !!!
Aus- oder Umwege zu 7 -Bit Problem 1: Sonderzeichen • Texte werden mit umschriebenen Umlauten als 7 -Bit ASCII verschickt: Ae, Oe, Ue, ae, oe, ue und ss • Andere Sonderzeichen sind schwieriger Problem 2: Binärdateien • Binäre Dateien werden vor dem Verschicken in das ACSII-Format konvertiert.
Multimedia-E-Mail zu Fuß • Encoding: Umwandlung von 8 -Bit in 7 -Bit ASCII • Hex-Ersetzungstabelle: – Byte: 8 -Bit 1010 0101 – Hex-Ziffer: 4 -Bit A – zwei Hex-Ziffern 2 x 4 -Bit 0100 0001 – 16 Hex-ASCII-Ziffern 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, F – doppelter Speicherplatz 3 0011 • optimierte Umwandlung: 3 in 4 – Hex nutzt 4 Bit, 16 ASCII-Zeichen – 6 Bit entsprechen 64 ASCII-Zeichen – Speicherplatz nimmt nur um 1/3 zu 3 x 8=4 x 6
uuencode • • • 8 6 8 8 6 6 6 3 x 8 -Bit aufteilenin 4 x 6 -Bit in ASCII umwandeln (+32 d, ASCII Space) „begin“-Zeile mit Dateinamen Zähler + 60 Zeichen/Zeile (45 Bytes) leere Zeile und „end“-Zeile begin 644 text. iso M 2&%L; &@4 F]B 97)T("$@"@I*971 Z="!G<OS? 92!I 8 V@@1&EC: "!M: 70@=FEE M; &5 N('-C: /9 N 96 XL('/WV 5 N(%5 M; &%U=&5 N+"`*<V@9&'? ($1 U(&IE='IT M(&%U 8 V@@<75 O=&5 D+7!R: 6 YT 86)L 92!Z 96 EG 96 X@: V%N; G-T+B`*"EIU; 2!4 J 97 -T. B#$UMP@Y/; (-@/2`*"E 9 I 96 P@4 W!AWPI 2; V)E<G 0@2^1 M<&8* ` end reine ASCII Datei
Multimedia-Mail zu Fuß - Sender • Umwandeln der binären Multimedia-Datei in ASCII • Mail an Empfänger schreiben (ASCII) Folgende Informationen dem Empfänger geben: 1 Ausgangsformat: z. B. Wordstar 2 Umwandlungsverfahren/Format: z. B. uuencode 3 Dateiname (falls nicht in Umwandlung enthalten) 4 Trennlinie (-----schnipp-----8<-------) • Einfügen der umgewandelten Datei als ASCII-Text in die Mail mit dem ganz normalen Text-Editor
Multimedia-Mail zu Fuß - Empfänger • Empfangen und Lesen der Mail • Merken der Informationen des Senders zur Datei • Editieren der E-Mail zum Abspeichern des Teils der E-Mail mit der ASCII-Datei • Rückverwandeln der ASCII-Datei in eine binäre Datei mit dem zum Encoding passenden Decoder • Problem: uuencode ist kein Standard – verschiedene Versionen – „Nachbearbeiten“ der Datei teilweise notwendig • Starten des zur Datei passenden Programms (Textverarbeitung, Bildbetrachter, . . . )
Multimedia zu Fuß - geht´s ? Informations- und Datenaustausch quer durchs Internet ist möglich: Multimedia zu Fuß funktioniert !!! Aber: aufwendig und kompliziert ! Vergleich zu Papier: Man muß wissen, wie Papier, Tinte, und Umschlag hergestellt werden. . .
MIME: E-Mail lernt Multimedia • Multipurpose Internet Mail Extension RFC 2045 - 2049 • kompatibel zu Text-E-Mail RFC 821/822 • Internationale Zeichensätze (8 Bit und mehr) • Transfer von binären Dateien (Anlagen) • Mehrere Dateien pro E-Mail (multipart) • Speicherung des Texts einer E-Mail in alternativen Formaten
MIME E-Mail Erweiterungen Altes RFC 822 E-Mail Format bleibt, Erweiterung durch neue Header-Zeilen: • MIME-Version: 1. 0 – Kennzeichnung als MIME - E-Mail • Content-Type: Media-Type/Sub-Type – Art der Daten, die in E-Mail enthalten sind. – grobe Einteilung: Media-Type – genaue Angabe: Sub-Type
E-Mail Erweiterungen • Content-Transfer-Encoding – 7 -Bit ASCII-Text E-Mail-System ist Basis – 8 -Bit Dateien werden in ASCII gepackt, Encoding sagt, wie das passiert ist • Encodings gemäß RFC: – Quoted-Printable ähnlich Ae oder “A – Base 64 ähnlich uuencode
E-Mail Erweiterungen • Content-Description – Kommentarzeile zu Mediendatei • Content-Disposition Erweiterung zu MIME (RFC 2183) – Anhang als Teil der E-Mail darstellen (inline) – Anhang als Datei behandeln (attachment) – Default-Dateiname für Datei mitschicken
E-Mail Erweiterungen • Argumente zu den jeweiligen Sub-Types – in Headerzeile nach Semikolon – in der Form Argument=Wert – Beispiel: Content-Type: text/ plain ; charset=ISO-8859 -1 • Normung der MIME-Types – offizielle Subtypes werden gemäß RFC vergeben – inoffizielle Subtypes beginnen mit x-
Content-Type • Sub-Type • Media-Type – – – text image audio video application multipart – message Texte Bilder Töne Filme Daten mehrere Dateien E-Mail in E-Mail – – – plain, html, richtext gif, jpeg, tiff x-wav, basic msvideo, mpeg pdf mixed, alternative
Content-Transfer-Encoding • 7 bit Data • 8 bit Data • Quoted-Printable • Base 64 • Binary Data 998 Zeichen/Zeile US-ASCII 998 Zeichen/Zeile 8 Bit (z. B. ISO-8859 -1) für Texte brauchbar für binäre Dateien 8 Bit Übertragung ! nicht bei E-Mail
Quoted-Printable • • Sonderzeichen als ´=´ und HEX-Ziffer schreiben übliche ASCII-Zeichen als ASCII-Zeichen Leerzeichen, Tab sind normale Zeichen Wenn Leerzeichen am Ende, dann als =20 oder: Soft-Umbruch und Leerzeile • Zeilenumbruch als CRLF bleibt • Maximale Zeilenlänge: 76 Zeichen Soft-Umbruch: ´=´ am Zeilenende
Base 64 • • Ähnlich uuencode 3 Bytes (24 Bit) liefern 4 x 6 Bit in ein ASCII-Zeichen packen Ersetzungstabelle keine Rechenvorschrift wie bei uuencode • 76 Zeichen (57 Bytes) pro Zeile • Keine Verzierungen (Header, Zähler, etc)
Base 64 Encoding Value Encoding 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 A B C D E F G H I J K L M N O P Q Value Encoding 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 R S T U V W X Y Z a b c d e f g h Value Encoding 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 i j k l m n o p q r s t u v w x y Value Encoding 51 52 53 54 55 56 57 58 59 60 61 62 63 z 0 1 2 3 4 5 6 7 8 9 + / (pad) =
Text-Datei Text - ISO 8859 -1 177 Bytes Jetzt grüße ich Dich mit vielen schönen, süßen Umlauten, so daß Du jetzt auch quoted-printable zeigen kannst. Zum Test: ÄÖÜ äöü ß = Text - deutsche Umlaute 192 Bytes Jetzt gruesse ich Dich mit vielen schoenen, suessen Umlauten, so dass Du jetzt auch quoted-printable zeigen kannst. Zum Test: Ae. Oe. Ue aeoeue ss = Text - Te. X Umlaute 192 Bytes Jetzt gr"u"se ich Dich mit vielen sch"onen, s"u"sen Umlauten, so da"s Du jetzt auch quoted-printable zeigen kannst. Zum Test: "A"O"U "a"o"u "s =
Text-Datei Text - Quted-Printable 217 Bytes Jetzt gr=FC=DFe ich Dich mit vielen sch=F 6 nen, s=FC=DFen Umlauten, = so da=DF Du jetzt auch quoted-printable zeigen kannst. = Zum Test: =C 4=D 6=DC =E 4=F 6=FC =DF =3 D = Text - Base 64 240 Bytes SGFsb. G 8 g. Um 9 i. ZXJ 0 ICEg. Cgp. KZXR 6 d. CBncvzf. ZSBp. Y 2 gg. RGlja. CBta. XQgdmllb. GVu. IHNja. PZu ZW 4 s. IHP 832 Vu. IFVtb. GF 1 d. GVu. LCAKc 28 g. ZGHf. IER 1 IGpld. Hp 0 IGF 1 Y 2 ggc. XVvd. GVk. LXBya. W 50 YWJs. ZSB 6 ZWln. ZW 4 ga 2 Fubn. N 0 Li. AKClp 1 b. SBUZXN 0 Oi. DE 1 twg 5 Pb 8 IN 8 g. PSAKCl. Zp. ZWwg. U 3 Bh 3 wp. Sb 2 Jlcn. Qg. S+Rtc. GYK
Bild-Datei Bild - GIF 201 Bytes 100 x 100 Pixel Bild - HEX 00000010 000020 000030 000040 000050 000060 000070 000080 000090 0000 a 0 0000 b 0 0000 c 0 47 ff 8 f e 2 8 d 97 2 e 1 d 07 16 2 a 2 b 2 c 49 ff a 9 48 e 7 cc e 9 7 e 28 a 9 3 a 3 b 3 c 701 Bytes 46 ff cb 96 fa a 6 09 c 3 25 36 aa 4 b 4 c 38 2 c ed e 6 ce b 3 0 e 9 f c 8 99 51 5 b 5 c 37 00 0 f 89 f 7 89 2 b f 2 b 4 56 e 8 6 b 2 c 61 00 a 3 a 6 fe 8 c ad f 9 c 7 69 44 7 b 54 64 00 9 c ea 0 f 4 a e 2 99 77 e 6 8 a 8 b 00 00 00 b 4 ca 0 c a 7 32 6 a 98 95 9 a 9 b 00 64 64 da b 6 0 a d 4 b 4 07 97 a 9 aa ab 3 b 00 00 8 b ee 87 aa 6 a d 7 68 b 9 ba bb 80 64 b 3 0 b c 4 f 5 4 e f 3 b 7 c 9 ca cb 00 00 de c 7 a 2 8 a 03 63 38 d 9 da db 00 00 bc f 2 f 1 cd c 8 34 d 7 e 9 ea eb 00 02 fb 4 c 98 6 a ea ff 08 f 9 fa fb 00 a 8 0 f d 7 03 b 7 32 3 e f 7 09 0 a 0 b 00 8 c 86 f 6 28 dc bb f 5 d 8 1 a 1 b 1 c
Bild-Datei Bild - uuencode 303 Bytes begin 644 bild. gif M 1 TE&. #=A 9`!D`(```````/___RP`````9`!D```"J(R/J<OM#Z. <M-J+L]Z M^P^&XDB 6 YHFFZLJV[@O'DS 7]HWG^L[W_@, "H? $HO&8`RB 7 S*: SB 8 Q*I]2 J M]8 K-: K? <+ND)#BNMXC*T: DX#R. HRNQU^PY_R^9 EJ!]? S 8 S 3_/O 4'*"7(M, =W MF)=HMSC 7"/? 8%JDVF 59 IYI 6 IN<G 9 Z? D)&BHZJE'H 1(J: JKK*VNKZ"ALK. TM; 5: WN+FZN[R]OK^PL<+#Q, 7"Q 4```[ ` end Bild - Base 64 272 Bytes R 0 l. GODdh. ZABk. AIAAAAAAAP///yw. AAAAAZABk. AAACq. Iy. Pqcvt. D 6 Oct. Nq. Ls 968+w+G 4 ki. W 5 omm 6 sq 27 gv. H 8 kz. X 9 o 3 n+s 73/g 8 MCof. Eov. GYAyi. Xz. Kazi. Yx. Kp 9 Sq 9 Yr. Narfc. Luk. JDiut 4 j. K 0 ak 4 D y. Ooyux 1+w 5/y+Zlq. B 9 fz. Yz. T/Pv. UHKCXIt. Md 3 m. Jdotzj. XCPf. YFqk 2 m. VZp 5 p. Wpucn. Z 6 fk. JGio 6 ql. Ho. RIqaqrr. K 2 ur 6 Chsr. O 0 tba 3 u. Lm 6 u 7 y 9 vr+wsc. LDx. MXCx. UAAA 7
Bild-Datei Bild - Quoted-Printable Bytes 503 GIF 87 ad=00=80=00=00=00=FF=FF=FF, =00=00 d=00=00=02=A 8=8 C= =8 F=A 9=CB=ED=0 F=A 3=9 C=B 4=DA=8 B=B 3=DE=BC=FB=0 F=86=E 2 H=96=E 6=89=A 6=EA=CA=B 6= =EE=0 B=C 7=F 2 L=D 7=F 6=8 D=E 7=FA=CE=F 7=FE=0 F=0 C =87=C 4=A 2=F 1=98=03(=97=CC=A 6=B 3=89=8 CJ=A 7=D 4=AA=F 5=8 A= CDj=B 7=DC. =E 9 =0 E+=AD= =E 22=B 4 j. N=03=C 8=EA 2=BB=1 D~=C 3=9 F=F 2=F 9=99 j=07=D 7=F 3 c 4=FF>=F 5=07(%=C 8=B 4=C 7= w=98=97 h=B 78=D 7=08=F 7=D 8=16=A 96=99 Vi=E 6=95=A 9=B 9=C 9=D 9=E 9=F 9 =1 A *: =AAQ=E 8= D=8 A=9 A=AA=BA=CA=DA=EA=FA =1 B+; K[k{=8 B=9 B=AB=BB=CB=DB=EB=FB=0 B=1 C, <L, T=00=00; =
Content-Type: Multipart multipart/mixed • mehrere Dokumente in einer E-Mail – Text und Media-Datei – Text und mehrere Media-Dateien • Argument: boundary=„eindeutiger String“ multipart/alternative • alternative Darstellungen des Inhalts • „höhere“ Qualität am Ende
mail. us-ascii Return-Path: kaempf (at) irx 1. hrz. tu-darmstadt. de Received: from irx 1. hrz. tu-darmstadt. de (irx 1. hrz. tu-darmstadt. de. . . Received: (from kaempf@localhost) by irx 1. hrz. tu-darmstadt. de Date: Fri, 12 Nov 1999 17: 05: 24 +0100 (CET) From: kaempf (at) hrz. PUB. tu-darmstadt. de (Robert Kaempf) Message-Id: <199911121605. RAA 64798@irx 1. hrz. tu-darmstadt. de> To: kaempf (at) irx 1. hrz. tu-darmstadt. de Subject: E-Mail fuer Dich Hallo Robert ! Das hier ist eine E-Mail, die ich Dir einfach so schicke, damit Du mal eine ganz normale E-Mail im US-ASCII Format zeigen kannst. Es gibt aber auch Umlaute: Ae, Oe, Ue, ae, oe, ue, ss Gruesse Robert Kaempf
mail. quoted-printable From: Robert Kaempf <kaempf (at) hrz. tu-darmstadt. DE> Subject: ISO-8859 -1 Mail To: kaempf (at) hrz. tu-darmstadt. DE (Robert Kaempf) Date: Fri, 12 Nov 1999 17: 09: 37 +0100 (CET) X-Mailer: ELM [version 2. 4 ME+ PL 25 (25)] MIME-Version: 1. 0 Content-Type: text/plain; charset=ISO-8859 -1 Content-Transfer-Encoding: quoted-printable Hallo Robert !=20 Jetzt gr=FC=DFe ich Dich mit vielen sch=F 6 nen, s=FC=DFen Umlauten, =20 so da=DF Du jetzt auch quoted-printable zeigen kannst. =20 Zum Test: =C 4=D 6=DC =E 4=F 6=FC =DF =3 D=20 Viel Spa=DF Robert K=E 4 mpf
From: Robert Kaempf <kaempf(at) hrz. tu-darmstadt. DE> Subject: Text und Bild To: kaempf (at) hrz. tu-darmstadt. DE (Robert Kaempf) Date: Fri, 12 Nov 1999 17: 14: 53 +0100 (CET) MIME-Version: 1. 0 Content-Type: multipart/mixed; boundary=ELM 942423292 -21211 -0_ Content-Transfer-Encoding: 7 bit mail. multipart. attach --ELM 942423292 -21211 -0_ Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7 bit Hallo Robert Hier ein GIF-Bild ! Gruesse Robert --ELM 942423292 -21211 -0_ Content-Type: image/gif Content-Disposition: attachment; filename=bild. gif Content-Description: op_sem 99/bild. gif Content-Transfer-Encoding: base 64 R 0 l. GODdh. ZABk. AIAAAAAAAP///yw. AAAAAZABk. AAACq. Iy. Pqcvt. D 6 Oct. Nq. Ls 968+w+G 4 ki. W 5 omm 6 sq 2 7 gv. H 8 kz. X 9 o 3 n+s 73/g 8 MCof. Eov. GYAyi. Xz. Kazi. Yx. Kp 9 Sq 9 Yr. Narfc. Luk. JDiut 4 j. K 0 ak 4 Dy. Ooyux 1+ w 5/y+Zlq. B 9 fz. Yz. T/Pv. UHKCXIt. Md 3 m. Jdotzj. XCPf. YFqk 2 m. VZp 5 p. Wpucn. Z 6 fk. JGio 6 ql. Ho. RIqaqrr. K 2 ur 6 Chsr. O 0 tba 3 u. Lm 6 u 7 y 9 vr+wsc. LDx. MXCx. UAAA 7 --ELM 942423292 -21211 -0_--
From: Robert Kaempf <kaempf (at) hrz. tu-darmstadt. DE> Subject: GIF und ISO-Text To: kaempf (at) hrz. tu-darmstadt. DE (Robert Kaempf) Date: Fri, 12 Nov 1999 17: 16: 32 +0100 (CET) MIME-Version: 1. 0 Content-Type: multipart/mixed; boundary=ELM 942423392 -21211 -1_ Content-Transfer-Encoding: 7 bit mail. multipart. attach. is o --ELM 942423392 -21211 -1_ Content-Type: text/plain; charset=ISO-8859 -1 Content-Transfer-Encoding: quoted-printable Hallo Robert !=20 Bild und Umlaute=20 Gr=FC=DFe Robert=20 --ELM 942423392 -21211 -1_ Content-Type: image/gif Content-Disposition: attachment; filename=bild. gif Content-Description: op_sem 99/bild. gif Content-Transfer-Encoding: base 64 R 0 l. GODdh. ZABk. AIAAAAAAAP///yw. AAAAAZABk. AAACq. Iy. Pqcvt. D 6 Oct. Nq. Ls 968+w+G 4 ki. W 5 omm 6 sq 2 7 gv. H 8 kz. X 9 o 3 n+s 73/g 8 MCof. Eov. GYAyi. Xz. Kazi. Yx. Kp 9 Sq 9 Yr. Narfc. Luk. JDiut 4 j. K 0 ak 4 Dy. Ooyux 1+ w 5/y+Zlq. B 9 fz. Yz. T/Pv. UHKCXIt. Md 3 m. Jdotzj. XCPf. YFqk 2 m. VZp 5 p. Wpucn. Z 6 fk. JGio 6 ql. Ho. RIqaqrr. K 2 ur 6 Chsr. O 0 tba 3 u. Lm 6 u 7 y 9 vr+wsc. LDx. MXCx. UAAA 7 --ELM 942423392 -21211 -1_--
mail. multipart. alternative Date: Fri, 12 Nov 1999 17: 33: 57 +0100 From: Robert Kaempf <kaempf (at) hrz. tu-darmstadt. de> X-Mailer: Mozilla 4. 61 C-SGI [en] MIME-Version: 1. 0 To: kaempf (at) hrz. tu-darmstadt. de Subject: alternative ? Content-Type: multipart/alternative; boundary="------763 E 6433 BDE 9836 C 87 EABFDE" -------763 E 6433 BDE 9836 C 87 EABFDE Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7 bit HTML und TEXT -------763 E 6433 BDE 9836 C 87 EABFDE Content-Type: text/html; charset=us-ascii Content-Transfer-Encoding: 7 bit <!doctype html public "-//w 3 c//dtd html 4. 0 transitional//en"> <html> <pre>HTML und TEXT</pre> </html> -------763 E 6433 BDE 9836 C 87 EABFDE--
From: Robert Kaempf <kaempf (at) hrz. tu-darmstadt. de> Date: Fri, 12 Nov 1999 17: 37: 07 +0100 X-Mailer: Mozilla 4. 61 C-SGI [en] MIME-Version: 1. 0 To: kaempf (at) hrz. tu-darmstadt. de Subject: alternative iso Content-Type: multipart/alternative; boundary="------2 FB 0 F 22 FF 96724 E 12 CC 5 C 6 C 2" mail. multipart. alternative. iso -------2 FB 0 F 22 FF 96724 E 12 CC 5 C 6 C 2 Content-Type: text/plain; charset=iso-8859 -1 Content-Transfer-Encoding: quoted-printable HTML und Text mit Umlauten Gr=FC=DFe Robert -------2 FB 0 F 22 FF 96724 E 12 CC 5 C 6 C 2 Content-Type: text/html; charset=us-ascii Content-Transfer-Encoding: 7 bit <!doctype html public "-//w 3 c//dtd html 4. 0 transitional//en"> <html> HTML und Text mit Umlauten Grü ß e Robert </html> -------2 FB 0 F 22 FF 96724 E 12 CC 5 C 6 C 2 --
Date: Fri, 12 Nov 1999 17: 39: 26 +0100 From: Robert Kaempf <kaempf (at) hrz. tu-darmstadt. de> X-Mailer: Mozilla 4. 61 C-SGI [en] MIME-Version: 1. 0 To: kaempf (at) hrz. tu-darmstadt. de Subject: alternative und mixed ? Content-Type: multipart/mixed; boundary="------7014 DFAE 513 EED 342 ED 07 F 3 A" mail. multipart. alternative. mixe d This is a multi-part message in MIME format. -------7014 DFAE 513 EED 342 ED 07 F 3 A Content-Type: multipart/alternative; boundary="------350 FFAFEE 03 F 8 B 0006 E 3 BA 88" -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 Content-Type: text/plain; charset=iso-8859 -1 Content-Transfer-Encoding: quoted-printable Jetzt mit HTML, Text und einem Bild ? Gr=FC=DFe Robert -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 Content-Type: text/html; charset=us-ascii Content-Transfer-Encoding: 7 bit <!doctype html public "-//w 3 c//dtd html 4. 0 transitional//en"> <html> Jetzt mit HTML, Text und einem Bild ? Grü ß e Robert</html> -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 -------7014 DFAE 513 EED 342 ED 07 F 3 A Content-Type: image/gif; name="bild. gif" Content-Transfer-Encoding: base 64 Content-Disposition: inline; filename="bild. gif" R 0 l. GODdh. ZABk. AIAAAAAAAP///yw. AAAAAZABk. AAACq. Iy. Pqcvt. D 6 Oct. Nq. Ls 968+w+G 4 ki. W 5 omm 6 sq 27 gv. H 8 kz. X 9 o 3 n+s 73/g 8 MCof. Eov. GYAyi. Xz. Kazi. Yx. Kp 9 Sq 9 Yr. Narfc. Luk. JDiut 4 j. K 0 ak 4 D y. Ooyux 1+w 5/y+Zlq. B 9 fz. Yz. T/Pv. UHKCXIt. Md 3 m. Jdotzj. XCPf. YFqk 2 m. VZp 5 p. Wpucn. Z 6 fk. JGio 6 ql. Ho. RIqaqrr. K 2 ur 6 Chsr. O 0 tba 3 u. Lm 6 u 7 y 9 vr+wsc. LDx. MXCx. UAAA 7 -------7014 DFAE 513 EED 342 ED 07 F 3 A--
mail. multipart. alternative. mixe d Date: Fri, 12 Nov 1999 17: 39: 26 +0100 From: Robert Kaempf <kaempf (at) hrz. tu-darmstadt. de> X-Mailer: Mozilla 4. 61 C-SGI [en] MIME-Version: 1. 0 To: kaempf (at) hrz. tu-darmstadt. de Content-Type: multipart/mixed; Subject: alternative und mixed ? Content-Type: multipart/mixed; boundary="------------7014 DFAE 513 EED 342 ED 07 F 3 A" This is a multi-part message in MIME format. --------------7014 DFAE 513 EED 342 ED 07 F 3 A Content-Type: multipart/alternative; boundary="------350 FFAFEE 03 F 8 B 0006 E 3 BA 88" Content-Type: multipart/alternative; boundary="------350 FFAFEE 03 F 8 B 0006 E 3 BA 88" -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 Content-Type: text/plain; charset=iso-8859 -1 -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 Content-Transfer-Encoding: quoted-printable Jetzt mit HTML, Text und einem Bild ? Gr=FC=DFe Robert Content-Type: text/plain; charset=iso-8859 -1 -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 Content-Type: text/html; charset=us-ascii Content-Transfer-Encoding: 7 bit -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 <!doctype html public "-//w 3 c//dtd html 4. 0 transitional//en"> Content-Type: <html> Jetzt mit HTML, Text und einem Bild ? Grü ß e Robert</html> -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 -------7014 DFAE 513 EED 342 ED 07 F 3 A Content-Type: image/gif; name="bild. gif" Content-Transfer-Encoding: base 64 Content-Disposition: inline; filename="bild. gif" text/html; charset=us-ascii -------350 FFAFEE 03 F 8 B 0006 E 3 BA 88 --------7014 DFAE 513 EED 342 ED 07 F 3 A Content-Type: image/gif R 0 l. GODdh. ZABk. AIAAAAAAAP///yw. AAAAAZABk. AAACq. Iy. Pqcvt. D 6 Oct. Nq. Ls 968+w+G 4 ki. W 5 omm 6 sq 27 gv. H 8 kz. X 9 o 3 n+s 73/g 8 MCof. Eov. GYAyi. Xz. Kazi. Yx. Kp 9 Sq 9 Yr. Narfc. Luk. JDiut 4 j. K 0 ak 4 D y. Ooyux 1+w 5/y+Zlq. B 9 fz. Yz. T/Pv. UHKCXIt. Md 3 m. Jdotzj. XCPf. YFqk 2 m. VZp 5 p. Wpucn. Z 6 fk. JGio 6 ql. Ho. RIqaqrr. K 2 ur 6 Chsr. O 0 tba 3 u. Lm 6 u 7 y 9 vr+wsc. LDx. MXCx. UAAA 7 --------------7014 DFAE 513 EED 342 ED 07 F 3 A-- T H
MIME und WWW • • HTTP 1. 0: RFC 1945 (1996!) HTTP 1. 1: RFC 2616 nach E-Mail entwickelt, 8 -Bit Transfer kein Encoding, kein Multipart ABER ab HTTP 1. 0: • MIME Content-Type wird benutzt • Server: Erst MIME-Type, dann Daten • Client: Anzeige der Daten je nach Typ oder Starten von besonderen Programmen
HTTP zu Fuß • telnet www. tu-darmstadt. de 80 GET http: //www. tu-darmstadt. de/hrz/o/iso. txt MIME/1. 0 • Leerzeile eingeben HTTP/1. 1 200 OK Date: Wed, 17 Nov 1999 20: 46: 42 GMT Server: Apache/1. 3. 3 Ben-SSL/1. 28 (Unix) Last-Modified: Wed, 17 Nov 1999 20: 04: 07 GMT Content-Length: 177 Connection: close Content-Type: text/plain Hallo Robert ! Jetzt grüße ich Dich mit vielen schönen, süßen Umlauten, so daß Du jetzt auch quoted-printable zeigen kannst. Zum Test: ÄÖÜ äöü ß = Viel Spaß Robert Kämpf
HTTP zu Fuß irx 1: /home/kaempf $ telnet www. tu-darmstadt. de 80 Trying 130. 83. 47. 198. . . Connected to sun 25. hrz. tu-darmstadt. de. Escape character is '^]'. GET http: //www. tu-darmstadt. de/hrz/o/bild. gif HTTP/1. 0 HTTP/1. 1 200 OK Date: Wed, 17 Nov 1999 20: 52: 59 GMT Server: Apache/1. 3. 3 Ben-SSL/1. 28 (Unix) Last-Modified: Wed, 17 Nov 1999 20: 04: 22 GMT ETag: "98 af 40 -c 9 -38330 a 46" Accept-Ranges: bytes Content-Length: 201 Connection: close Content-Type: image/gif X-Pad: avoid browser bug GIF 87 add€ÿdd�¨Œ©Ëí£œ´Ú‹³Þ¼û†âH–扦êʶî çúÎ÷þ ÇòL×ö ‡Ä¢ñ˜�(—̦³‰ŒJ§ÔªõŠÍj·Ü. é + â 2´j. N�Èê 2» �~ßòù™j×óc 4õ(%È´Çw˜— h· 8÷Ø�© 6™Viæ • ©¹ÉÙéù �*: ªQèDŠšªºÊÚêú �+; K[k{‹› «» ËÛëû �, <L, T; Connection closed by foreign host.
- Slides: 47