LIGHTWEIGHT DIRECTORY ACCESS PROTOCOL LDAP DAMAR APRI SUDARMADI

  • Slides: 17
Download presentation
LIGHTWEIGHT DIRECTORY ACCESS PROTOCOL (LDAP) DAMAR APRI SUDARMADI MITA PRAMIHAPSARI TYA MARINA

LIGHTWEIGHT DIRECTORY ACCESS PROTOCOL (LDAP) DAMAR APRI SUDARMADI MITA PRAMIHAPSARI TYA MARINA

OUTLINE INTODUCTION OTENTIKASI LDAP PRINSIP KERJA LDAP KELEBIHAN DAN KEKURANGAN

OUTLINE INTODUCTION OTENTIKASI LDAP PRINSIP KERJA LDAP KELEBIHAN DAN KEKURANGAN

INTRODUCTION • LDAP adalah protokol kelas ringan untuk mengakses servis direktori, yang berdasarkan pada

INTRODUCTION • LDAP adalah protokol kelas ringan untuk mengakses servis direktori, yang berdasarkan pada protokol servis direktori X. 500. • TCP/IP • RFC 225 l "The Lightweight Directory Access Protocol (v 3)“ • RFC 4511, RFC 4512, RFC 4513 dll.

INTRODUCTION • RFC 4511 tentang protokol dari LDAP • RFC 4512 tentang Model Direktori

INTRODUCTION • RFC 4511 tentang protokol dari LDAP • RFC 4512 tentang Model Direktori Informasi pada LDAP. • RFC 4513 tentang mekanisme otentikasi dan mekanisme keamanan dari LDAP.

INTRODUCTION • LDAP mengakses direktori yang menawarkan cara untuk mencari, mengambil, dan memanipulasi isi

INTRODUCTION • LDAP mengakses direktori yang menawarkan cara untuk mencari, mengambil, dan memanipulasi isi dari direktori, 1. akses tidak sah ke dalam direktori data melalui operasi pengambilan data. 2. akses tidak sah ke dalam data direktori melalui akses monitoring lainnya. 3. modifikasi data direktori yang tidak sah. 4. konfigurasi modifikasi informasi yang tidak sah. 5. Denial of Service. 6. Spoofing. 7. Hijacking.

INTRODUCTION (1)Otentikasi dengan cara operasi Bind. (2)Intergritas layanan data dengan cara lepisan keamanan pada

INTRODUCTION (1)Otentikasi dengan cara operasi Bind. (2)Intergritas layanan data dengan cara lepisan keamanan pada Transport Layer Security (TLS) atau mekanisme SASL. (3)Server otentikasi dengan cara mekanisme protokol TLS atau SASL. (4)Penggunaan server administratif

OTENTIKASI LDAP operasi Bind menyediakan tiga mekanisme otentikasi, mekanisme tersebut adalah 1. Sebuah mekanisme

OTENTIKASI LDAP operasi Bind menyediakan tiga mekanisme otentikasi, mekanisme tersebut adalah 1. Sebuah mekanisme otentikasi anonim 2. Sebuah mekanisme otentikasi yang tidak berkepentingan, 3. Sebuah mekanisme otentikasi nama / sandi yang menggunakan kredensial yang terdiri dari nama

OTENTIKASI LDAP operasi Bind berfungsi untuk mengotentikasi pesan yang ditukar antara klien dengan server.

OTENTIKASI LDAP operasi Bind berfungsi untuk mengotentikasi pesan yang ditukar antara klien dengan server. Bind. Request berisi : (1)Versi, (2)Nama, . (3)Otentikasi,

OTENTIKASI LDAP • LDAP melindungi mekanisme otentikasi password / nama menggunakan mekanisme TLS •

OTENTIKASI LDAP • LDAP melindungi mekanisme otentikasi password / nama menggunakan mekanisme TLS • Implementasi LDAP tidak mengijinkan penggunaan nama / password secara default. • Implementasi LDAP server harus mendukung pernyataan otoritas dari identitas klien melalui mekanisme EXTERNAL SASL. • LDAP server yang mendukung implementasi tidak mempunyai

OTENTIKASI LDAP • Operasi STARTTLS menyediakan kemampuan untuk membangun TLS dalam sesi LDAP. •

OTENTIKASI LDAP • Operasi STARTTLS menyediakan kemampuan untuk membangun TLS dalam sesi LDAP. • protokol TLS pada LDAP => memastikan kerahasiaan data dan integritas, selain itu untuk opsional menyediakan otentikasi.

OTENTIKASI LDAP • Setiap sesi LDAP memiliki Authorization State atau otoritas State. • State

OTENTIKASI LDAP • Setiap sesi LDAP memiliki Authorization State atau otoritas State. • State terbagi dari beberapa faktor • Faktor dapat ditentukan atau dipengaruhi oleh protokol dan terdapat beberapa faktor yang dapat ditentukan oleh peristiwa eksternal

OTENTIKASI LDAP • Operasi Bind pada RFC 4511 memungkinkan untuk mengotentikasi pesan yang ditukar

OTENTIKASI LDAP • Operasi Bind pada RFC 4511 memungkinkan untuk mengotentikasi pesan yang ditukar antara klien dengan server. • Permintaan Bind biasanya menentukan otentikasi identitas yang diinginkan. • memungkinkan Klien untuk menentukan otoritasi dari identitas. • Jika otorisasi identitas di tentukan, maka server harus memverifikasi otentikasi identitas dari klien. • Sebaliknya, jika otorisasi identitas tidak di tentukan, maka server akan

PRINSIP KERJA LDAP 1. klien mengirimkan permintaan protokol menggambarkan operasi yang akan dilakukan untuk

PRINSIP KERJA LDAP 1. klien mengirimkan permintaan protokol menggambarkan operasi yang akan dilakukan untuk server. 2. Server kemudian bertanggung jawab untuk melakukan operasi yang diperlukan dalam Direktori. 3. Setelah menyelesaikan suatu operasi, server mengembalikan sebuah respon yang biasanya mengandung data yang sesuai ke klien yang meminta. Protokol operasi umumnya independen satu sama lain. Setiap operasi diproses sebagai tindakan atom, meninggalkan direktori dalam keadaan yang konsisten. Permintaan dan tanggapan untuk beberapa operasi secara umum dapat dipertukarkan antara klien dan

PRINSIP KERJA LDAP SERVER LDAP menggunakan model X. 500(93)

PRINSIP KERJA LDAP SERVER LDAP menggunakan model X. 500(93)

KEKURANGAN LDAP (-) Terdapat kemungkinan client mengakses server yang berbeda melalui URL (-) URL

KEKURANGAN LDAP (-) Terdapat kemungkinan client mengakses server yang berbeda melalui URL (-) URL bekerja otomatis tanpa melibatkan pengguna password kemungkinan akan digunakan kembali secara otomatis (-) kemungkinan server melakukan penyalahgunaan dan penyadapan

k. ELEBIHAN LDAP (+) Proses otentikasi dilakukan dengan sederhana (+) Terdapat mekanisme yang menjamin

k. ELEBIHAN LDAP (+) Proses otentikasi dilakukan dengan sederhana (+) Terdapat mekanisme yang menjamin kerahsiaan data dan integritas data

TERIMA KASIH. .

TERIMA KASIH. .