Komunikacijski protokoli i mree Aplikativni sloj i DNS



















![Internet aplikacije: transportni protokoli Protokol Aplikacija aplikativnog nivoa SMTP [RFC 2821] Telnet [RFC 854] Internet aplikacije: transportni protokoli Protokol Aplikacija aplikativnog nivoa SMTP [RFC 2821] Telnet [RFC 854]](https://slidetodoc.com/presentation_image_h/1953d42936bdf7868114c0cc88cfb950/image-20.jpg)
















































- Slides: 68
Komunikacijski protokoli i mreže Aplikativni sloj i DNS Disclaimer: The European Commission support for the production of this document does not constitute an endorsement of the contents which reflects the views only of the authors, and the Commission cannot be held responsible for any use which may be made of the information contained therein.
Sadržaj predavanja • Principi mrežnih aplikacija • DNS KPM - Aplikativni sloj i DNS 2
Aplikativni sloj Naš cilj: • Konceptulani i izvedbeni aspekti mrežnih aplikativnih protokola • modeli usluga transportnog sloja • klijent-server pristup • peer-to-peer pristup • naučiti o protokolima analizirajući popularne protokole aplikativnog sloja • DNS • SMTP / POP 3 / IMAP • HTTP KPM - Aplikativni sloj i DNS 3
Aplikativni nivo Molim, početnu Web stranicu HTTP zahtjev Web preglednik Softver (aplikacija) Web server KPM - Aplikativni sloj i DNS 4
Aplikativni nivo Izvoli(te), početnu Web stranicu HTTP odgovor Web preglednik • Dva programa razmjenjuju poruke • Koristeći neki “jezik” (protokol) • Ovdje HTTP KPM - Aplikativni sloj i DNS Softver (aplikacija) Web server 5
Slojevitost • Ovim programima je bitno da razumiju jedan drugog i da mogu slati jedan drugom poruke • Kako te poruke putuju njih (njihove autore) ne zanima, bitno je da stižu do (pravog) odredišta i nazad • Nivo APSTRAKCIJE KPM - Aplikativni sloj i DNS 6
Podproblemi - mrežni slojevi Softver (aplikacija) • Kako napraviti jezik (protokol) kojim pričaju aplikacije koje mogu razmjenjivati poruke Aplikativni sloj • Aplikativni sloj Transportni sloj Mrežni sloj Sloj veze podataka KPM - Aplikativni sloj i DNS Fizički sloj 7
Neke mrežne aplikacije • • • e-pošta Web instant messaging remote login P 2 P dijeljenje datoteka višekorisničke mrežne igre • streaming pohranjenih video sadržaja • voice over IP • video konferencije • grid računarstvo • • • KPM - Aplikativni sloj i DNS 8
Pravljenje mrežnih aplikacija Napisati programe koji application transport network data link physical • se izvršavaju na (različitim) krajnjim sistemima • komuniciraju preko mreže • npr. , Web server softver komunicira sa Web preglednik softverom Nema potrebe da se piše softver za uređaje u mreži (core) • uređaji u mreži ne izvršavaju korisničke aplikacije • aplikacije na krajnjim sistemima omogućavaju brz razvoj aplikacija i širenje KPM - Aplikativni sloj i DNS application transport network data link physical 9
Arihitektura aplikacija • Klijent-server • Peer-to-peer (P 2 P) • Hibrid klijent-server i P 2 P KPM - Aplikativni sloj i DNS 10
Klijent-server arhitektura server: • stalno upaljen računar (host) • stalna IP adresa • farme servera za skaliranje klijenti: klijent/server • komuniciraju sa serverom • mogu se povremeno povezivati • mogu imati dinamičke IP adrese • ne komuniciraju direktno jedan sa drugim KPM - Aplikativni sloj i DNS 11
Čista P 2 P arhitektura • nema stalno upaljenog servera • proizvoljni krajnji sistemi peer-peer komuniciraju direktno • peer-ovi se povremeno povezuju i mijenjaju IP adrese Vrlo skalabilno ali teško za upravljanje KPM - Aplikativni sloj i DNS 12
Hibrid klijent-server i P 2 P Skype • voice-over-IP P 2 P aplikacija • centraliziran server: za pronalaženje adrese pozvanog • klijent-klijent konekcija: direktna (ne preko servera) Instant messaging • razgovor (chat) između dva korisnika je P 2 P • centralizirane usluge: usluga otkrivanja prisutnosti i lokacije klijenta • korisnik registruje svoju IP adresu kod servera kad se prijavi • korisnik kontaktira centralni server da sazna IP adrese svojih kontakata KPM - Aplikativni sloj i DNS 13
Komunikacija procesa Proces: program koji se izvršava na krajnjem uređaju (računaru). • na istom uređaju, dva procesa komuniciraju koristeći među-procesnu komunikciju (definisanu od OS). • procesi na različitim uređajima komuniciraju razmjenjujući poruke Klijent proces: proces koji inicira komunikaciju Server proces: proces koji čeka da bude kontaktiran • Napomena: aplikacije sa P 2 P arhitekturama imaju klijent procese i server procese KPM - Aplikativni sloj i DNS 14
Socket-i • proces šalje/prima poruke preko svog socket • socket analogan vratima • proces koji šalje “izbacuje” poruku kroz vrata • oslanja se na transportnu infrastrukturu sa druge strane vrata da dostavi poruku do socket prijemnog procesa računar ili server kontrolisan od autora aplikacije proces socket TCP sa buffer-ima i varijablama Internet TCP sa buffer-ima i varijablama kontrolisan od OS r API: (1) izbor transportnog protokola; (2) mogućnost da prilagodi neke parametre KPM - Aplikativni sloj i DNS 15
Adresiranje procesa • da bi primio poruku, proces mora imati identifikator • računari imaju jedinstvene 32 -bitne IP adrese • P: da li je IP adresa računara na kom se proces izvršava dovoljna za identifikaciju procesa? • O: Ne, mnogi procesi se mogu izvršavati na istom računaru • identifikator uključuje i IP adresu i broj porta povezan sa procesom na računaru. • Primjer brojeva portova: • HTTP server: 80 • Mail server: 25 • za slanje HTTP poruke www. etf. unsa. ba Web serveru: • IP adresa: 78. 47. 195. 203 • Port number: 80 KPM - Aplikativni sloj i DNS 16
Protokol aplikativnog nivoa definiše • Tipove poruke koje se razmjenjuju • npr. , zahtjev, odgovor • Sintaksu poruka • koja su polja u poruci i kako se odvajaju • Semantiku poruka • Značenje informacija u poljima • Pravila kad i kako proces šalje i odgovara na poruku Javni (public-domain) protokoli: • definisani u RFC-ovima • omogućavaju interoperabilnost • npr. HTTP, SMTP Ne-javni (proprietary) protokoli: • npr. Skype KPM - Aplikativni sloj i DNS 17
Koje transportne usluge aplikacije trebaju? Propusnost (Ne)Gubitak paketa • neke aplikacije (npr. , • neke aplikacije (npr. audio) multimedia) zahtijevaju mogu tolerisati neke gubitke minimalnu količinu • druge aplikacije (npr. , prenos propusnosti da bi bile radile datoteka, telnet) zahtijevaju kako treba 100% pouzdan prenos • druge aplikacije podataka (“elastične”) koriste dostupnu propusnost Vrijeme prenosa Sigurnost • neke aplikacije (npr. , Internet telefonija, • šifriranje, integritet interaktivne igre) podataka, … zahtijevaju malo kašnjenje da bi bile radile kako treba KPM - Aplikativni sloj i DNS 18
Zahtjevi na transportne usluge nekih aplikacija Aplikacija prenos datoteka e-pošta Web dokumenti audio/video u realnom vremenu pohranjen aud/vid interaktivne igre trenutne poruke Gubitak podataka bez bez toleriše bez Propusnost elastičan audio: 5 kb/s-1 Mb/s video: 10 kb/s-5 Mb/s kao gore bar nekoliko kb/s elastičan KPM - Aplikativni sloj i DNS Vremenska osjetljivost ne ne ne da, 100 -ine ms da, nekolio s da, 100 -ine ms da i ne 19
Internet aplikacije: transportni protokoli Protokol Aplikacija aplikativnog nivoa SMTP [RFC 2821] Telnet [RFC 854] HTTP [RFC 2616] FTP [RFC 959] HTTP (npr. Youtube), RTP [RFC 1889] Internet telefonija SIP, RTP, proprietary (npr. Skype) e-pošta terminalski pristup daljinski Web prenos datoteka streaming multimedia KPM - Aplikativni sloj i DNS Transportni protokol TCP TCP TCP ili UDP tipično UDP 20
DNS: Domain Name System: Ljudi: razni identifikatori: • distribuirana baza podataka izvedena kroz hijerahiju mnogo name servera (imena) • JMBG, ime, br. pasoš Internet računari i ruteri: • IP adresa (32 bit) – koristi se za adresiranje datagrama • “ime”, npr. , www. facebook. com – koriste ljudi P: mapiranje između IP adresa i imena? • protokol aplikativnog nivoa za komunikaciju računari, ruteri, serveri imena rade resolve imena (prevod adresa/ime) • napomena: core (unutrašnja) Internet funkcija, izvedena kao protokol aplikativnog nivoa • kompleksnost na mrežnoj “ivici” KPM - Aplikativni sloj i DNS 21
DNS usluge • prevod imena računara (hostname) u IP adresu • host aliasing • kanonička, alias imena • mail server aliasing • distribucija opterećenja • replicirani Web serveri: skup IP adresa za jedno kanoničko ime Zašto ne centralizirani DNS? • jedinstveno mjesto otkaza • količina saobraćaja • udaljena centralizirana baza podataka • održavanje ne skalira ! (dobro) KPM - Aplikativni sloj i DNS 22
DNS – Domain Name System • Usluga koja omogućava mapiranje između domenskih imena čvorova u mreži i njihovih IP adresa • RFC 1034 i 1035 • Nije prava (korisnička) aplikacija • Ne koriste ga ljudi (direktno) • Koriste ga aplikacije (koje koriste ljudi) • Distribuirana baza podataka • Prije DNS hosts. txt (održavan od strane NIC) KPM - Aplikativni sloj i DNS 23
Pozicija DNS u komunikaciji KPM - Aplikativni sloj i DNS 24
DNS elementi • Prostor domenskih imena • Baza DNS podataka • Poslužitelji imena (Name Servers) • Programi za upite – DNS klijenti (Resolvers) KPM - Aplikativni sloj i DNS 25
Prostor domenskih imena • Skup mogućih domenskih imena • Domen – grupa računara pod kontrolom jedne organizacije • Organizacija domena je hijerarhijska • Domen može imati poddomene • Cjelokupni Internet je podijeljen manji broj osnovnih (top) domena • Svi ostali domeni su poddomeni osnovnih KPM - Aplikativni sloj i DNS 26
DNS osnovni domeni (stari) • GTLD (Generic Top Level Domains) – stari 1985 • • . com. edu. gov. mil. net. org. arpa • cc. TLD - dvoslovni kod države ISO 3166 • . ba (naš, a ima ih preko 250) KPM - Aplikativni sloj i DNS 27
Podjela osnovnih domena (2015) • • • Generički (g. TLD) Državni (cc. TLD) Infrastrukturni (ARPA) Testni (t. TLD) Ograničeni (gr. TLD) Sponzorisani (s. TLD) • Internet Corporation for Assigned Names and Numbers (ICANN) • Internet Assigned Numbers Authority (IANA) KPM - Aplikativni sloj i DNS 28
DNS poddomeni • etf. unsa. ba (naša zona i naš Name Server) • ba • unsa • etf • Vlasnik domena kreira (prodaje) poddomene • . ba domen - UTIC • Do 127 nivoa • Cijelo ime domena maksimalno 255 znakova • Pojedina polja do 63 znaka KPM - Aplikativni sloj i DNS 29
Dio Internet DNS stabla KPM - Aplikativni sloj i DNS 30
Baza DNS podataka • Zapisi o resursima (Resource Records – RR) • Upit ka DNS serveru sa imenom vraća zapise (RR) vezane uz to ime • RR format • • • Domain_name – ime po kom se pretražuje TTL – u sekundama – vremenska promjenljivost Class – IN (za Internet), može i drugo Type – SOA, A, MX, NS, CNAME, PTR, HINFO, TXT Value – vrijednost, zavisno od tipa zapisa KPM - Aplikativni sloj i DNS 31
Tipovi i vrijednosti DNS zapisa Tip Značenje Vrijednost SOA Start of Authority Parametri za ovu zonu A IP adresa za ime 32 bitni cjeli broj MX Mail exchange Prioritet, ime računara NS Name Server Ime servera za domen CNAME Canonical name Ime domena PTR Pointer Alias za IP adresu HINFO Opis računara CPU i OS TXT Tekst Slobodni tekst Ima još i MINFO, SRV, WKS KPM - Aplikativni sloj i DNS 32
DNS zapisi DNS: distribuirana db pohranjuje resource records (RR) RR format: (name, value, type, ttl) • Type=A – – • Type=CNAME name je hostname value je IP adresa – • Type=NS • name is domen (npr. foo. com) • value je hostname autoritativnog servera imena za ovaj domen name je nadimak (alias) za neko “canonical” (pravo) ime www. ibm. com je zapravo servereast. backup 2. ibm. com – value je kanonsko ime • Type=MX – value je ime mail servera vezano (asocirano) za ime KPM - Aplikativni sloj i DNS 33
etf. unsa. ba zapisi ; /var/named/master/etf. unsa. ba ; ; Zone file for etf. unsa. ba ; type: MASTER ; by: Ime Administratora <ime. administratora@etf. unsa. ba> Start of Authority – osnovni podaci i parametri @ IN SOA ns. etf. unsa. ba. hostmaster. etf. unsa. ba. ( 2007101410 ; serial, todays date + todays ser 10800 ; refresh, seconds, 3 H 3600 ; retry, seconds, 1 H 360000 ; expire, seconds, 100 H 86400 ) ; minimum, 1 D KPM - Aplikativni sloj i DNS 34
etf. unsa. ba zapisi (2) Name server NS ns Mail Exchanger MX 10 igman. etf. unsa. ba. Tekstualne informacije o domenu TXT "Faculty of Electrical Engineering Sarajevo" KPM - Aplikativni sloj i DNS 35
etf. unsa. ba zapisi (3) Zapisi tipa A (IP adrese za imena) localhost A 127. 0. 0. 1 ns A 80. 65. 66 ; reserved dev A 80. 65. 71 ; reserved win A 80. 65. 72 ; reserved majevica A 80. 65. 73 ; reserved A 80. 65. 78 ; reserved . . . igman KPM - Aplikativni sloj i DNS 36
etf. unsa. ba zapisi (4) Zapisi tipa CNAME (zamjenska imena) ns 1 CNAME ns hostmaster CNAME ns . . . winsrv CNAME win . . . webmail CNAME igman c 2 CNAME majevica . . . KPM - Aplikativni sloj i DNS 37
etf. unsa. ba zapisi (5) Još zapisa tipa A (IP adrese za imena) – web serveri nastava A 80. 65. 71 ; nastava icat A 80. 65. 71 ; ICAT Site courses A 80. 65. 72 ; Coursware people A 80. 65. 71 ; People from ETF portal A 80. 65. 71 ; ETF web portal www A 80. 65. 71 ; CNAME portal A 80. 65. 73 . . . ; . . . zamger ; . . . KPM - Aplikativni sloj i DNS 38
Distribuirana hijerarhijska baza podataka Root DNS serveri com DNS serveri yahoo. com DNS serveri amazon. com DNS serveri org DNS serveri pbs. org DNS serveri edu DNS serveri poly. edu umass. edu DNS serveri Klijent želi IP za www. amazon. com; osnovna procedura: • klijent pita root server za com DNS server • klijent pita com DNS server za amazon. com DNS server • klijent pita amazon. com DNS server za IP adresu www. amazon. com KPM - Aplikativni sloj i DNS 39
Kako radi DNS KPM - Aplikativni sloj i DNS 40
Kako radi DNS • Korisnički program traži IP adresu za ime nekog domena • Resolver (u lokalnom računaru) pravi upit za definisani name server (najčešće lokalni koji je u istom domenu) • (Lokalni) name server provjerava lokalnu bazu • Ako pronađe, vraća IP adresu onom ko je tražio • Ako ne, pita druge dostupne name server-e • Počinje od korijena DNS stabla ili koliko visoko na stablu je moguće • Korisnički program dobiva traženu IP adresu ili poruku o grešci KPM - Aplikativni sloj i DNS 41
TLD i autoritativni serveri • Top-level domain (TLD) serveri: • odgovorni za com, org, net, edu, itd i sve domene zemalja: ba, uk, fr, ca, jp. . . • Network Solutions održava servere za com TLD • Educause za edu TLD • Autoritativni DNS serveri: • DNS serveri organizacije, daju autoritativna mapiranja imena u IP za servere organizacije (npr. , Web, mail). • može ih održavati organizacija ili davalac usluge povezivanja na Internet (ISP) KPM - Aplikativni sloj i DNS 42
Lokalni serveri imena • formalno ne pripadaju hijererhiji • svaki ISP (ISP za građanstvo, kompanija, univerzitet) ga ima • naziva se i “default name server” • kada računar pravi DNS upit, upit šalje svom lokalnom DNS serveru • ponaša se kao posrednik (proxy), prosljeđuje upit u hijerarhiju KPM - Aplikativni sloj i DNS 43
Primjer razrješavanja DNS imena root DNS server • Računar sa cis. poly. edu traži IP adresu za gaia. cs. umass. edu iterativni upit: • kontaktirani server odgovara sa imenom servera kog treba kontaktirati • “Ja ne znam ovo ime, ali pitaj ovaj server” 2 3 4 lokalni DNS server TLD DNS server 5 dns. poly. edu 1 8 računar koji traži 7 6 autoritativni DNS server dns. cs. umass. edu cis. poly. edu gaia. cs. umass. edu KPM - Aplikativni sloj i DNS 44
DNS iterativno ponašanje KPM - Aplikativni sloj i DNS 45
Primjer razrješavanja DNS imena root DNS server rekurzivni upit: 2 • stavlja teret razrješavanja imena na kontaktirani server imena • veliko opterećenje? 3 7 6 TLD DNS server lokalni DNS server dns. poly. edu 1 5 4 8 requesting host autoritativni DNS server dns. cs. umass. edu cis. poly. edu gaia. cs. umass. edu KPM - Aplikativni sloj i DNS 46
DNS odgovori na upite • Kada name server dobije upit na koji nema odgovor u lokalnoj bazi ili cache • Pita drugi name server i vraća dobiveni odgovor – rekurzivno ponašanje • Vraća adresu slijedećeg name servera kome treba biti upućem upit – iterativno ponašanje • Ako je pitanje postavio DNS klijenti (Resolver) – rekurzivno ponašanje • DNS serveri međusobno koriste i jedno i drugo – zavisno od upita i mogućnosti KPM - Aplikativni sloj i DNS 47
DNS hijerarhija • Podjela DNS stabla na nepreklapajuće zone • Zona – dio DNS stabla sa NS za tu zonu • Skup zapisa (RR) za zonu – autoritativan • Zona – proizvoljan broj hijerarhijskih nivoa • Neke (ili sve) grane iz zone – posebne zone KPM - Aplikativni sloj i DNS 48
Zone – Poslužitelji imena KPM - Aplikativni sloj i DNS 49
DNS: Root serveri imena • kontaktiraju ih lokalni server imena kad ne mogu “razrješiti” (resolve) ime • root server imena (u principu, ali ne i u praksi): • kontaktira autoritativni server imena ako ne zna mapiranje IP adrese za ime • dobiva mapiranje • vraća mapiranje lokalnom serveru imena a Verisign, Dulles, VA c Cogent, Herndon, VA (takođe LA) d U Maryland College Park, MD g US Do. D Vienna, VA h ARL Aberdeen, MD j Verisign, ( 21 lokacija) e NASA Mt View, CA f Internet Software C. Palo Alto, CA k RIPE London (i 16 drugih lokacija) i Autonomica, Stockholm (i 28 drugih lokacija) m WIDE Tokyo (takođe Seoul, Paris, SF) (i 36 drugih lokacija) 13 root servera diljem svijeta b USC-ISI Marina del Rey, CA l ICANN Los Angeles, CA KPM - Aplikativni sloj i DNS 50
Root name servers • 13 po cijelom svijetu (a-m. root-servers. net) • Replicirani zapisi o NS svih osnovnih domena • Prilično zauzeti • stotine miliona DNS upita dnevno • Njihove adrese u konfiguracijskim datotekama DNS servera • http: //www. internic. net/zones/named. root KPM - Aplikativni sloj i DNS 51
Root name serveri (1) Server Operator Locations IP Addresses A Veri. Sign, Inc. Sites: 5 B Information Sciences Institute Sites: 1 C Cogent Communications Sites: 8 IPv 4: 198. 41. 0. 4 IPv 6: 2001: 503: BA 3 E: : 2: 30 IPv 4: 192. 228. 79. 201 IPv 6: 2001: 478: 65: : 53 IPv 4: 192. 33. 4. 12 D University of Maryland Sites: 50 IPv 4: 128. 8. 10. 90 E NASA Ames Research Center Sites: 13 IPv 4: 192. 203. 230. 10 F Internet Systems Consortium, Inc. Sites: 57 G U. S. DOD Network Information Center Sites: 6 IPv 4: 192. 5. 5. 241 IPv 6: 2001: 500: 2 f: : f IPv 4: 192. 112. 36. 4 KPM - Aplikativni sloj i DNS 52
Root name serveri (2) Server Operator Locations IP Addresses H U. S. Army Research Lab Sites: 2 I Autonomica Sites: 41 J Veri. Sign, Inc. Sites: 61 K RIPE NCC Sites: 5 L ICANN Sites: 157 M WIDE Project Sites: 6 IPv 4: 128. 63. 2. 53 IPv 6: 2001: 500: 1: : 803 f: 235 IPv 4: 192. 36. 148. 17 IPv 6: 2001: 7 fe: : 53 IPv 4: 192. 58. 128. 30 IPv 6: 2001: 503: C 27: : 2: 30 IPv 4: 193. 0. 14. 129 IPv 6: 2001: 7 fd: : 1 IPv 4: 199. 7. 83. 42 IPv 6: 2001: 500: 3: : 42 IPv 4: 202. 12. 27. 33 IPv 6: 2001: dc 3: : 35 KPM - Aplikativni sloj i DNS 53
KPM - Aplikativni sloj i DNS 54
DNS protokol i poruke DNS protocol : upit i odgovor poruke, obje sa istim formatom poruka zaglavlje poruke • identification: 16 bitni broj upita, odgovor na upit koristi broj • flags: • upit ili odgovor • rekurzija poželjna • rekurzija dostupna • odgovor je autoritativan KPM - Aplikativni sloj i DNS 55
DNS protokol i poruke Name i type polja za upit RR-ovi, odgovor na upit zapisi o autoritativnim serverima dodatne “korisne” informacije KPM - Aplikativni sloj i DNS 56
Format DNS poruke KPM - Aplikativni sloj i DNS 57
Pretraga za www. etf. unsa. ba • Krenimo od Root Name Sever m KPM - Aplikativni sloj i DNS 58
Pretraga za www. etf. unsa. ba • Pitamo prvi na koji nas je Root uputio KPM - Aplikativni sloj i DNS 59
Pretraga za www. etf. unsa. ba • Pitamo konačno onaj koji tačno zna KPM - Aplikativni sloj i DNS 60
Umetanje zapisa u DNS • primjer: nova firma “Mrežna Utopija” • registruje ime mreznautopija. ba kod DNS registrara (npr. , UTIC) • daje imena i IP adrese autoritativnih servera imena (primarni i sekundarni) • registrar umeće dva RR u ba TLD server: (mreznautopija. ba, dns 1. mreznautopija. ba, NS) (dns 1. mreznautopija. ba, 212. 1, A) • pravi, na autoritativnom serveru, Type A zapis za www. mreznautopia. ba; i Type MX zapis za mreznautopia. ba • Kako ljudi dolaze do IP adrese naše Web lokacije? KPM - Aplikativni sloj i DNS 61
DNS: caching i ažuriranje zapisa • jednom kad (bilo koji) server imena nauči (neko) mapiranje, on cache-ira mapiranje • cache unosi ističu (nestaju) nakon nekog vremena • TLD serveri tipično cache-irani u lokalnim serverima imena • stoga root serveri imena se ne posjećuju (pre)često • mehanizam ažuriranja/notifikacije dizajnira IETF • RFC 2136 • http: //www. ietf. org/html. charters/dnsind-charter. html KPM - Aplikativni sloj i DNS 62
DNS predmemorisanje (cache) • Radi uštede vremena i mrežnih resursa dobiveni odgovori na DNS upite se pamte na određeno vrijeme (cache) na više mjesta u lancu upita • Aplikacije (Web preglednici) • OS • (Svi) Name server-i • Odgovor se pamti onoliko dugo koliko kaže TTL u odgovoru KPM - Aplikativni sloj i DNS 63
DNS server softveri • BIND – Prva UNIX implementacija, najčešći, 10 (11) root name servera koristi BIND • djbdns (Tiny. DNS) – sigurnost prije svega • Microsoft DNS (2000, 2003, 2008, NT 4) • NSD – 3 root name servera • Knot DNS – 2 root name servera (skupa sa NSD) KPM - Aplikativni sloj i DNS 64
Aplikativni sloj - rezime • aplikativne arhitekture • klijent-server • P 2 P • hibridna • specifični protokoli: – – – • zahtjevi aplikacija na usluge: – HTTP FTP SMTP, POP, IMAP DNS • pouzdanost, propusnost, kašnjenje • Internet transportni model usluga • konekciono orjentisani, pouzdani: TCP • nepouzdani, datagrami: UDP KPM - Aplikativni sloj i DNS 65
Aplikativni sloj – rezime (2) • tipična zahtjev/odgovor razmjena poruka: • klijent traži informaciju ili uslugu • server odgovara da podacima, statusnim kodom • formati poruka: Bitne teme: • kontrolne i podatkovne poruke – in-band, out-of-band • centralizovano ili decentralizovano • sa ili bez stanja • pouzdan ili ne prenos poruka • “kompleksnost na ivici mreže” • zaglavlja: polja daju informacije o podacima • podaci: informacija koja se prenosi KPM - Aplikativni sloj i DNS 66
Napomena • Dio slajdova zasnovan na slajdovima J. Kurose, K. Ross, “Computer Networking: A Top-Down Approach” • Hvala James and Keith KPM - Aplikativni sloj i DNS 67
Literatura • J. Kurose, K. Ross, “Computer Networking“, poglavlje 2. 1 i 2. 5 KPM - Aplikativni sloj i DNS 68