IDC HPC User Forum Panasas Update April 5

  • Slides: 15
Download presentation
IDC HPC User Forum Panasas Update April 5, 2011 Houston, TX

IDC HPC User Forum Panasas Update April 5, 2011 Houston, TX

Panasas Focused on Growth within HPC Markets Strong Financial Position • Five consecutive years

Panasas Focused on Growth within HPC Markets Strong Financial Position • Five consecutive years of revenue growth • 42% revenue growth in FY 10, year-over-year Revenue and Customer Growth Loyal, Brand Name Customers Revenue • >75% repeat buyers Active Customers Global Presence • >300 active customers in over 50 countries 2006 2007 2008 2009 Est 2010 Expecting 50% Headcount Increase in 2011 Worldwide support with over 25 global resellers

Panasas® PAS 12 Hardware • 4 U chassis (eleven blades) houses up to 40

Panasas® PAS 12 Hardware • 4 U chassis (eleven blades) houses up to 40 TB of storage at 1. 5 GB/s performance throughput • 10 chassis per standard 40 U rack – 400 TB/15 GB/s per rack • Blades are form, fit, function backward compatible – investment protection Performance • Aggregate performance scales from 1. 5 GB/s to a staggering 150 GB/s, the industry’s highest per gigabyte performance Capacity • Expansion from 40 TB to 4 PB in 40 TB increments Scalability • Add blades, chassis, or entire racks, without system disruption, to extend performance and capacity. Additional capacity is self configured. • Blades are managed in a global namespace and can be easily networked to create extremely large storage pools 3

Unprecedented Performance and Scale with Parallel Architecture

Unprecedented Performance and Scale with Parallel Architecture

Why a Standard for Parallel I/O? NFS is the only network file system standard

Why a Standard for Parallel I/O? NFS is the only network file system standard • Proprietary file systems have unique advantages, but aren’t right for everyone NFS widens the playing field • Panasas, IBM, EMC want to bring their experience in large scale, high-performance file systems into the NFS community • Sun/Oracle and Net. App want a standard HPC solution • Broader market benefits vendors • More competition benefits customers What about open source • NFSv 4 Linux client is very important for NFSv 4 adoption, and therefore p. NFS • Still need vendors that are willing to do the heavy lifting required in quality assurance for mission critical storage

NFSv 4 and p. NFS originally created in ’ 80 s to share data

NFSv 4 and p. NFS originally created in ’ 80 s to share data among engineering workstations NFSv 3 widely deployed NFSv 4 several years in the making • Integrated Kerberos (or PKI) user authentication • Integrated File Locking and Open Delegations (stateful server!) • ACLs (hybrid of Windows and POSIX models) • Official path to add (optional) extensions NFSv 4. 1 adds even more • p. NFS for parallel I/O • Directory Delegations for efficiency • RPC Sessions for robustness, better RDMA support

p. NFS: Standard Storage Clusters p. NFS is an extension to the Network File

p. NFS: Standard Storage Clusters p. NFS is an extension to the Network File System v 4 protocol standard Allows for parallel and direct access • From Parallel Network File System clients • To Storage Devices over multiple storage protocols • Moves the NFS (metadata) server out of the data path data p. NFS Clients met ad ata l tro n o c NFSv 4. 1 Server Block (FC) / Object (OSD) / File (NFS) Storage

The p. NFS Standard The p. NFS standard defines the NFSv 4. 1 protocol

The p. NFS Standard The p. NFS standard defines the NFSv 4. 1 protocol extensions between the server and client The I/O protocol between the client and storage is specified elsewhere, for example: • SCSI Block Commands (SBC) over Fibre Channel (FC) • SCSI Object-based Storage Device (OSD) over i. SCSI • Network File System (NFS) The control protocol between the server and storage devices is also specified elsewhere, for example: • SCSI Object-based Storage Device (OSD) over i. SCSI Client Storage Meta. Data Server

p. NFS Layouts Client gets a layout from the NFS Server The layout maps

p. NFS Layouts Client gets a layout from the NFS Server The layout maps the file onto storage devices and addresses The client uses the layout to perform direct I/O to storage At any time the server can recall the layout Client commits changes and returns the layout when it’s done p. NFS is optional, the client can always use regular NFSv 4 I/O layout Storage Clients NFSv 4. 1 Server

p. NFS Client Common client for different storage back ends Wider availability across operating

p. NFS Client Common client for different storage back ends Wider availability across operating systems Fewer support issues for storage vendors Client Apps p. NFS Client Layout Driver NFSv 4. 1 p. NFS Server Layout metadata grant & revoke Cluster Filesystem 1. SBC (blocks) 2. OSD (objects) 3. NFS (files) 4. PVFS 2 (files) 5. Future backend…

Key p. NFS Participants Panasas (Objects) ORNL and ESSC/Do. D funding Linux p. NFS

Key p. NFS Participants Panasas (Objects) ORNL and ESSC/Do. D funding Linux p. NFS development Network Appliance (Files over NFSv 4) IBM (Files, based on GPFS) Blue. Arc (Files over NFSv 4) EMC (Blocks, High. Road MPFSi) Sun/Oracle (Files over NFSv 4) U of Michigan/CITI (Linux maint. , EMC and Microsoft contracts) DESY – Java-based implementation

p. NFS Standard Status IETF approved Internet Drafts in December 2008 RFCs for NFSv

p. NFS Standard Status IETF approved Internet Drafts in December 2008 RFCs for NFSv 4. 1, p. NFS-objects, and p. NFS-blocks published January 2010 • RFC 5661 - Network File System (NFS) Version 4 Minor Version 1 Protocol • RFC 5662 - Network File System (NFS) Version 4 Minor Version 1 External Data Representation Standard (XDR) Description • RFC 5663 - Parallel NFS (p. NFS) Block/Volume Layout • RFC 5664 - Object-Based Parallel NFS (p. NFS) Operations 12

p. NFS Implementation Status NFSv 4. 1 mandatory features have priority • • RPC

p. NFS Implementation Status NFSv 4. 1 mandatory features have priority • • RPC session layer giving reliable at-most-once semantics, channel bonding, RDMA Server callback channel Server crash recovery Other details EXOFS object-based file system (file system over OSD) • • In kernel module since 2. 6. 29 (2008) Export of this file system via p. NFS server protocols Simple striping (RAID-0), mirroring (RAID-1), and RAID-5 “Most stable and scalable implementation” Files (NFSv 4 data server) implementation • • Open source server based on GFS Layout recall not required due to nature of underlying cluster file system Blocks implementation • • Server in user-level process, Ganesha/NFS support desirable Sponsored by EMC

Linux Release Cycle Kernel Merge Window Date What’s New 2. 6. 30 Mar 2009

Linux Release Cycle Kernel Merge Window Date What’s New 2. 6. 30 Mar 2009 RPC sessions, NVSv 4. 1 server, OSDv 2 rev 5, EXOFS 2. 6. 31 June 2009 NFSv 4. 1 client, sans p. NFS 2. 6. 32 Sep 2009 130 server-side patches add back-channel 2. 6. 33 Dec 2009 43 p. NFS patches 2. 6. 34 Feb 2010 21 NFS 4. 1 patches 2. 6. 35 May 2010 1 client and 1 server patch (4. 1 support) 2. 6. 36 Aug 2010 16 patches 2. 6. 37 Nov 2010 First chunk of p. NFS beyond generic 4. 1 infrastructure. Disabled for now. 2. 6. xx 2011 250 p. NFS patches including remaining files-based p. NFS patches, object-based p. NFS, block-based p. NFS Then comes Linux distribution support…

A Few Predictions p. NFS will be in production use in 2012, fully supported

A Few Predictions p. NFS will be in production use in 2012, fully supported by major Linux distributions and by leading storage vendors (including Panasas) Proprietary protocols like Direct. Flow will continue to provide higher performance and reliability advantages for some time as p. NFS matures p. NFS will see most of its early adoption within HPC, especially in NFS environments Storage systems leveraging p. NFS objects will be the ones capable of delivering the highest parallel file system performance p. NFS will eventually make parallel file systems commonplace