drafttiruveedhulamplsmldpmib02 Definitions of Managed Objects for the LDP
draft-tiruveedhula-mpls-mldp-mib-02 Definitions of Managed Objects for the LDP Point-to-Multipoint and Multipoint-to-Multipoint Label Switched Paths draft-tiruveedhula-mpls-mldp-mib-02 Kishore Tiruveedhula (kishoret@juniper. net ) Uwe Joorde (Uwe. Joorde@telekom. de) Arvind Venkateswaran (arvvenka@cisco. com ) Presenter: Vishnu Pavan Beeram (vbeeram@juniper. net ) IETF 89 – London, England, March 2014 1
draft-tiruveedhula-mpls-mldp-mib-02 m. LDP MIB • Extensions to LDP MIB (RFC 3815) • Need MIB support for – – p 2 mp and mp 2 mp LDP LSPs (RFC 6388). m. LDP inband signaling (RFC 6826). m. LDP Mo. FRR (draft-ietf-rtgwg-mofrr-03). m. LDP Node protection (draft-ietf-mpls-mldp-nodeprotection-00. txt). – m. LDP traffic statistics. IETF 89 – London, England, March 2014 2
draft-tiruveedhula-mpls-mldp-mib-02 Scalar Objects • • • mpls. Mldp. P 2 mp. Capable mpls. Mldp. Mp 2 mp. Capable mpls. Mldp. Mbb. Time mpls. Mldp. Num. Fecs. Active mpls. Mldp. Plr. Capable mpls. Mldp. Mpt. Capable mpls. Mldp. Prot. Lsr. Capable mpls. Mldp. Node. Prot. Capable IETF 89 – London, England, March 2014 3
draft-tiruveedhula-mpls-mldp-mib-02 m. LDP Tables – LDP Peer Capability Table: mpls. Ldp. Peer. Capability. Table – m. LDP Session Stats Table: mpls. Mldp. Session. Stats. Table – m. LDP Fec Table: mpls. Mldp. Fec. Table – m. LDP Fec Branch Traffic statistics Table: mpls. Mldp. Fec. Branch. Stats. Table – m. LDP Fec Upstream Session Table: mpls. Mldp. Fec. Upstream. Sess. Table – m. LDP Interface Traffic statistics Table: mpls. Mldp. Interface. Stats. Table IETF 89 – London, England, March 2014 4
draft-tiruveedhula-mpls-mldp-mib-02 Notifications – mpls. Mldp. Fec. Up – mpls. Mldp. Fec. Down IETF 89 – London, England, March 2014 5
draft-tiruveedhula-mpls-mldp-mib-02 Relationship to LDP/LSR MIB mpls. Ldp. Peer. Capability. Table mpls. Ldp. Peer. Table mpls. Ldp. Session. Stats. Table mpls. Mldp. Fec. Table mpls. Ldp. Lsp. Fec. Table mpls. XCTable mpls. In. Segment. Table mpls. Mldp. Fec. Upstream. Sess. Table mpls. Out. Segment. Table mpls. Mldp. Fec. Branch. Stats. Table if. Table Existing tables mpls. Mldp. Interface. Stats. Table New tables IETF 89 – London, England, March 2014 6
draft-tiruveedhula-mpls-mldp-mib-02 Next Steps • Solicit feedback – Vendors – Operators • Any missing m. LDP features? IETF 89 – London, England, March 2014 7
- Slides: 7