CS 690 b Presentation Multimedia Network Implementation DataVoice
CS 690 b Presentation Multimedia Network Implementation - Data/Voice Convergence Xianfeng Zeng ( zxf@cs. purdue. edu ) Department of Computer Sciences Purdue University April 1, 1999
Agenda • Overview • Data/Voice Convergence Technologies • Problems • Summary
Why Voice/Data Convergence ? • Huge growth of Data/IP WAN traffic • Integrated Networks is cheaper to manage • Shared infrastructure - redundancy • Voice Processing is now economical – Voice compression algorithms give good quality at 8 Kbps and DSPs have come down in price – Potential for reducing WAN costs integrating Voice and Data • Standards and Deregulation are here or are close – Voice over ATM, Voice over Frame Relay, Voice over IP – Voice compression, echo, jitter, etc. .
Multiservice Evolution PSTN/VPN VPN Legacy Data Frame Relay TDM Private ATM Internet Remote Access Source: Gartner Group Enhanced FR/ATM Public IP Enhanced Public IP 1997 - 1998 1999 - 2000 Integrated Single Network Fabric 2000+
PSTN Access over IP Service SS 7 Signalling allows Carrier Scalability (and reduces cost) IP Access Server Q. 931 Phone 3600 SS 7 Signalling PABX Local Exchange Trunk Interface Trunk Exchange PSTN
Applications and Services Phone-to-Phone 3600/2600 FXS Intranet Milano Roma PBX Trunking 2600/3600/5300 E&M E 1 Intranet Key System Milano Roma PBX
Applications and Services Real-Time Fax to Fax 2600/3600 FXS FXO Intranet Londra Milano Computer or Ether. Phone to PSTN H. 323 Software H. 323 Gateway Ethernet 2600/3600/5300 PSTN
Applications and Services Toll Bypass Milano Roma Qo. S IP Wan PSTN Residential & Business PSTN Local Calls Residential & Business
PBX Extension 3640 V PBX PSTN Qo. S WAN (Intranet) V 3640 Branch Office Headquarters
Challenge • Have to understand both Voice networking and Data networking • Developing Qo. S networks and functionality • Voice quality is hard to guarantee • Need solutions (architecture) to move Voice from analog to data network quicker
The Service Challenge Feature Transparency IP/FR/ATM Network Via PBX or PSTN Service Interworking IP Network F E FRAD FR Network PSTN & PBX Network B A C ATM Network Interworking unit D Billing System
Packet to PSTN Gateway Forecast Source: Frost & Sullivan; Internet Telephony Product Markets; #5637 -60
Voice Quality: Compression Standards Unacceptable Utility Business Toll 64 48 40 32 Bandwidth (kbps) 56 Cellular Voice ADPCM 32 (G. 723) ASPCM 24 (G. 725) 24 ADPCM 16 (G. 726) 16 8 LPC 4. 8 PCM LDCELP 16 (G. 728) CS-ACELP 8 (G. 729) 0 Quality
Quality/Delay Issue One Way Delay (msec) Description 0– 150 Acceptable for Most User Applications 150– 400 Acceptable Provided that Administrations Are Aware of the Transmission Time Impact on the Transmission Quality of User Applications 400+ Unacceptable for General Network Planning Purposes; However, it Is Recognized that in Some Exceptional Cases this Limit will Be Exceeded ITU G. 114 Recommendation
Voice over ATM/FR/IP - 1997 Scalability/ Performances ATM IP IP Campus TDM MAN Infrastructure Access FR
Voice over ATM/FR/IP - 1999 Scalability/ Performances ATM IP FR TDM Campus MAN Infrastructure Access
Standards & Organizations • ITU-T—H. 323 • IMTC—Vo. IP ( International Multimedia Teleconferencing Consortium) • IETF—RSVP, WFQ, RED, RTP • FRF—Vo. FR FRF. 11 FRF. 12
Voice Technologies/Standards Status G. 711 ITU-T recommendation (1988)— Pulse Code Modulation (PCM) of voice frequencies G. 723. 1 ITU-T recommendation (3/96)—Dual Rate Speech encoder for multimedia connections transmitting at 5. 3 and 6. 3 kbit/s G. 729 ITU-T recommendation (3/96)—Coding of speech at 8 kbit/s using conjugate-structure algebraic-code-excited linearprediction Q. 931 ITU-T recommendation (3/93)—Digital Subscriber signalling System No. 1 (DSS 1)—ISDN user network interface Layer 3 specification for basic call control Q. 931 bis ITU -T recommendation (2/95)—PICS and abstract test suite for ISDN DSS 1 Layer 3—Circuit and Circuit mode, basic call control conformance testing 72
Voice over IP Protocols Presentation Session G. 729(A)/G. 723(. 1)/G. 711 H. 323/H. 323 Gateway/SIP/SDP Transport RTP/UDP/RSVP Network IP/WFQ/IP-prec Link Physical MLPPP/FR/ATM AAL 1 – – –
Content of a Conversation Essential Components 22% Repetitive 22% Pauses 56% Over half of the typical voice call is silence!
Vo. IP Technologies/Standards Status H. 323 ITU-T Recommendation (11/96)—Visual Telephone Systems and Equipment for Local Area Networks Which Provide a Non-Guaranteed Quality of Service H. 245 ITU-T Recommendation (3/96)—Control Protocol for Multimedia Communications RFC 1889 IETF RFC 1889 RTP: A Transport Protocol for Real-Time Applications RFC 1717 IETF RFC 1717 MP: The PPP Multilink Protocol RFC 1990 IETF RFC 1990 MP: The PPP Multilink Protocol Obsoletes RFC 1717 IETF Draft RSVP - Resource Re. Ser. Vation Protocol (RSVP)— Version 1 Functional Specification 0090_08 F 8_c 1 873301 -01 75
RTP - RFC 1889 • RTP “ Real-time Transfer Protocol “ – Small, real time data packets - Connectionless environment • RTCP “ Real-time Transfer Control Protocol “ – Provides feedback on current network conditions
H. 323 Interoperability I-Phone H. 323 S/W PBX PSTN Residential PBX 4 to 12 Analog ports Qo. S WAN (Intranet) 3620 V V 3640 I-Phone H. 323 S/W Branch Office Headquarters • H. 323 Vo. IP local loop bypass • Integrated messaging: e-mail, v-mail, fax mail • Interoperability with Net. Meeting, etc.
H. 323 Networking H. 323 Terminal H. 323 MCU H. 323 Terminal Scope of H. 323 WAN RSVP H. 323 Gatekeeper H. 323 Gateway PSTN V. 70 Terminal H. 324 Terminal H. 323 Terminal ISDN Speech Terminal H. 320 Terminal Speech Terminal
H. 323 Terminal Characteristics System Control and User Interface Video I/O Equipment Audio I/O Equipment Video Codec H. 261, H 263 Audio Codec G. 711, G. 722, G. 723, G. 723. 1, G. 728, G. 729 System Control H. 245 Control Call Control H. 225. 0 RAS Control H. 225. 0 Receive Path Delay H. 225. 0 Layer LAN Stack User Data Applications T. 120 Scope of H. 323
Gatekeeper Functions • Mandatory services: – – Address translation Admissions control Bandwidth control Zone management • Optional services: – Call control signalling – Call authorization – Bandwidth management and reservation – Call management – Gatekeeper management information data structure – Directory services
Public Vo. IP Service Using Packet Gateways ISP “A” Settlement Provider Local PSTN (Trusted 3 rd Party) Authentication, Call Routing, Billing and Settlement Server V Qo. S Interconnect (or Internet) POP (i) ISP “A” Backbone V POP (ii) Local PSTN ISP “B” Backbone Local PSTN V
Vo. IP Packet Gateway Roadmap Enterprise Qo. S WAN 3600 Today G. 729, Group 3 Fax, RTP, RSVP IP over Frame Relay, Leased Lines, ISDN or other WAN links V V 3600 PSTN Analog Voice Interfaces Trials Q 1’ 98 3600 Qo. S WAN V V Digital (T 1/E 1/PRI) Voice Interfaces Digital (BRI) Voice Interfaces Service Provider Trials Q 1’ 98 I-Phone POTS Phone Residential PSTN Internet V H. 323 Interoperability Internet Service Provider
H. 323 Interoperability - H. 323 Vo. IP Local Loop Bypass - Resendential and business services - Interoperability with Net. Meeting type programs Business PBX PSTN PBX I-Phone H. 323 S/W V Router + Vo. IP Local PSTN I-Phone H. 323 S/W Qo. S WAN POP Internet Residential I-Phone H. 323 S/W Residential x. DSL XDSL Modem 2 nd line phone DSLA M Local PSTN V Central Office
Vo. IP Voice Compression VAD etc. PCM CODER G. 711 64 Kbps FXS Voice Card G. 729 r 8 8 Kbps
Quality Policies G. 729 r 8 8 Kbps Packetizazion Quality/Class of Service RTP Header Compression Plus Quality Standard Best Effort Weighted Fair Queuing, IP Precedence RSVP, ecc. IP WAN Link FXS Voice Card
Voice Integration Small PBX, POTS 2 Analog Fax Qo. S WAN PBX V Cisco 3600 Remote Branch Plus Quality Standard Best Effort PSTN Central Headquarter
Jitter - Delay Variation Sender Receiver Network B A C Sender Transmits t A D 1 B D 2 = D 1 C D 3 = D 2 Sink Receives t • RTP timestamp for jitter estimation • Adaptive jitter buffers in end points
Line Protocol Problem Voice Packet FTP Session Time to : • High Priority Queue Empty • The Router starts sending packet from another queue 1500 bytes take 187 ms at 64 K Jumbogram FTP Session Link IP WAN
Line Protocol Problem Voice Packet FTP Session Time t 1 : • New RTP Packets Come • It has to wait the FTP Jumbogram to be sent 1500 bytes take 187 ms at 64 K Vo. IP Jumbogram FTP Session Link IP WAN
Multilink PPP Interleave Voice Packet FTP Session Time to : • High Priority Queue Empty • The Router starts sending packet fragments from another queue FTP Link IP WAN FTP
Multilink PPP Interleave Voice Packet FTP Session Time t 1 : • New RTP Packets Come • They are INTERLEAVED between FTP fragments “ INTERLEAVED ” Vo. IP FTP Link IP WAN Vo. IP FTP
Algorithm Vo. IP FTP Jumbogram FTP Session Vo. IP FTP • Fragment large packets • Let small packets: Use normal encapsulation Interleave with fragmented traffic
RTP Compression G. 729 r 8 8 Kbps 20 ms 20 bytes IP Payload 12 bytes RTP 8 bytes UDP 20 bytes Payload 20 bytes IP Header 40 bytes Header
RTP Compression G. 729 r 8 8 Kbps 20 ms 40 bytes Header 20 bytes IP Payload 12 bytes RTP 8 bytes UDP 20 bytes IP Header Real Time Protocol Header Compression 20 bytes IP Payload 23 -25 bytes 20 msec 3 -5 bytes 9, 2 Kbps
Network Architecture Access POP Backbone POP Edge Functions POP Solutions require cooperative edge and backbone functions. POP Backbone Functions Customer access aggregation High speed transport Policy Application Security Packet classification Admission Control Queuing Congestion management Services & traffic metering Queue management Policy enforcement Traffic management
Packet Classification Policy Specification Network Edge Packet Classifier Backbone Layer 3 CAR Filter Customer Premise RSVP Multimedia • Up to 6 Traffic Classes via TOS bits • Classification by Port, IP Address, or Application Port • Network or Customer Assignment Mission-Critical Drop 3 rd 2 nd 1 st Per Application CAR
CAR Policy Examples Drop 1 st 2 nd CAR + Premium Firm CAR Drop RSVP Multimedia Drop 3 rd 2 nd 1 st Mission-Critical 2 nd 1 st CAR & Best Effort Per Application CAR
The Problem of Congestion Throughput Managed Congestion Uncontrolled Congestion Offered Load Congestion Management Goals • Max Goodput and Min. Delay • Scale to High Speed Nets • Fairness • Accommodates IP Burstiness • Preserves Traffic Classes • Avoids Global Synchronization
Number of Packets Discarded WRED Service Profile Example Two service levels are shown; up to 6 can be defined. Standard Service Profile “Slope” is adjustable Queue Length Std Min. Premium Service Profile Std Max Premium Max
Putting it All Together Solutions require cooperative edge and backbone functions Access High Standard Low Core L 3 CAR Ingress rate thresholds. L 3 CAR WRED/WFQ Determine packet class Administer packet class Egressrate thresholds
Multimedia Conference Manager Gatekeeper Proxy • Zone definition • Supported ASR interfaces • Bandwidth management • Qo. S • Authentication • Limit H. 323 traffic on the WAN • Making calls with in a zone • Security • Making calls to H. 323 devices out side the Gatekeeper Zone • Remote zone Gatekeeper lookup • Accounting • Address resolution * H. 323 Multimedia Conference Manager is implemented on Cisco IOS
H. 323 Infrastructure Gatekeeper Client H. 323 Corp LAN Router Gateway Proxy Gatekeeper H. 320 (Over ISDN) Internet Real-time Network Telephone Network H. 324 (Over POTs) Speech Only (Telephone) H. 323
H. 323 Signaling Admission Request RAS H. 323 Admission Confirm Gatekeeper Setup Connect Q. 931 H. 323 Capabilities Exchange Open Logical Channel H. 245 Open Logical Channel Acknowledge RTP Stream RTCP Stream Media
- Slides: 49