3 GPP IMS Emergency Calls Stage 3 Update









- Slides: 9
3 GPP IMS Emergency Calls Stage 3 Update Georg Mayer 1 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials
3 GPP IMS Emergency Calls – Status 10/2008 • IMS Emergency Calls have been added in 3 GPP Rel-7 • Before: only fall-back to CS emergency all • Based on IETF specifications and 3 GPP architecture (TS 23. 167, TS 22. 101) • Special treatment of e-calls from visited network • Special requirements due to PSAPs located in PSTN • Still • Rel-7 is frozen since December 2007 • Major change since then: Removal of Emergency IMPU (see Milan Patels presentation) • No news on IMS Emergency Calls in Rel-8 • EPS (also known as SAE/LTE) added as an IMS access network 2 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials
IMS Emergency Calls Beyond Rel-8 • Further alignment with latest IETF progress • E. g. how to handle e-calls from pure RFC 3261 clients via IMS • E. g. role of LOST protocol • Emergency Calls in Session Continutiy cases • e. g. ongoing e-call whilst user walks out of IMS coverage and call is transferred to CS domain or to different IMS access network (e. g. GRPS -> I-WLAN) • Especially interesting when new 3 GPP EPS is used as access network • Further issues may come up • Currently these issues are not discussed on a stage 3 (protocol) level 3 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials
Basic 3 GPP IMS Architecture for Emergency Calls Specified emergency categories Fixed Broadband Access PSAP= Public Safety Answering Point 112 WLAN 3 GPP IP access 3 GPP IMS core PSAP Emergency Control Centre IWF GPRS access PSTN/ CS core 3 GPP LTE access 4 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials Emergency Control Centre h p f
IETF Specifications used for IMS Emergency Calls • Basic SIP specifications, such as RFC 3261 • RFC 4119 – A Presence-based GEOPRIV Location Object Format • RFC 5031 – A Uniform Resource Name (URN) for Services • draft-ietf-sip-location-conveyance – Location Conveyance for SIP • draft-holmberg-sip-keep – Indication of support for keep-alive 5 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials
Entities • UE (SIP: UA) • Initiates e-calls, if necessary also e-registration • May receive callbacks from PSAP • P-CSCF (SIP: Outbound Proxy) • Detects whether call is subject to emergecny treatment • Rejects e-calls if UE should e. g. use CS domain • Forwards e-calls to the E-CSCF • S-CSCF (SIP: Registrar, Home Service Proxy) • Registration of the user / always locates in users home network • Call-backs from PSAP take place via home network • E-CSCF • Routing to PSAP (based on e-URN, location information, etc. ) • Can query LRF (Location Function in 3 G networks) for user location information • PSAP • No 3 GPP specific requirements • MGCF / MGW (Interworking between IMS / CS) • No additional requirements due to e-calls 6 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials
Emergency Registration and Emergency Call GGSN in Home Network n tio S er ge nc y. R eg ist ra I Em No co n em mm e un rge ica nc ito y n P Emergency Call P E Emergency CSCF Visited Network IMS Emergency APN 7 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials Public Safety Answering Point (PSAP)
Emergency Registration and Initiating the E-Call • If UE detects, that emergency call needs to be made (based on dialled number / URI), it shall • Detect whether to use CS or IMS domain (based on operator preference) • If connected to home network and already IMS registered • Start IMS emergency call directly • If connected to home network and not registered • Perform emergency registration • Perform emergency call • If connected to visited network (roaming) • Perform emergency registration with home network • Perform emergency call via visited network • Emergency Calls for unregistered users are possible • P-CSCF can reject INVITE requests from the UE with 380 (Alternative Service) response, including a 3 GPP specific XML document, which can indicate: • that the UE shall use the CS domain to perform the emergency call • that the UE shall perform IMS emergency registration before emergency call 8 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials
Thank You! • http: //www. 3 gpp. org 9 © 2008 Nokia V 1 -Filename. ppt / YYYY-MM-DD / Initials